Search found 6 matches

by GemX
Wed Jan 11, 2012 10:18 am
Forum: Help
Topic: OgreView doesn't render anything (Cocoa+FSAA RenderTarget)
Replies: 10
Views: 864

Re: OgreView doesn't render anything (Cocoa+FSAA RenderTarge

creating a texture manually and setting texture usage as TU_RENDERTARGET. TexturePtr texture = TextureManager::getSingleton().createManual(targetName, resourceGroupName, TEX_TYPE_2D, width, height, 0, pf, TU_RENDERTARGET, 0, false, fsaa); // pf is B8G8R8A8 texture->setMipmap(0); // targets are alway...
by GemX
Tue Jan 10, 2012 5:58 pm
Forum: Help
Topic: OgreView doesn't render anything (Cocoa+FSAA RenderTarget)
Replies: 10
Views: 864

Re: OgreView doesn't render anything (Cocoa+FSAA RenderTarge

Hi Masterfalcon, I have tried both versions of Ogre (1.7 & 1.8RC), and both of them fail to render anything on a screen window as soon as FSAA is enabled on any render target. The same code renders perfect on a Windows machine. So it seems to me that there is a bug in the OSX version (maybe Ogre...
by GemX
Thu Sep 15, 2011 9:10 am
Forum: Help
Topic: OgreView doesn't render anything (Cocoa+FSAA RenderTarget)
Replies: 10
Views: 864

Re: OgreView doesn't render anything (Cocoa+FSAA RenderTarge

It's 1.7.2. I have a built version and one from the mecurial repository.
by GemX
Wed Sep 07, 2011 1:30 pm
Forum: Help
Topic: OgreView doesn't render anything (Cocoa+FSAA RenderTarget)
Replies: 10
Views: 864

OgreView doesn't render anything (Cocoa+FSAA RenderTarget)

Hi all, I have an application and rendering in an OgreView under Cocoa (MacOS 10.6). I have some RenderTargets defined. As soon as I enable anti-aliasing on any of them (FSAA>0) the OgerView keeps the Cocoa gray color and nothing is rendered in the view. Although the content of the RenderTarget is c...
by GemX
Wed Jul 20, 2011 10:52 am
Forum: Help
Topic: OgreBites button caption doesn't appear
Replies: 17
Views: 3987

Re: OgreBites button caption doesn't appear

Try using this: // load fonts explicitly after resources are loaded (esp. SdkTray.zip) since they will not be loaded on start up from the resource manager ResourceManager::ResourceMapIterator iter = Ogre::FontManager::getSingleton().getResourceIterator(); while (iter.hasMoreElements()) { iter.getNex...
by GemX
Wed Jul 20, 2011 10:51 am
Forum: Developer talk
Topic: Cannot display TextArea in single Panel
Replies: 18
Views: 9231

Re: Cannot display TextArea in single Panel

Try using this: // load fonts explicitly after resources are loaded (esp. SdkTray.zip) since they will not be loaded on start up from the resource manager ResourceManager::ResourceMapIterator iter = Ogre::FontManager::getSingleton().getResourceIterator(); while (iter.hasMoreElements()) { iter.getNex...

Go to advanced search