New CeguiMeshViewer 1.2 - 1.4 Compatible (binary and source)

Anything and everything that's related to OGRE or the wider graphics field that doesn't fit into the other forums.
OvermindDL1
Gnome
Posts: 333
Joined: Sun Sep 25, 2005 7:55 pm
Contact:

Postby OvermindDL1 » Thu Apr 13, 2006 11:24 pm

The input classes in Ogre were not really designed to be used, they were designed to be *just* useful enough for the demo's to work, ergo it does not support anything even partially advanced as that. OIS however, is designed for pure input.
0 x

Bolt
Gnoblar
Posts: 14
Joined: Mon May 22, 2006 11:24 pm

Postby Bolt » Fri May 26, 2006 7:24 pm

Just one question:
Why is mouse cursor movement so slow and sluggish for me?

Tried reducing color depth and resolution, and still sluggish.
Full-screen or windowed doesn't matter either.
0 x

User avatar
neocryptek
Gnome
Posts: 335
Joined: Sat Mar 01, 2003 11:21 pm
Location: Idaho, USA
Contact:

Postby neocryptek » Fri May 26, 2006 7:54 pm

Bolt wrote:Just one question:
Why is mouse cursor movement so slow and sluggish for me?

Tried reducing color depth and resolution, and still sluggish.
Full-screen or windowed doesn't matter either.

Sluggish as in sensitivity or as in not capturing fast enough (low FPS)?
Implimenting a hardware cursor would probably solve both (as well as the previous 'lock the mouse' statements).
0 x

Bolt
Gnoblar
Posts: 14
Joined: Mon May 22, 2006 11:24 pm

Postby Bolt » Fri May 26, 2006 10:15 pm

Sluggish as compared to my desktop cursor movement. The OGRE viewer cursor is much slower,
almost unbearable. Is any of this configurable?
0 x

User avatar
neocryptek
Gnome
Posts: 335
Joined: Sat Mar 01, 2003 11:21 pm
Location: Idaho, USA
Contact:

Postby neocryptek » Mon May 29, 2006 3:52 am

Bolt wrote:Sluggish as compared to my desktop cursor movement. The OGRE viewer cursor is much slower,
almost unbearable. Is any of this configurable?

Yeah, that is just sensitivity then. The viewer is probably hard coded sensitivity wise just to simplify things.

Easiest way to compensate for that is to implement a hardware cursor, which would inherently use your desktop cursor sensitivity.

You could submit a patch to Tuan Kuranes ;).
0 x

zeroflag
Goblin
Posts: 247
Joined: Mon Apr 03, 2006 3:48 pm

Postby zeroflag » Mon May 29, 2006 1:14 pm

uhm

Code: Select all

13:50:37: An exception has been thrown!

-----------------------------------
Details:
-----------------------------------
Error #: -2005532292
Function: D3D9Texture::_createNormTex
Description: Error creating texture.
File: ..\src\OgreD3D9Texture.cpp
Line: 505
Stack unwinding: <<beginning of stack>>
13:50:38: *-*-* OGRE Shutdown


when I run it with OpenGL I get a hard crash (access violation)...

this PC here doesn't have any good 3D card installed but I got some of the ogre tutorials and even stuntplayground to run just fine... so what's wrong with this one?
0 x

User avatar
tuan kuranes
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 2653
Joined: Wed Sep 24, 2003 8:07 am
Location: Haute Garonne, France
Contact:

Postby tuan kuranes » Tue May 30, 2006 9:17 am

what's wrong with this one?

No D7D renderer in this one.
When do you get this error ?
As it may load shader based material, It tries to do things the card doesn't support, even if it lies about it (Intel card does that.)

BTW it is now in Ograddons, as official meshviewer, so any patch is welcome.
0 x

zeroflag
Goblin
Posts: 247
Joined: Mon Apr 03, 2006 3:48 pm

Postby zeroflag » Tue May 30, 2006 9:40 am

tuan kuranes wrote:
what's wrong with this one?

No D7D renderer in this one.
When do you get this error ?
As it may load shader based material, It tries to do things the card doesn't support, even if it lies about it (Intel card does that.)

it happens druing initialization... I get the config window and the ogre window, then it seems to load the resources and crashes...
and I think there's an intel onboard graphics chip in the machine. :(

any way to work arround it?

I tried the source code but didn't even get it to compile... you are once again using very strange folders... where am I supposed to unpack the source?

regards.
0 x

User avatar
tuan kuranes
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 2653
Joined: Wed Sep 24, 2003 8:07 am
Location: Haute Garonne, France
Contact:

Postby tuan kuranes » Tue May 30, 2006 9:59 am

any way to work arround it?

you have to disable resource loading at startup and only load group you want/can load.

I tried the source code but didn't even get it to compile.

Try CVS version. Ogreaddons cvs version is made to work without having to move it.
0 x

zeroflag
Goblin
Posts: 247
Joined: Mon Apr 03, 2006 3:48 pm

Postby zeroflag » Tue May 30, 2006 10:05 am

I tried the source code but didn't even get it to compile.

Try CVS version. Ogreaddons cvs version is made to work without having to move it.


CVS doesn't seem to work with the proxy here... :(

guess I gotta get the source when I'm home...
0 x

User avatar
xabila
Goblin
Posts: 225
Joined: Mon Jun 05, 2006 9:40 am
Location: rennes [FR]

Postby xabila » Wed Jun 14, 2006 2:30 pm

Hello all,

I tried to port this ceguimeshviewer to Linux.
I mostly renamed files (like usually the cass problem ) and put the tinyxml on a namespace (because CEGUIBase is including tinyxml.h, and the xml/tinyxml.h is not exactly the same ...).

I have a last problem with an exception on CEGUI :

---- Beginning loading of GUI layout from 'meshviewer.layout' ----
(InfL2) Window 'root' of type 'DefaultWindow' has been created.
(Error) Exception: WindowFactoryManager::getFactory - A WindowFactory object, an alias, or mapping for 'Falagard/Combobox' Window objects is not registered with the system.
(InfL2) Window 'root' has been added to dead pool.
(Error) Exception: GUILayout_xmlHandler::startElement - layout loading has been aborted since no WindowFactory is available for 'Marti/Combobox' objects.
(Error) WindowManager::loadWindowLayout - loading of layout from file 'meshviewer.layout' failed.

Any idea about that ?

Thanks
0 x

User avatar
tuan kuranes
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 2653
Joined: Wed Sep 24, 2003 8:07 am
Location: Haute Garonne, France
Contact:

Postby tuan kuranes » Wed Jun 14, 2006 3:05 pm

can that be a Cegui Version problem.
Cegui must have "Falagard" support to be able to load that meshviewer layout.
0 x

User avatar
xabila
Goblin
Posts: 225
Joined: Mon Jun 05, 2006 9:40 am
Location: rennes [FR]

Postby xabila » Wed Jun 14, 2006 3:15 pm

actually i have the last version of CEGUI with these lib CEGUITaharezLook CEGUIFalagardBase and CEGUIWindowsLook but for linux...
0 x

User avatar
xabila
Goblin
Posts: 225
Joined: Mon Jun 05, 2006 9:40 am
Location: rennes [FR]

Postby xabila » Wed Jun 14, 2006 3:31 pm

oups sorry, actually i have the last stable version for linux : 0.4.1.
0 x

User avatar
tuan kuranes
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 2653
Joined: Wed Sep 24, 2003 8:07 am
Location: Haute Garonne, France
Contact:

Postby tuan kuranes » Wed Jun 14, 2006 3:45 pm

Does your ogre media folder has the good .xsd and .scheme ?
(Falagard.xsd ?)
(0.4.1 should be ok, and is the one distributed with Ogre.)
0 x

User avatar
xabila
Goblin
Posts: 225
Joined: Mon Jun 05, 2006 9:40 am
Location: rennes [FR]

Postby xabila » Wed Jun 14, 2006 3:58 pm

yes i have copied all you have given for windows.
so there is the Falagard.xsd but no Falagard.scheme
0 x

User avatar
xabila
Goblin
Posts: 225
Joined: Mon Jun 05, 2006 9:40 am
Location: rennes [FR]

Postby xabila » Fri Jun 16, 2006 5:00 pm

OK i solved the problem, and now the viewer is working on linux !

So it was my Makefile i was linking with libCEGUITaharezLook.so, libCEGUIWindowsLook.so and libCEGUIFalagardBase.so ...
0 x

User avatar
tuan kuranes
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 2653
Joined: Wed Sep 24, 2003 8:07 am
Location: Haute Garonne, France
Contact:

Postby tuan kuranes » Sat Jun 17, 2006 1:07 pm

Great news !
Please send a patch.
0 x

ProfesorX
Halfling
Posts: 95
Joined: Thu Oct 07, 2004 7:18 pm
Location: Veracruz, Mexico

Postby ProfesorX » Sat Nov 11, 2006 4:39 am

I am trying to compile CeguiMeshViewer using CodeBlocks/Mingw, and only one file refuse to compile, but i don't know what this error means, and how to solve it:

Code: Select all

..\src\MeshViewerMeshInfo.cpp:364: error: invalid initialization of non-const reference of type 'Ogre::GpuProgramPtr&' from a temporary of type 'Ogre::GpuProgramPtr'
..\src\MeshViewerMeshInfo.cpp:365: error: invalid initialization of non-const reference of type 'Ogre::GpuProgramPtr&' from a temporary of type 'Ogre::GpuProgramPtr'


The file in question is MeshViewerMeshInfo.cpp, and next, the 2 lines that give the error:

Code: Select all

                                            GpuProgramPtr &pProgPS = GpuProgramPtr();
                                            GpuProgramPtr &pProgVS = GpuProgramPtr();


I am using Ogre 1.2.3.

Can someone please tell me how can i fix this in the code?

Thanks in advance.
0 x
Image

User avatar
irrdev
Orc
Posts: 420
Joined: Sun Oct 15, 2006 7:30 pm
Contact:

Great Job, tuan kuranes!

Postby irrdev » Sat Nov 11, 2006 8:47 am

Great job, tuan kuranes! Much better than the GEGUI Mesh Viewer! Please make this the one availble in the downloads section! :lol:
0 x
FeedLaunch .NET RSS and ATOM feed editor- open-source and released under the GPL. Visit Feed Launch .NET Project Website hosted at sourceforge.net

enaut
Gnoblar
Posts: 9
Joined: Sun Jan 28, 2007 6:33 pm

Postby enaut » Sun Jan 28, 2007 7:36 pm

looks very nice on the pictures... but.

trying to run it by myself causes an error:

Image

besides that i tried to compile it for linux but since im pretty new to programming i have no idea how to compile that stuff...it would be really nice if someone coul'd either make a binary - *.deb - ubuntu preferred or make a easy to use tutorial... how to compile and install...

mfg enaut

ps: if you need some information on my system just ask...

thx for help
0 x

greg_marlow
Gnoblar
Posts: 10
Joined: Wed Jun 14, 2006 12:56 am
Location: Johnson City TN
Contact:

Postby greg_marlow » Mon Jan 29, 2007 5:43 am

So I'm going to keep posting on this thread because it is somewhat related.

Basically what I am needing is a way for animators (Who have no knowledge of Coding) to be able to view their Facial and Skeletal animation in the engine.

So a programmer I work with found that the SDK 1.2.x compatible demo that will show blendshape animation as well as skeleton.

It is really nice and I can get their demo of pose animation to work but I cant get it to work myself. It keeps giving me the following error:

Error #:4
Function: Mesh::getSubMesh
Desription: Index out of bounds..
File: ..\src\OgreMesh.cpp
Line 164


Does anyone have any Ideas of what to do?

Greg
0 x

User avatar
spooky_paul
Halfling
Posts: 61
Joined: Fri Oct 20, 2006 6:09 am
Location: Romania
Contact:

Postby spooky_paul » Mon Jan 29, 2007 8:17 am

@enaut:

copy the cegui mesh viewer executable into *ogre installation folder*\bin in either the "release" or "debug" folder depending on what configuration you used. this should get rid of that nasty error window

i had the same problem and this fixed it


*edit:*

don`t forget to copy the extra media that came with the source to your default ogre media folder. default: *ogre installation folder*\media
0 x

User avatar
hmoraldo
OGRE Expert User
OGRE Expert User
Posts: 517
Joined: Tue Mar 07, 2006 11:22 pm
Location: Buenos Aires, Argentina
Contact:

Postby hmoraldo » Mon Jan 29, 2007 10:53 pm

Did this solve it? If yes, then I was wrong on my diagnose of the error, but I'd found that strange as I'm almost sure it's rather related to the pose animation structure.
0 x
H. Hernan Moraldo
Personal website

enaut
Gnoblar
Posts: 9
Joined: Sun Jan 28, 2007 6:33 pm

Postby enaut » Tue Feb 20, 2007 9:06 pm

sorry i did not try this method... i simply changed to another viewer - especially because or project is using a different one too - but if you need debug information i can test it for you... please reply i hope i will not need so long to report again ;)

greetings enaut
0 x


Return to “General Discussion”

Who is online

Users browsing this forum: Google [Bot] and 1 guest