Search found 748 matches

by dermont
Mon Nov 13, 2017 6:36 pm
Forum: Help
Topic: v2-2 ParticleSystem stall
Replies: 5
Views: 116

Re: v2-2 ParticleSystem stall

Just tried "writeContentsToFile" with Workspace->getFinalTarget() and a RTT texture, both saved correctly. There must have been something wrong in my code, sorry for the noise.

I'll try the saving the texture for a (RTT/ParticleSystem) if I can track down the problem the ParticleSytem.
by dermont
Mon Nov 13, 2017 5:57 pm
Forum: Help
Topic: v2-2 ParticleSystem stall
Replies: 5
Views: 116

Re: v2-2 ParticleSystem stall

Yes like writeContentsToFile, I didn't see that method. This was my code as a starting point. I first tested RTT class ScreenShotTextureGpuListener: public Ogre::TextureGpuListener { public: ScreenShotTextureGpuListener() : Ogre::TextureGpuListener() { } static void saveToFile( TextureGpu *texture, ...
by dermont
Mon Nov 13, 2017 4:34 am
Forum: Help
Topic: v2-2 ParticleSystem stall
Replies: 5
Views: 116

v2-2 ParticleSystem stall

GL3/Linux/Nvidia. I've recently updated to latest v2-2 branch to try out the updates for TextureGpu::copyTo. The scene contains a v1 particle system. Since updating the render pipeline stalls/hangs after a few frames, remove the particle system everything renders OK. Previously I started with trying...
by dermont
Fri Nov 03, 2017 10:02 am
Forum: Help
Topic: Solved [2.2] ObjCmdBuffer FastArray Invalid free
Replies: 14
Views: 264

Re: [2.2] ObjCmdBuffer FastArray Invalid free

Thanks the fix solved the problems.
by dermont
Fri Nov 03, 2017 3:19 am
Forum: Help
Topic: Solved [2.2] ObjCmdBuffer FastArray Invalid free
Replies: 14
Views: 264

Re: [2.2] ObjCmdBuffer FastArray Invalid free

Thanks for the feedback, really appreciate your assistance on this. I've tested this with gcc 6.4 and 7.2, it may be one of optimization flags. I'll try and check. Meantime I'll build with Clang.
by dermont
Fri Nov 03, 2017 2:18 am
Forum: Help
Topic: Solved [2.2] ObjCmdBuffer FastArray Invalid free
Replies: 14
Views: 264

Re: [2.2] ObjCmdBuffer FastArray Invalid free

Added change for OgreTextureGpuManager.cpp, all source/build dirs deleted and clean build, PbsMaterials demo still crashes only with Release builds. Release Build: Thread 1 "Sample_PbsMater" received signal SIGBUS, Bus error. malloc_consolidate (av=av@entry=0x7ffff628ec20 <main_arena>) at malloc.c:4...
by dermont
Thu Nov 02, 2017 5:19 pm
Forum: Help
Topic: Solved [2.2] ObjCmdBuffer FastArray Invalid free
Replies: 14
Views: 264

Re: [2.2] ObjCmdBuffer FastArray Invalid free

I'm pretty sure I have the latest code from bitbucket. v2-2-WIP 11727:f80d00a4cb2b This is the destructor for FastArray: ~FastArray() { for( size_t i=0; i<mSize; ++i ) mData[i].~T(); ::operator delete( mData ); mSize = 0; mCapacity = 0; mData = 0; } I wrongly assumed it was only a problem with Relea...
by dermont
Sun Oct 29, 2017 6:05 pm
Forum: Announcements / News / Information
Topic: [Announcement] Forums updated/ Addon forums to go down
Replies: 39
Views: 2402

Re: [Announcement] Forums updated/ Addon forums to go down

dark_sylinc wrote:
Sun Oct 29, 2017 12:30 am
Uh oh, that information you posted is key. It would appear the forums are not reachable from IPv6 but they are from IPv4.

I've informed Pavel about the situation.
Thanks I can now access the forums directly.
by dermont
Sat Oct 28, 2017 12:13 pm
Forum: Announcements / News / Information
Topic: [Announcement] Forums updated/ Addon forums to go down
Replies: 39
Views: 2402

Re: [Announcement] Forums updated/ Addon forums to go down

Thanks I'm already using Google as a DNS provider (2001:4860:4860::8888 / 2001:4860:4860::8844) for IPv6. I'll try again in a few days.
by dermont
Fri Oct 27, 2017 9:25 pm
Forum: Announcements / News / Information
Topic: [Announcement] Forums updated/ Addon forums to go down
Replies: 39
Views: 2402

Re: [Announcement] Forums updated/ Addon forums to go down

Yeah, Paroj had been moving the server in steps (i.e. for a time being parts of the website were hosted in two servers at the same time) because it's huge; and he now migrated the forums and the DNS took time to propagate. We all had the same issue as well, for some lasted longer than others. Paroj...
by dermont
Tue Oct 24, 2017 4:57 am
Forum: Help
Topic: Solved [2.2] ObjCmdBuffer FastArray Invalid free
Replies: 14
Views: 264

Re: [2.2] ObjCmdBuffer FastArray Invalid free

I've been suspecting memory corruption around the places you're indicating (particularly with the introduction of HW mipmap generation filter). Most likely the bug goes away if you hardcode mDefaultMipmapGen to DefaultMipmapGen::SwMode. Tried the suggestion regarding the DefaultMipmapGen, still the...
by dermont
Thu Oct 19, 2017 12:59 pm
Forum: Help
Topic: [2.1] Equivelant of setDatablock() for a submesh?
Replies: 6
Views: 98

Re: Equivelant of setDatablock() for a submesh?

subitem->setDatablock(block)
by dermont
Thu Oct 19, 2017 12:58 pm
Forum: Ogre 2.0+
Topic: [2.1] How to compile MyGUI for Ogre 2.1
Replies: 11
Views: 263

Re: [2.1] How to compile MyGUI for Ogre 2.1

Code: Select all

       /** Initialise all resource groups which are yet to be initialised.
        @see ResourceGroupManager::intialiseResourceGroup
        */
        void initialiseAllResourceGroups( bool changeLocaleTemporarily );
by dermont
Thu Oct 19, 2017 12:54 pm
Forum: Ogre 2.0+
Topic: [2.1] The 1st and 3rd party plugins/components that haven’t been ported yet
Replies: 4
Views: 179

Re: [2.1] The 1st and 3rd party plugins/components that haven’t been ported yet

So... about the CEGUI According to this post I think using the macro is fine. We never supported Ogre 2.1 anyway so if we "break" ABI for Ogre 2.1 it's not really a break. And it's been 2 years (2015-2017) since CEGUI successfully port to Ogre 2.1 (still build error, need to tweak), CEGUI still not...
by dermont
Wed Oct 18, 2017 3:52 am
Forum: Ogre 2.0+
Topic: [Ogre 2.1] Porting CEGUI to OGRE 2.1
Replies: 63
Views: 6249

Re: [Ogre 2.1] Porting CEGUI to OGRE 2.1

You've not made the changes correctly. See attachment, you should double check if I've applied the changes correctly. Also included a demo, uses OIS but may be of some help to you.
by dermont
Tue Oct 17, 2017 11:51 am
Forum: Ogre 2.0+
Topic: [Ogre 2.1] Porting CEGUI to OGRE 2.1
Replies: 63
Views: 6249

Re: [Ogre 2.1] Porting CEGUI to OGRE 2.1

Did you make the changes to the CEGUI OgreRenderer that user _hack provided on the previous page for Hlms cache/pso?
by dermont
Tue Oct 17, 2017 6:22 am
Forum: Help
Topic: [2.1] How to get Ogre's RenderTarget for CEGUI's OgreRenderer
Replies: 2
Views: 85

Re: [2.1] How to get Ogre's RenderTarget for CEGUI's OgreRenderer

CEGUI::OgreRenderer* cegui_renderer = &CEGUI::OgreRenderer::bootstrapSystem(*static_cast<Ogre::RenderTarget*>(mRenderWindow));
by dermont
Tue Oct 17, 2017 6:19 am
Forum: Ogre 2.0+
Topic: [Ogre 2.1] Porting CEGUI to OGRE 2.1
Replies: 63
Views: 6249

Re: [Ogre 2.1] Porting CEGUI to OGRE 2.1

@123iamking

The samples framework may not build for 2-1, try disabling the samples, i.e. CEGUI_SAMPLES_ENABLED=OFF
by dermont
Tue Oct 17, 2017 3:28 am
Forum: Help
Topic: Solved [2.2] ObjCmdBuffer FastArray Invalid free
Replies: 14
Views: 264

Re: [2.2] ObjCmdBuffer FastArray Invalid free

Modified V2Mesh example attached.
by dermont
Tue Oct 17, 2017 1:36 am
Forum: Help
Topic: Solved [2.2] ObjCmdBuffer FastArray Invalid free
Replies: 14
Views: 264

Re: [2.2] ObjCmdBuffer FastArray Invalid free

Btw make sure you do a clean build because FastArray was modified, and if the change wasn't picked up it would cause the crash you're mentioning. Yes all clean builds. Tried again, built Ogre in Release/Debug mode, only appears to happen for the Release build. ======= Backtrace: ========= /lib/x86_...
by dermont
Mon Oct 16, 2017 10:38 am
Forum: Help
Topic: Solved [2.2] ObjCmdBuffer FastArray Invalid free
Replies: 14
Views: 264

Solved [2.2] ObjCmdBuffer FastArray Invalid free

Hi, I've just updated to the latest changes for v2-2/OpenGL/NVidia and am having problems with and invalid free in Ogre::ObjCmdBuffer::clear(), Everything was OK prior to the update to FastArrays updates for ObjCmdBuffer. In python-ogre it just crashes when rendering a frame. Maybe something has cha...
by dermont
Sat Oct 14, 2017 6:32 am
Forum: Announcements / News / Information
Topic: [Announcement] Forums updated/ Addon forums to go down
Replies: 39
Views: 2402

Re: [Announcement] Forums updated/ Addon forums to go down

That's sad that the Addons forum will be going downdown, always took an interest in python-ogre and always thought that MOGRE had a healthy user base. I guess it's difficult to maintain some of the addons without a stable release and the current Ogre user base probably doesn't justify a separate add...
by dermont
Sat Oct 14, 2017 6:03 am
Forum: Help
Topic: [2.1] How to draw as wire?
Replies: 23
Views: 924

Re: [2.1] How to draw as wire?

What distro are you using? Rapidjson is header only so you only need to include the header path, either: 1) check your package manager for the development package for rapidjson (on Ubuntu it's rapidjson_dev) and build using the dependencies from your package manager. 2) Alternatively if your distro ...
by dermont
Tue Oct 03, 2017 4:52 am
Forum: Help
Topic: v2-2 ParticleSystem ColourImageAffector crash
Replies: 0
Views: 90

v2-2 ParticleSystem ColourImageAffector crash

For v2-2 ParticleSystem the ColourImageAffector is still using OgreImage and crashes since the image type is registered with the ImageCodec2/ImageData2 and OgreImage is attempting to load and use ImageData2. python3: /media/sdb11/THISITPYTHONOGRE3/v2-2/downloads/ogre-v2-2/OgreMain/include/OgreShared...
by dermont
Thu Sep 21, 2017 3:39 pm
Forum: Help
Topic: [Solved] StagingTexture returns zero width/height TextureBox
Replies: 6
Views: 307

Re: v2-2 StagingTexture returns zero width/height TextureBox

Thanks for the fix and the feedback everything running fine now.