Search found 61 matches

by libolt
Wed Jul 18, 2018 5:48 pm
Forum: Help
Topic: 1.11 + MyGUI on Linux - SOLVED
Replies: 1
Views: 89

Re: 1.11 + MyGUI on Linux - SOLVED

I ended up re-downloading and building OGRE from scratch. Then MyGUI built without issue.
by libolt
Tue Jul 17, 2018 8:52 pm
Forum: Help
Topic: 1.11 + MyGUI on Linux - SOLVED
Replies: 1
Views: 89

1.11 + MyGUI on Linux - SOLVED

Ogre Version: :1.11: Operating System: :OpenSUSE Tumbleweed: Render System: :OpenGL: Okay so I have Ogre 1.11 and MyGUI working properly on Windows/MInGW. However, trying to build MyGUI under linux with the latest 1.11 from Mercurial I get the following: [ 90%] Building CXX object Platforms/Ogre/Og...
by libolt
Wed Jul 11, 2018 10:16 pm
Forum: Help
Topic: Ogre Version
Replies: 2
Views: 113

Ogre Version

While I am moving my code to Ogre 1.11 I still need compatability with 1.10. Does ogre have a preprocessor macro that defines the version number?
by libolt
Mon Jun 18, 2018 7:35 am
Forum: Help
Topic: RenderSystem_GL on MinGW-W64
Replies: 0
Views: 161

RenderSystem_GL on MinGW-W64

So I fixed my issue with OgreBites by cleaning up my build and switching to using MSYS2 packages for things like SDL, zziplib, freeimage, freetype etc instead of building ogre's dependencies from mercurial. However, now I get the following error during linking of RenderSystem_GL. I have installed th...
by libolt
Fri Jun 15, 2018 5:05 pm
Forum: Help
Topic: 1.11 +OgreBites
Replies: 1
Views: 131

1.11 +OgreBites

I'm running the latest HG pull/update of 1.11 and I have noticed that the OgreBites component is no longer being built and the OGRE_BUILD_COMPONENT_BITES option is no longer available if I run cmake-gui. Without OgreBies I am unable to build MyGUI.
by libolt
Wed Jun 13, 2018 6:40 pm
Forum: Help
Topic: 1.11 + btOgre
Replies: 2
Views: 128

Re: 1.11 + btOgre

paroj, Thank you. That worked with the exception of CMake's FindBullet module not finding my mingw-w64 build of bullet. But that's something I've been dealing with for years so I substituted my own module and btOgre built successfully. Now I just have to figure out why boost is not bootstrapping on ...
by libolt
Tue Jun 12, 2018 9:07 am
Forum: Help
Topic: 1.11 + btOgre
Replies: 2
Views: 128

1.11 + btOgre

So I got a new laptop and decided to try building my game against Ogre 1.11 again instead of 1.10. I managed to get MyGUI from git to build and link against 1.11 with a couple of minor modifications. However, now I am trying to get the btOgre wrapper to build. It fails with the following: [ 50%] Bui...
by libolt
Fri Feb 23, 2018 12:02 am
Forum: Help
Topic: 1.11 + MyGUI
Replies: 6
Views: 258

Re: 1.11 + MyGUI

I will take a look at imgui when I get some time. In the meantime thanks for the work on getting mygui patched for 1.11. I will try it soon. Then hopefully I can get everything to build for android.
by libolt
Thu Feb 22, 2018 5:17 am
Forum: Help
Topic: 1.11 + MyGUI
Replies: 6
Views: 258

Re: 1.11 + MyGUI

paroj, Again, thanks, I was able to fix those errors by switching to OgreBites. However, it now fails with the following: [ 91%] Building CXX object Platforms/Ogre/OgrePlatform/CMakeFiles/MyGUI.OgrePlatform.dir/src/MyGUI_OgreRenderManager.cpp.obj D:\nextcloud\builds\sources\mygui\Platforms\Ogre\Ogre...
by libolt
Tue Feb 20, 2018 11:14 pm
Forum: Help
Topic: 1.11 + MyGUI
Replies: 6
Views: 258

Re: 1.11 + MyGUI

paroj, Thanks, that fixed one error. Now I get the following: [ 91%] Building CXX object Platforms/Ogre/OgrePlatform/CMakeFiles/MyGUI.OgrePlatform.dir/src/MyGUI_OgreRTTexture.cpp.obj In file included from D:\nextcloud\builds\sources\mygui\Platforms\Ogre\OgrePlatform\src\MyGUI_OgreRTTexture.cpp:9:0: ...
by libolt
Tue Feb 20, 2018 7:43 am
Forum: Help
Topic: 1.11 + MyGUI
Replies: 6
Views: 258

1.11 + MyGUI

Hi, I decided to try building MyGUI against the latest Ogre 1.11 in hg and got the following error. I'm not sure if the fault lies in Ogre or MyGUI but I can build just fine with the Ogre 1.10.11 branch. Any help is appreciated. > mingw32-make [ 90%] Built target MyGUIEngine [ 90%] Building CXX obje...
by libolt
Fri Jan 12, 2018 7:49 pm
Forum: Help
Topic: 1.10 branch
Replies: 2
Views: 127

Re: 1.10 branch

paroj,

Thanks, I have everything working again. :)
by libolt
Fri Jan 12, 2018 6:11 pm
Forum: Help
Topic: 1.10 branch
Replies: 2
Views: 127

1.10 branch

First off I am building on OpenSUSE Tumbleweed with GCC 7.2.1. So I updated to the latest code in the default branch which built fine. But then I went to build MyGUI and it died witht he following. [ 90%] Building CXX object Platforms/Ogre/OgrePlatform/CMakeFiles/MyGUI.OgrePlatform.dir/src/MyGUI_Ogr...
by libolt
Mon Jan 30, 2017 5:26 pm
Forum: General Discussion
Topic: Ogre 1.10 from default branch error regarding MurmurHash3.h
Replies: 2
Views: 537

Re: Ogre 1.10 from default branch error regarding MurmurHas

Okay, sounds good. I appreciate that you have taken up maintenance of the 1.10.x code. My project isn't likely to be migrated to 2.1 anytime soon.
by libolt
Sun Jan 29, 2017 6:54 am
Forum: General Discussion
Topic: Ogre 1.10 from default branch error regarding MurmurHash3.h
Replies: 2
Views: 537

Ogre 1.10 from default branch error regarding MurmurHash3.h

Hello, I received the following error compiling my game against the default branch on my Linux desktop: from /usr/local/include/OGRE/OgreSceneNode.h:33, from /usr/local/include/BtOgrePG.h:21, from /home/libolt/Projects/ubc/include/typedefs.h:33, from /home/libolt/Projects/ubc/include/engine/networke...
by libolt
Mon Jan 16, 2017 10:34 pm
Forum: Help
Topic: Ogre 1.10 default branch fails to compile on MinGW-W64 32bit
Replies: 11
Views: 1028

Re: Ogre 1.10 default branch fails to compile on MinGW-W64 3

I am not sure how to do a pull request. However, here is the output of hg diff: diff -r 28319bf4f2ed OgreMain/include/OgreAxisAlignedBox.h --- a/OgreMain/include/OgreAxisAlignedBox.h Mon Jan 16 02:14:11 2017 +0100 +++ b/OgreMain/include/OgreAxisAlignedBox.h Mon Jan 16 14:31:41 2017 -0700 @@ -350,7 +...
by libolt
Fri Jan 13, 2017 10:09 pm
Forum: Help
Topic: Ogre 1.10 default branch fails to compile on MinGW-W64 32bit
Replies: 11
Views: 1028

Re: Ogre 1.10 default branch fails to compile on MinGW-W64 3

Thanks, that fixed the build of the GL RenderSystems. I ran into an issue where I had to remove _OgrePCZPluginExport from line 263 of PlugIns/PCZSceneManager/include/OgrePCZone.h. Which is similar to the _OgreExport issues and that allowed the rest of Ogre to build successfully. Thanks for your help...
by libolt
Thu Jan 12, 2017 11:21 pm
Forum: Help
Topic: Ogre 1.10 default branch fails to compile on MinGW-W64 32bit
Replies: 11
Views: 1028

Re: Ogre 1.10 default branch fails to compile on MinGW-W64 3

Okay that got me further. Now it fails linking RenderSystem_GL.dll. Thanks for the help. [ 39%] Linking CXX shared library ..\..\bin\RenderSystem_GL.dll ../../lib/OgreGLSupport.a(OgreWin32GLSupport.cpp.obj):OgreWin32GLSupport.cpp:(.text+0x7d29): undefined reference to `_imp__wglCreateContext@4' ../....
by libolt
Thu Jan 12, 2017 9:49 pm
Forum: Help
Topic: Ogre 1.10 default branch fails to compile on MinGW-W64 32bit
Replies: 11
Views: 1028

Re: Ogre 1.10 default branch fails to compile on MinGW-W64 3

Okay I removed _OgreExport from that line as well as lines in a couple of other files to get further. Now it dies with the following: [ 46%] Building CXX object RenderSystems/GL/CMakeFiles/RenderSystem_GL.dir/src/OgreGLContext.cpp.obj C:\Users\mmclean\Nextcloud\builds\sources\ogre-1.10\RenderSystems...
by libolt
Thu Jan 12, 2017 4:25 pm
Forum: Help
Topic: Ogre 1.10 default branch fails to compile on MinGW-W64 32bit
Replies: 11
Views: 1028

Re: Ogre 1.10 default branch fails to compile on MinGW-W64 3

Thanks, that fixed the error. Unfortunately it now dies building the OpenGL Rendersystem [ 37%] Building CXX object RenderSystems/GLSupport/CMakeFiles/OgreGLSupport.dir/src/win32/OgreWin32Context.cpp.obj In file included from C:/Users/mmclean/Nextcloud/builds/sources/ogre-1.10/OgreMain/include/OgreB...
by libolt
Wed Jan 11, 2017 10:18 pm
Forum: Help
Topic: Ogre 1.10 default branch fails to compile on MinGW-W64 32bit
Replies: 11
Views: 1028

Ogre 1.10 default branch fails to compile on MinGW-W64 32bit

Until recently I had been building ogre from the V1-10 branch, which works just fine. Upon attempting to build the default branch from a fresh checkout I get several errors. I am using the 32-bit version of GCC 6.2.0 from MSYS2/MinGW-W64 on Windows 10. [ 18%] Building CXX object OgreMain/CMakeFiles/...
by libolt
Fri Jul 29, 2016 10:21 pm
Forum: General Discussion
Topic: Hockey Game with OGRE3D?
Replies: 2
Views: 972

Re: Hockey Game with OGRE3D?

I have been _very_ slowly working on an open source basketball game using ogre (currently 1.10) and bullet for physics. It's not by any means ready for release. I am in fact heavily reworking it currently and it's mostly broken. But if anyone wants to take a look the code is here: https://github.com...
by libolt
Thu Feb 11, 2016 11:19 pm
Forum: Mobile Devices
Topic: Android input library or try to handle natively
Replies: 7
Views: 1214

Re: Android input library or try to handle natively

I use SDL2 to handle input on all platforms that my game runs on. Getting it working on Android stumped me for a long time. I finally ended up creating an android implementation of create Window From that I patched into my local copy of SDL2. I should send a patch to the SDL developers at some point.
by libolt
Thu Jan 15, 2015 9:33 pm
Forum: Mobile Devices
Topic: Android Window focus
Replies: 3
Views: 1954

Re: Android Window focus

Ok to expand on my situation further: I do not use OgreActivityJNi.java and try to use the minimum amount of JNI calls from my code for initializing or managing ogre. Everything is done in the native c++ code like on linux and Windows, the other platforms I code on. I use a minimal amount of jni cod...
by libolt
Mon Jan 12, 2015 10:18 pm
Forum: Mobile Devices
Topic: Android Window focus
Replies: 3
Views: 1954

Re: Android Window focus

Do you by chance have an example of how to do such a thing? I never did get this figured out. The software keyboard is read by SDL just fine, but no other events get picked up.