Search found 298 matches

by vilgeits
Tue Mar 28, 2017 9:55 am
Forum: Help
Topic: Issues with AMD Radeon RX 460
Replies: 2
Views: 342

Issues with AMD Radeon RX 460

We have a source that works ok on most of the systems but one that has this GPU It cannot compile the shaders 10:43:22: Error: commonVP's syntax is not supported 10:43:22: Error: commonFP's syntax is not supported And the reason probably is this one: 10:43:21: * Supported Shader Profiles: arbfp1 arb...
by vilgeits
Fri Feb 19, 2016 10:42 am
Forum: General Discussion
Topic: [solved] Mirror a transform matrix from a fixed axis
Replies: 1
Views: 597

Re: Mirror a transform matrix from a fixed axis

I need a facepalm icon I figure myself the solution:

The response was premult with the matrix
1 0 0
0 1 0
0 0 -1

instead post mult.
by vilgeits
Thu Feb 18, 2016 7:57 pm
Forum: General Discussion
Topic: New website
Replies: 60
Views: 3950

Re: New website

Nice now only forum buttons look a bit outdated.
by vilgeits
Thu Feb 18, 2016 7:54 pm
Forum: General Discussion
Topic: [solved] Mirror a transform matrix from a fixed axis
Replies: 1
Views: 597

[solved] Mirror a transform matrix from a fixed axis

I'm making a exporter from ogre to an external format but unfortunatly my format has inverted Z direction. Most probably your response could say: easy just invert the Z axis offset, but unfortunatly it is not as easy since rotations should be affected too since animation is exported too. Any tip wil...
by vilgeits
Sat Aug 24, 2013 9:45 am
Forum: Developer talk
Topic: Windows XP support for 1.9 dropped?
Replies: 46
Views: 16025

Re: Windows XP support for 1.9 dropped?

Problem lies in OgreAtomicWrappers.h and is not caused by using intrinsic _InterlockedCompareExchange64 but by using InterlockedIncrement64 and InterlockedDecrement64. They are implemented in winbase.h as inline functions using API function InterlockedCompareExchange64. So I replaced all Interlocke...
by vilgeits
Wed Aug 21, 2013 12:24 pm
Forum: Developer talk
Topic: Windows XP support for 1.9 dropped?
Replies: 46
Views: 16025

Re: Windows XP support for 1.9 dropped?

I tried the solution of simply compiling Ogre 1.9RC myself on a Windows XP machine, and doing only that already turns out to solve the problem. Apparently when compiled on Windows XP, Ogre does not attach itself to functions that are not available on Windows XP. :) Probably it could work perfectly ...
by vilgeits
Tue Feb 26, 2013 10:46 am
Forum: General Discussion
Topic: DirectX11 has problems with loading?
Replies: 4
Views: 680

Re: DirectX11 has problems with loading?

Weird experiments: Ogre::LogManager::getSingletonPtr()->logMessage("Previous message"); MRenderedTexture = Ogre::TextureManager::getSingleton().createManual( "mRenderedTextureOrig", Ogre::ResourceGroupManager::DEFAULT_RESOURCE_GROUP_NAME, Ogre::TextureType::TEX_TYPE_2D, 300 ,400, 0, Ogre::PF_FLOAT32...
by vilgeits
Tue Feb 26, 2013 9:35 am
Forum: General Discussion
Topic: DirectX11 has problems with loading?
Replies: 4
Views: 680

Re: DirectX11 has problems with loading?

As for mip maps, they are generated automatically and are used to provide different levels of detail when rendering. I didn't noticed it! That's weird since I'm working on a imagen postproduction tool and I need no mip maps, so they are just a waste of memory for me. Don't forget that DirectX 11 Re...
by vilgeits
Mon Feb 25, 2013 6:32 pm
Forum: Developer talk
Topic: DirectX 11 render system - work-in-progress
Replies: 709
Views: 184059

Re: DirectX 11 render system - work-in-progress

I've put this http://www.ogre3d.org/forums/viewtopic.php?f=1&t=76572 on the General forum but maybe people from this post could be the proper ones to add light to the question.
by vilgeits
Mon Feb 25, 2013 5:41 pm
Forum: General Discussion
Topic: DirectX11 has problems with loading?
Replies: 4
Views: 680

DirectX11 has problems with loading?

First problem is really straightfoward to be detected Ogre::TextureManager::getSingleton().load(lightfile1,Ogre::ResourceGroupManager::DEFAULT_RESOURCE_GROUP_NAME,Ogre::TEX_TYPE_2D,0); Ogre::TextureManager::getSingleton().load(lightfile2,Ogre::ResourceGroupManager::DEFAULT_RESOURCE_GROUP_NAME,Ogre::...
by vilgeits
Sat Feb 23, 2013 10:39 am
Forum: Help
Topic: DX11convertToImage UnimplementedException pack to PF_UNKNOWN
Replies: 0
Views: 111

DX11convertToImage UnimplementedException pack to PF_UNKNOWN

This code was running fine in DX9 mTptr = Ogre::TextureManager::getSingleton().load(texname,Ogre::ResourceGroupManager::DEFAULT_RESOURCE_GROUP_NAME,Ogre::TEX_TYPE_2D,0,1,false,Ogre::PF_FLOAT16_RGBA); while (!mTptr->isLoaded()){} mTptr->convertToImage(myImages[i]); but in Dx11 it throws this exceptio...
by vilgeits
Fri Feb 22, 2013 2:09 pm
Forum: General Discussion
Topic: From HLSL to RTShaderSystem
Replies: 1
Views: 193

From HLSL to RTShaderSystem

I'm introducing myself into the RTShaderSystem to upgrade my test to DX11. Currently I've lots of hlsl custom shaders. Reading the wiki I notice that RTShaderSystem is works great to uses Ogrematerials in dx11 and so, and there is also chance to write your own effects... But there is any easy way to...
by vilgeits
Sun May 13, 2012 9:08 am
Forum: Using OGRE in practice
Topic: Bug on Ogre::String? VS2010 bug?
Replies: 4
Views: 982

Re: Bug on Ogre::String? VS2010 bug?

Thank you all!

As I said I manage to fix it but my doubt was why I've needed to change that code that previously was working like a charm.
by vilgeits
Wed May 09, 2012 2:00 pm
Forum: Using OGRE in practice
Topic: Bug on Ogre::String? VS2010 bug?
Replies: 4
Views: 982

Re: Bug on Ogre::String? VS2010 bug?

Weird doing this it works fine: TCHAR szMyDocs[MAX_PATH]; SHGetFolderPath(NULL, CSIDL_COMMON_APPDATA, NULL, 0, szMyDocs) ; QString mTempDir= QString::fromUtf16(szMyDocs) mTempDir+="myFile.log"; Ogre::String mPath=mTempDir.toUtf8(); mRoot = new Ogre::Root("plugins.cfg","ogre.cfg",mPath); //works fine...
by vilgeits
Wed May 09, 2012 11:17 am
Forum: Using OGRE in practice
Topic: Bug on Ogre::String? VS2010 bug?
Replies: 4
Views: 982

Bug on Ogre::String? VS2010 bug?

I've updated my visual studio to visualstudio 2010 and retrieved the last 1.8 (unstable) version. A working code has stopped to work and the problem is here TCHAR szMyDocs[MAX_PATH]; SHGetFolderPath(NULL, CSIDL_COMMON_APPDATA, NULL, 0, szMyDocs) ; QString mTempDir= QString::fromUtf16(szMyDocs) Ogre:...
by vilgeits
Tue Aug 23, 2011 11:34 am
Forum: General Discussion
Topic: DirectX problems with more than one +4096 textures?
Replies: 6
Views: 502

Re: DirectX problems with more than one +4096 textures?

If I try to load .jpg's instead .exr (8bit instead 32bit) it works fine but I repeat is not a memory issue, also it crashes at same point if I use 16 bit per channel.
by vilgeits
Mon Aug 22, 2011 5:47 pm
Forum: Papercuts
Topic: writeContentsToFile
Replies: 2
Views: 1156

Re: writeContentsToFile

It simply ads a new (int) optional parameter to writeContentsToFile and writeContentsToTimestampedFile that indicates the quality:
- 0 ->Superb
- 1->Good
- 2->Normal
- 3->Average
- Other->bad

by default 0 (SuperB) is used.
by vilgeits
Mon Aug 22, 2011 5:45 pm
Forum: Papercuts
Topic: writeContentsToFile
Replies: 2
Views: 1156

writeContentsToFile

I don't know if this is the proper section to put this, if not could be this considered as a patch? If the correct way to deal with this is a patch and you want to summit it yourself there is no problem :D I miss from some time ago the option to choose quality of the saved .jpg files (probably the m...
by vilgeits
Mon Aug 22, 2011 1:21 pm
Forum: General Discussion
Topic: DirectX problems with more than one +4096 textures?
Replies: 6
Views: 502

Re: DirectX problems with more than one +4096 textures?

14:20:26: Texture: TEXFIRST.exr: Loading 1 faces(PF_FLOAT32_RGB,6000x3000x1) with 0 generated mipmaps from Image. Internal format is PF_FLOAT32_RGBA,6000x3000x1. 14:20:27: FIRST LOADING 14:20:27: FIRST LOADED 14:20:30: Texture: TEXSECOND.exr: Loading 1 faces(PF_FLOAT32_RGB,6000x3000x1) with 0 gener...
by vilgeits
Mon Aug 22, 2011 12:34 pm
Forum: General Discussion
Topic: DirectX problems with more than one +4096 textures?
Replies: 6
Views: 502

Re: DirectX problems with more than one +4096 textures?

A 6000x6000 image will most likely be padded up to 8192x8192 (padding is different on different chipsets, I had a texture 320 wide, an ati card padded it to 384 and a nvidia card padded it to 512). 8192x8192 (assuming 32 bit colour) takes 256MB of ram. The standard memory size of a geforce 8800gt i...
by vilgeits
Mon Aug 22, 2011 8:57 am
Forum: General Discussion
Topic: DirectX problems with more than one +4096 textures?
Replies: 6
Views: 502

DirectX problems with more than one +4096 textures?

I'm working on a composition system that needs to work on large images. Mostly are under that 4096 but some times supersampling is needed so if you want to use a 3000 px image you are really using a 6000px one. I noticed that I need to disable mip generation to avoid to go over 8192, and it is loade...
by vilgeits
Tue May 31, 2011 8:22 am
Forum: Help
Topic: Ati+Fixed Pipeline madness [Solved!]
Replies: 4
Views: 242

Re: Ati+Fixed Pipeline madness

You are right!

Thank you.
by vilgeits
Mon May 30, 2011 12:04 pm
Forum: Help
Topic: Ati+Fixed Pipeline madness [Solved!]
Replies: 4
Views: 242

Re: Ati+Fixed Pipeline madness

Nope I had it in account.

I was forcing all my shaders to ps_3_0 (supported for the gpu) but if I use ps_2_0 it works (as I said it works fine with 3.0 in NVidia too)


Anyway thanks for your response!
by vilgeits
Mon May 30, 2011 11:05 am
Forum: Help
Topic: Ati+Fixed Pipeline madness [Solved!]
Replies: 4
Views: 242

Ati+Fixed Pipeline madness [Solved!]

I'm getting mad with this: Currently I'm using fixed pipeline for almost all but in some parts it don't works on Ati Hardware but in Nvidia. For example - SkyX works without problems in my 8800GT but some parts like layered clouds go out in my Ati 5650. - PagedGeometry works fine on both but if I us...
by vilgeits
Mon Apr 11, 2011 5:03 pm
Forum: General Discussion
Topic: Can OGRE runs on a virtualized OSX?
Replies: 21
Views: 1283

Re: Can OGRE runs on a virtualized OSX?

I've been digging, dumb myself, you're right I was very happy about bought it used (pretty cheap) but it seems that I'll need buy a Mac hw too. Some one wants to sell? :roll: Since I can't do it the question is not needed to be answered anymore, but just for curiosity I was doing the things in the r...