How to know the version of my Ogre

Anything and everything that's related to OGRE or the wider graphics field that doesn't fit into the other forums.
Post Reply
tolily
Kobold
Posts: 35
Joined: Mon Apr 25, 2005 11:49 am

How to know the version of my Ogre

Post by tolily » Tue May 24, 2005 2:11 am

My classmate told me we were using Ogre1.0.0 Final, but it seems not, how to get to know it?

In the file Ogre.log, there is:

....
*Version 1.0.0 (Azathoth)

So is my ogre version Ogre1.0.0 Final?
0 x

User avatar
temas
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 390
Joined: Sun Oct 06, 2002 11:19 pm
Location: The Woodlands, TX
Contact:

Post by temas » Tue May 24, 2005 4:18 am

Yes, Azathoth is just the codename for the 1.0 branch.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Post by jacmoe » Tue May 24, 2005 6:13 am

You should go and get Ogre 1.0.1 :)
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
Kencho
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 4011
Joined: Fri Sep 19, 2003 6:28 pm
Location: Burgos, Spain
x 1
Contact:

Post by Kencho » Tue May 24, 2005 9:25 am

In OgrePrerequisites.h :
- OGRE_VERSION_MAJOR
- OGRE_VERSION_MINOR
- OGRE_VERSION_NAME
- OGRE_VERSION_PATCH

Is that enough? ;)
0 x
Image

User avatar
monster
OGRE Community Helper
OGRE Community Helper
Posts: 1098
Joined: Mon Sep 22, 2003 2:40 am
Location: Melbourne, Australia
Contact:

Post by monster » Tue May 24, 2005 9:38 am

Yes, but...
monster wrote:That [version] string comes from the following macros in OgrePrerequisites.h
Code:
#define OGRE_VERSION_MAJOR 1
#define OGRE_VERSION_MINOR 0
#define OGRE_VERSION_PATCH 0
#define OGRE_VERSION_NAME "Azathoth"

Which has been defined thus since revision 1.84 which was committed to CVS on January 29, 2005. So it just shows you've got the 1.0.x branch. Not exactly which version of the entire source package you downloaded. But then, really, you should know that yourself shouldn't you?
So those macros won't actually give you a definitive answer. But as I (also) say, I think it's reasonable to expect a developer to know which version they downloaded! Isn't it?

To be on the safe side, just download the latest version and use that!
:)
Last edited by monster on Tue May 24, 2005 9:42 am, edited 1 time in total.
0 x

User avatar
Kencho
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 4011
Joined: Fri Sep 19, 2003 6:28 pm
Location: Burgos, Spain
x 1
Contact:

Post by Kencho » Tue May 24, 2005 9:41 am

Just found that in the API docs :P Don't know more about that anyways :oops:
0 x
Image

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Post by jacmoe » Tue May 24, 2005 10:36 am

If it is the cvs version, there should be a tag in the root cvs folder (it is hidden) - it should read "Tv1-0-1"
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

Post Reply