Paging Landscape v2 - Comments / Questions / Suggestions

Anything and everything that's related to OGRE or the wider graphics field that doesn't fit into the other forums.
Locked
ceisnaugle
Gnoblar
Posts: 1
Joined: Thu Dec 16, 2004 2:41 am

OgrePanelOverlayElement.h

Post by ceisnaugle »

Just a quick question.

I downloaded and compiled Hastur 15.1, then downloaded ogreaddons and was able to compile the PagindLandscape2 plugin. However when I went to compile the PagingLandscape2 sample I was told it could not open this file "OgrePanelOverlayElement.h". I checked the various include directories as well as doing a file search and it was not found.

I then grabbed a copy of the latest CVS snapshot and the file is there. I noticed also this same problem came up earlier for someone but there had not been a clear resolution to the problem.

Is the PagingLandscape Plugin not being built against the 15.1 release of Hastur? And if it is what is the solution to this missing file and compile problem?

Thanks in Advance,

Chris Eisnaugle

User avatar
tuan kuranes
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 2653
Joined: Wed Sep 24, 2003 8:07 am
Location: Haute Garonne, France
x 4
Contact:

Post by tuan kuranes »

latest pslm2 is nearly always up to date with latest cvs. (at least, til ogre 1.0 comes out).

Latest ogre cvs include the resource management changes.
( that are indeed very useful for latest plsm2 )

I also updated the cfg files with much more comments.

Vanish
Gnoblar
Posts: 16
Joined: Thu Dec 23, 2004 6:18 pm
Contact:

Post by Vanish »

Ok, I can't get the plugin to compile because it can't find the definition for:

MemoryDataStream
DataStreamPtr

and neither can I :cry:

I searched all Ogre directories and the internet and I can't find a darn thing about these types (obviously related). Is it in the latest Ogre CVS which just refuses to update on my computer (well what do you know, it finally did! With no luck on the above problem)?

User avatar
sinbad
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 19265
Joined: Sun Oct 06, 2002 11:19 pm
Location: Guernsey, Channel Islands
x 66
Contact:

Post by sinbad »

That's because PLSM has been upgraded to the latest CVS which uses the new resource system and is thus interface incompatible with Hastur (0.15.x). Just like kuranes said above your post in fact ;). If you want, use CVS to get a version prior to this change by using the -d parameter. I believe the change was done around the 20th December.

Vanish
Gnoblar
Posts: 16
Joined: Thu Dec 23, 2004 6:18 pm
Contact:

Post by Vanish »

Oi, all these versions are hurting my brain, lol. I did read all 19 pages of this thread because I am very interested in using this plugin, but I am new to Ogre, so please permit me a little slack, hehe.

Alright, I guess I will keep at other parts of my project until I have compatible stuff.

Thanks.

jmm
Gnoblar
Posts: 9
Joined: Fri Oct 15, 2004 12:43 pm
Location: Bremen, Germany

Sharp performance drop after switch to PLSM2

Post by jmm »

After an experimental switch from the TerrainSceneManager to PLSM2 the average frame rate on my Radeon 9200 (with DRI drivers) dropped from ~85 fps to ~20 fps. With some tweaking of the various settings in the geometry definition I could improve it to ~25 fps, but it's still a very sharp drop in performance. I understand that PSLM includes more functionality (and terrain splatting works really fine) and that more terrain needs to be prepared for rendering (although the amount of displayed terrain isn't significantly larger than in the statically paged old implementation, as the camera is pretty close). Is this to be expected, as PSLM is less optimized yet in comparison to TSM?

Cheers,
Moritz

User avatar
tuan kuranes
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 2653
Joined: Wed Sep 24, 2003 8:07 am
Location: Haute Garonne, France
x 4
Contact:

Post by tuan kuranes »

@jmm : it depends heavily on the textureformat.Using textureformat=image will let you compare with TSM. All other Texture format will have impact on perfs (shader opengl splatting under linux with dri drivers is expected to drop frame rates...).

Otherwise try tweaking VisibleRenderables, DistanceLOD, MaxRenderLevel, MaxAdjacentPages parameters

News from the front : PLSM2 is in sync with latest cvs change. (mappsplitter has known mem leaks, waiting for a patch on Ogre::Image to be applied)

jmm
Gnoblar
Posts: 9
Joined: Fri Oct 15, 2004 12:43 pm
Location: Bremen, Germany

Post by jmm »

@tuan kuranes:
The 25 fps are already the result of TextureFormat=image
Tweaking some of the options showed a bit of improvement (e.g. an average of ~29 fps, when I lower the VisibleRenderables to 10), but it's still not enough for low-end systems and systems with bad 3D drivers, so I guess we'll stick with our static paging for now. Thanks for all the help!

Cheers,
Moritz

User avatar
spoke
Greenskin
Posts: 121
Joined: Sun Oct 06, 2002 11:19 pm
Location: Spain
Contact:

Post by spoke »

Sorry, I may miss your testing computer details, so which system are those FPS from?
May the force be with you.

jmm
Gnoblar
Posts: 9
Joined: Fri Oct 15, 2004 12:43 pm
Location: Bremen, Germany

Post by jmm »

@spoke:

The 25 fps come from a AMD Athlon(tm) XP 1700+ with a Radeon 9200 (regular version, not SE) with DRI drivers.

The 5-7 fps come from my notebook, a Thinkpad X31 with a Pentium M 1400 and an onboard Radeon Mobility M6 LY. I'm using the DRI drivers as well.

User avatar
tuan kuranes
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 2653
Joined: Wed Sep 24, 2003 8:07 am
Location: Haute Garonne, France
x 4
Contact:

Post by tuan kuranes »

This Post is now closed. (too many pages, unreadable and too old informations)

Please use pages below :

Read WIKI page for all information

Binary demo

Help request page

Bugs, contribs and feature request page

Locked