X2 - 3D Sidescroller demo "download"

Anything and everything that's related to OGRE or the wider graphics field that doesn't fit into the other forums.
User avatar
ahmedali
Gnome
Posts: 302
Joined: Fri Feb 20, 2004 8:52 pm
Location: Lahore, Pakistan

X2 - 3D Sidescroller demo "download"

Post by ahmedali » Thu Oct 21, 2004 7:40 pm

Image

Download from
http://www.angelfire.com/tv2/ahmedali/p ... ges/x2.htm
Dont forget to download MissingFiles zip, that is required if you dont have them already. It contains msvcp70.dll and mscvr70.dll.

Im a little short on time so there is no detail on page nor in zip file.
This is an EXPERIMENTAL project, Unlike X1* this is not a boring demo but not a game too.

NOTICE:
actually I did some early mistakes... To run demo soomthly you should change your monitor's refresh rate to 100Hz and run the demo with VSync option ON.
You dont need this to do if you dont have a fast card or machine to reach 100 fps. But anyway people having fps higher or lower that 100 fps will not get smooth results.

Keys:-
Left, Right and Up for jump.

Please tell me if you see some file is missing or you are getting strange behaviour.

Credits:
As you can see, I did not even have time to put my own name in level or other credits.
Special thanks to Ogre team and contributers. Without their efforts for making tools and exporters, it was not possible to make this demo in short period of time.

Thanx for John for allowing me to use his Quake3 model.
Model Name "Martian"
Concept/3D Model/Skinmap John Diamond
<alienrace@adelphia.net>

Re-Rigging and animation in max is done by me. I took advantage of all spare assets as im not an aritist.

*You can also see my older project X1 which was created with irrlicht.
Download from
http://www.angelfire.com/tv2/ahmedali/p ... ges/x1.htm
Last edited by ahmedali on Fri Oct 22, 2004 8:05 am, edited 2 times in total.
0 x

User avatar
ahmedali
Gnome
Posts: 302
Joined: Fri Feb 20, 2004 8:52 pm
Location: Lahore, Pakistan

Post by ahmedali » Thu Oct 21, 2004 7:45 pm

and its 4MB. Please give me your reply if you download it and tried it.
0 x

User avatar
Kezzer
Orc
Posts: 444
Joined: Mon Aug 16, 2004 2:19 pm
Location: Silicon Valley

Post by Kezzer » Thu Oct 21, 2004 7:50 pm

x2.exe - Unable To Locate Componont

This Application has failed to start because MSVCP70.dll was not found. Re-installing the application may fix this problem.



An exception has been thrown!
-----------------------
Details:
-----------------------
Error #: 9
Function: DynLib::load
Description: Could not load dynamic library. \Plugin_DotSceneManager. System error: Unknown Error.
File: \Libraries\ogre\ogrenew\OgreMain\src\OgreDynLib.cpp
Line: 83
Stack unwinding: DynLib::load(..) <- <<beginning of stack>>

:cry:
0 x

User avatar
ahmedali
Gnome
Posts: 302
Joined: Fri Feb 20, 2004 8:52 pm
Location: Lahore, Pakistan

Post by ahmedali » Thu Oct 21, 2004 8:06 pm

thanx, i have added a missingFiles link on mainpage. get these dlls from there.
0 x

User avatar
Kezzer
Orc
Posts: 444
Joined: Mon Aug 16, 2004 2:19 pm
Location: Silicon Valley

Post by Kezzer » Thu Oct 21, 2004 8:49 pm

I can't see them on the main page :(
0 x

Chev
Gnoblar
Posts: 13
Joined: Fri Mar 05, 2004 6:11 pm

Post by Chev » Thu Oct 21, 2004 8:57 pm

It works for me after downloading the missing files. I'll try it again when I get home. I'm on my work pc so it ran pretty slow (onboard intel video card).
0 x

User avatar
ahmedali
Gnome
Posts: 302
Joined: Fri Feb 20, 2004 8:52 pm
Location: Lahore, Pakistan

Post by ahmedali » Thu Oct 21, 2004 8:59 pm

Actually i meant this
http://www.angelfire.com/tv2/ahmedali/p ... ges/x2.htm
by main page :)
0 x

User avatar
Kezzer
Orc
Posts: 444
Joined: Mon Aug 16, 2004 2:19 pm
Location: Silicon Valley

Post by Kezzer » Thu Oct 21, 2004 9:38 pm

Yup, works fine now, great work there :)
0 x

User avatar
sinbad
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 19261
Joined: Sun Oct 06, 2002 11:19 pm
Location: Guernsey, Channel Islands
Contact:

Post by sinbad » Thu Oct 21, 2004 10:33 pm

Nice little demo. I get 270fps on my FX5900 with vsync off :)
0 x

User avatar
Xinc
Halfling
Posts: 52
Joined: Sat May 08, 2004 12:55 pm
Location: Toronto, Canada

Post by Xinc » Fri Oct 22, 2004 1:47 am

very nice demo indeed :) The jump animation reminded me of some of the half-life "jump" animation sequences hehe (good times, good times).
0 x
- Xinc

nfz
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 1263
Joined: Wed Sep 24, 2003 4:00 pm
Location: Halifax, Nova Scotia, Canada

Post by nfz » Fri Oct 22, 2004 2:57 am

Worked great here on a ATI A.I.W 9600XT. Averaged 200FPS at 1024x768 DX9 with VSync off. Getting by the rotating thingy took some mastering but I finally got it.
0 x

User avatar
ahmedali
Gnome
Posts: 302
Joined: Fri Feb 20, 2004 8:52 pm
Location: Lahore, Pakistan

Post by ahmedali » Fri Oct 22, 2004 7:46 am

KeZZeR & Xinc:
thanx

sinbad:
Glad you like it.

nfz:
I dont know how i got his idea but I wanted to add some difficulty to make demo interesting. Also I wanted to the BlueOrb enemy to fire shots but didnt had time for that.

Development Related
----------------------------
Just to tell you guys that martian had 1 spine IK and two IKs for legs. And the problem with current ogreMax exporter that I had to manually put keys on each ik dependent bone and export all animation clips indiviudally and then combine them. So I used my own scripted Ik animation baker to make keys for bones. And used an INI file to create 11 animation clips. So there is almost no pre/post-export extra work needed to import model in ogre. So you can do changings in animations and see the result in ogre with only 2 clicks.

I wanted to add some mood to scene using lighting and vertex lighting. But DotSceneMan was not loading lights and DotSceneConvert messed with all my vertex colours during conversion process.

Also noticed a problem with cTh's exporter exporting vertex colors. So did this change to get correct results in MeshViewer
// original
// *pColor++ = cv.getAsLongABGR();
// changed to
*pColor++ = cv.getAsLongARGB();

:?: One thing I wondered was why I can only see vertex colors when some lights are present in scene. And ambient lighting was not litting vertex colours?

Also I wanted to use yake but as Im at learning stage so may be in future.

One thing I learned from this project. That it requires huge amount of artistic assets and resources, a team of designers and leve-designers to make an interesting side-scroller game.
0 x

User avatar
Banania
Gremlin
Posts: 150
Joined: Wed Oct 20, 2004 2:35 pm
Location: Paris, France
Contact:

Nice demo

Post by Banania » Fri Oct 22, 2004 9:39 am

Good job!

It works fine !
0 x
Banania

User avatar
SpannerMan
Gold Sponsor
Gold Sponsor
Posts: 446
Joined: Fri May 02, 2003 10:05 am
Location: UK
Contact:

Post by SpannerMan » Fri Oct 22, 2004 2:19 pm

Cool, I like it. Runs very fast here.
0 x

User avatar
pjcast
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 2543
Joined: Fri Oct 24, 2003 2:53 am
Location: San Diego, Ca
Contact:

Post by pjcast » Fri Oct 22, 2004 6:40 pm

Looks good, only a couple of prolems here:

DirectX7 - Works fine, I get about 17 fps
OpenGL: Crashes hard (took out my laptop monitor, and had to reboot).
DirectX9 - Error #9 Direct3D9VertexDeclaration::getD3DVertexDeclaration
Cannot create D3D9 vertex declaration. Line 121

Anyway, all Ogre demos work fine here except the Celshading and Fresnal demo, so I don't know.

Presario 2175, WinXP Pro 512MB DDR
2.4Ghz AMD
IGP320 Graphics card (i know, its a crap card :( )

:!: :!:
Perhaps this file may help with your exporting using cTh's exporter. Not sure if its a similiar problem though... Check out this thread.
0 x
Have a question about Input? Video? WGE? Come on over... http://www.wreckedgames.com/forum/

User avatar
Xinc
Halfling
Posts: 52
Joined: Sat May 08, 2004 12:55 pm
Location: Toronto, Canada

Post by Xinc » Fri Oct 22, 2004 7:36 pm

Worked fine on both OGL and DX 9 (didn't check DX 7) for me.

card: ATI 9200pro 128mb
0 x
- Xinc

User avatar
Goosey
Halfling
Posts: 88
Joined: Wed Sep 29, 2004 3:33 am
Location: Ohio, USA
Contact:

Post by Goosey » Sun Oct 24, 2004 9:32 am

DX7: Runs at about 25fps

DX9:
Error #: -1005530516
Function: D3D9HardwareVertexBuffer::lock
Description: Cannot lock D3D9 vertex buffer.
File: ..stuff..\OgreD3D9HardwareVertexBuffer.cpp
Line: 83

OpenGL: Runs fine.

Cool demo, I like it. I am curious what you did for collision detection. I thought the graphics looked pretty nice considering how few tri's were in use, I especially liked the pretty particles on the ball-enemy.

Only complaint: The background sound gets really repetitive.
0 x
I <3 the OGRE Wiki, and SO SHOULD YOU! :)

old_man_auz
Halfling
Posts: 87
Joined: Tue Jun 15, 2004 5:10 am
Location: Australia

Post by old_man_auz » Sun Oct 24, 2004 10:11 am

Hey,
that was pretty cool. Good job.

I got about 350 fps with a :
Athlon 2500 XP
Radeon 9800 pro
0 x

User avatar
Kencho
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 4011
Joined: Fri Sep 19, 2003 6:28 pm
Location: Burgos, Spain
x 1
Contact:

Post by Kencho » Sun Oct 24, 2004 3:26 pm

Nice game. You've done a great job ;)
0 x
Image

User avatar
ahmedali
Gnome
Posts: 302
Joined: Fri Feb 20, 2004 8:52 pm
Location: Lahore, Pakistan

Post by ahmedali » Mon Oct 25, 2004 8:21 am

Thank you very much all the people.
I experienced problems with dx7 too, dont know why.
Goosey wrote: Cool demo, I like it. I am curious what you did for collision detection. I thought the graphics looked pretty nice considering how few tri's were in use, I especially liked the pretty particles on the ball-enemy.
Only complaint: The background sound gets really repetitive.
The collision is done b/w 2d lines sets and capsule(character). I used constraining technique and verlet particles for collision response and character physics.
I couldnt fine any "mars attack" like background music anyware for free, but this small clip was free, so i used it.

Anyway thanx all guys for apreciation.
0 x

User avatar
dennis
Gremlin
Posts: 154
Joined: Mon Nov 11, 2002 4:21 pm

Post by dennis » Tue Nov 09, 2004 9:37 am

Two of the three beams on that rotating beam thing flicker heavily. It's on a GF2MX.
0 x

Vectrex
Ogre Magi
Posts: 1266
Joined: Tue Aug 12, 2003 1:53 am
Location: Melbourne, Australia
Contact:

Post by Vectrex » Sun Nov 21, 2004 11:27 am

ahmedali: did you have to split up the max geometry at all? If you are using the octree manger i was wondering if the whole base level mesh gets drawn all the time as the octtree needs seperate chunks in order to cull them? All the other bits look like they would work with it. That is assuming the ground mesh is one big mesh.
0 x

Lucias
Gnoblar
Posts: 6
Joined: Fri Apr 08, 2005 6:05 am

Post by Lucias » Fri Apr 08, 2005 7:40 am

Hey man, that is pretty cool, I get about 160fps with opengl, 220fps dx9, and 25fps dx7 with a geforce 4 and everything seems to work fine.

I have a few questions I'd like to ask if you don't mind, because I need to do a very similar 2d sidescroller in a few weeks and I'm kind of having a difficult time getting started.

1. What did you use to make the actual level

2. Any advice on how to get started on something like that.

once again cool stuff and thanks for sharing with us.
0 x

User avatar
regress
Halfling
Posts: 78
Joined: Sat Mar 26, 2005 8:39 pm

Post by regress » Sun Apr 10, 2005 8:44 am

ahmedali, is there any way you could post the source for this? I think it's a perfect program for teaching us newly initiated about how to use ogre to make a product.

If you would be so kind as to be willing to open the source, I would gladly go over it and document my experience, and create a tutorial based on it at the end.

Anyway, I really hope this is possible, it's such a great start!

Regards
0 x
regards

Post Reply