Bugs in docs/tuts...

Anything and everything that's related to OGRE or the wider graphics field that doesn't fit into the other forums.
Post Reply
User avatar
Sydius
Gnoblar
Posts: 18
Joined: Fri Mar 25, 2005 6:30 pm
Location: Los Gatos, CA
Contact:

Bugs in docs/tuts...

Post by Sydius » Sat Mar 26, 2005 12:52 am

Maybe this is the wrong place to point this out, and maybe it is already known, but on the “Intermediate Tutorial 1” (and maybe others), there is a bug in the “code to start with”… I am a relative newbie and just copied/pasted it, thinking that would be fine. A half hour later, I finally figured out why it was not being defined as a Win32 application.

The line that says:

#if OGRE_PLATFORM == PLATFORM_WIN32

Breaks it for Windows users because it actually sets OGRE_PLATFORM to OGRE_PLATFORM_WIN32… I probably looked at the definition a dozen times before I noticed the difference. For same reason, exception messages do not work.



Also, in the manual, at http://www.ogre3d.org/docs/manual/manual_30.html#SEC145 the command at the bottom (rotation) seems to be missing the pretty gold text and an explanation.
0 x

User avatar
haffax
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 4823
Joined: Fri Jun 18, 2004 1:40 pm
Location: Berlin, Germany
Contact:

Post by haffax » Sat Mar 26, 2005 12:56 am

You can change the text in the wiki yourself, just create an account and click edit on the page you like to change.. The PLATFORM_WIN32 is from a pre 1.0 version of Ogre.
0 x
team-pantheon programmer
creators of Rastullahs Lockenpracht

User avatar
sinbad
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 19261
Joined: Sun Oct 06, 2002 11:19 pm
Location: Guernsey, Channel Islands
Contact:

Post by sinbad » Sat Mar 26, 2005 4:13 pm

I've fixed the manual.
0 x

Post Reply