Basic tutorial does not work

Anything and everything that's related to OGRE or the wider graphics field that doesn't fit into the other forums.
Post Reply
mgs_oleg
Gnoblar
Posts: 20
Joined: Fri Mar 30, 2018 8:24 pm
x 1

Basic tutorial does not work

Post by mgs_oleg » Fri Apr 06, 2018 10:48 pm

Hi All,

I've decided to create app based on http://wiki.ogre3d.org/BasicTutorial6SourceCurrent
Thing is I am getting error

Code: Select all

23:44:26: FileNotFoundException: Cannot locate resource DualQuaternion_Common.glsl in resource group General. in ResourceGroupManager::openResource at P:\dev\ogre-1.10.11\OgreMain\src\OgreResourceGroupManager.cpp (line 708)
Once fixed this issue by adding additional directories where required file located, I am getting another error

Code: Select all

23:29:16: InvalidStateException: RenderSystem does not support FixedFunction, but technique has no Vertex Shader: Ogre/Earring in SceneManager::_setPass at P:\dev\ogre-1.10.11\OgreMain\src\OgreSceneManager.cpp (line 1035)
Do you know what might be an issue ?
0 x

paroj
OGRE Team Member
OGRE Team Member
Posts: 615
Joined: Sun Mar 30, 2014 2:51 pm
x 85
Contact:

Re: Basic tutorial does not work

Post by paroj » Sat Apr 07, 2018 12:15 pm

the old tutorials do not initialize the RTSS, so they do not work with GL3+/ DX11/ GLES2 out of the box.

but also see the discussion here:
viewtopic.php?f=2&t=94161
0 x

mgs_oleg
Gnoblar
Posts: 20
Joined: Fri Mar 30, 2018 8:24 pm
x 1

Re: Basic tutorial does not work

Post by mgs_oleg » Sat Apr 07, 2018 2:28 pm

thanks. Please close this case then
0 x

Post Reply