Ogre Tutorial Framework - doesn't compile

Get answers to all your basic programming questions. No Ogre questions, please!
Post Reply
mkolenda
Gnoblar
Posts: 1
Joined: Mon Jun 15, 2015 11:38 am

Ogre Tutorial Framework - doesn't compile

Post by mkolenda » Mon Jun 15, 2015 12:07 pm

I have downloaded "Ogre Wiki Tutorial Framework 1.9 - (Unix line endings)" from http://www.ogre3d.org/tikiwiki/Ogre+Wik ... +Framework

Please tell me friends why the hell DisplayString is "?" in error message and why this isn't obviously called as void setParamValue(unsigned int, const ? &)

Code: Select all

mDetailsPanel->setParamValue(9, "Bilinear");

Code: Select all

 ----- error ----
Invalid arguments 'Candidates are:
void setParamValue(const ? &, const ? &)
void setParamValue(unsigned int, const ? &)
 
---- reality ----
-- /usr/incude/OGRE/SdkTrays.h
void setParamValue(const Ogre::DisplayString& paramName, const Ogre::DisplayString& paramValue)
void setParamValue(unsigned int index, const Ogre::DisplayString& paramValue)
 
---- what's DisplayString ----
#if OGRE_UNICODE_SUPPORT // in my case this is true
    typedef UTFString DisplayString;
#    define OGRE_DEREF_DISPLAYSTRING_ITERATOR(it) it.getCharacter()
#else // this isn't my case
    typedef String DisplayString;
#    define OGRE_DEREF_DISPLAYSTRING_ITERATOR(it) *it
#endif
Include:

Code: Select all

/usr/include/OGRE
/usr/include/OGRE/Overlay
/usr/include/OIS
Libraries:

Code: Select all

OgreOverlay
OgreMain
OIS
boost_system
System: Gentoo Linux x86_64
0 x

Badspot
Gnoblar
Posts: 13
Joined: Sat Sep 24, 2011 3:13 pm

Re: Ogre Tutorial Framework - doesn't compile

Post by Badspot » Fri Jul 24, 2015 9:19 am

Got the very same problem, including the setParamValue thing. I have OGRE v1.9 on Ubuntu 14.04.2. :lol: But additionally I also get an OverlaySystem couldn't be resolved error.
0 x

Post Reply