Setup window doesn't open

Problems building or running the engine, queries about how to use features etc.
Post Reply
Cutthroadstreak
Gnoblar
Posts: 1
Joined: Mon May 03, 2021 7:52 pm

Setup window doesn't open

Post by Cutthroadstreak »

Recently I tried to play an old game I used to play on my old pc time ago, now that I have a new pc I wanted to try again but I have a little problem... The game doesn't start, I tried compatibility mode, turn off anti-virus and nothing is working, I decided to download another game that is also made with Ogre, however this other game doesn't depend of the "Setup" like the other one does and I could open the game, BUT the setup never show up, so I came to the conclusion that there's something on my computer that's stopping the Setup windows from opening and that's why I can't play the game, but what and why? My Windows defender is also disabled, I tried a lot like re-install the game and nothing worked...
Image

Here's and image of the setup window I'm supposed to get...
User avatar
sercero
Bronze Sponsor
Bronze Sponsor
Posts: 174
Joined: Sun Jan 18, 2015 4:20 pm
Location: Buenos Aires, Argentina
x 41

Re: Setup window doesn't open

Post by sercero »

Hello,

Check the contents of the folder where the game was installed to see if there is a file called "ogre.cfg" with a configuration similar to this:

Code: Select all

Render System=Direct3D9 Rendering Subsystem

[Direct3D9 Rendering Subsystem]
Allow NVPerfHUD=No
FSAA=0
Fixed Pipeline Enabled=Yes
Floating-point mode=Fastest
Full Screen=No
Multi device memory hint=Use minimum system memory
Rendering Device=Monitor-1-AMD Radeon(TM) RX Vega 11 Graphics
Resource Creation Policy=Create on all devices
Use Multihead=Auto
VSync=Yes
VSync Interval=1
Video Mode=1024 x 768 @ 32-bit colour
sRGB Gamma Conversion=No

[OpenGL Rendering Subsystem]
Colour Depth=32
Display Frequency=60
FSAA=0
Fixed Pipeline Enabled=Yes
Full Screen=Yes
RTT Preferred Mode=FBO
VSync=No
VSync Interval=1
Video Mode=1024 x 768
sRGB Gamma Conversion=No
Deleting that file might make the dialog appear, also the file might be placed by the setup program somewhere else so if you don't find it in the game folder it might be in your AppData folder.
Post Reply