ogre config dialog empty? (solved)

Problems building or running the engine, queries about how to use features etc.
Post Reply
User avatar
JaJDoo
Gnome
Posts: 343
Joined: Wed Feb 04, 2009 9:15 pm

ogre config dialog empty? (solved)

Post by JaJDoo » Sat Mar 27, 2010 3:38 pm

i've set up a simple app (such as tutorials), when i run it the above happens. (no options, no configs)

RenderSystem_Direct3D9_d.dll,RenderSystem_GL_d.dll and an 'ogre.cfg' file (copied from sample) are present in the working directory.

only code relating to this is a simple:

Code: Select all

    void setupRenderSystem()
    {
        if (!mRoot->restoreConfig() && !mRoot->showConfigDialog())
			throw Exception(52, "User canceled the config dialog!", "Application::setupRenderSystem()");
    }
suggestions?
Last edited by JaJDoo on Sat Mar 27, 2010 6:30 pm, edited 1 time in total.
0 x
some post from somewhere:
"So you basically want to make a car without a steering wheel because you don't know how to drive. I'd say learn how to use pointers"

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: ogre config dialog empty?

Post by spacegaier » Sat Mar 27, 2010 3:48 pm

Did you also copy the plugins.cfg? In this file, there should at least one RenderSystem be listed, because that are the entries that are missing in your dialog.
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

trueleowdeo
Kobold
Posts: 38
Joined: Fri Feb 26, 2010 10:40 am

Re: ogre config dialog empty?

Post by trueleowdeo » Sat Mar 27, 2010 4:35 pm

i have had a similar problem. (am using ogre 1.7)
You will notice that if you compile in release mode, instead of debug mode, your config dialog is OK.
solution i used
Ogre seems to need a plugins.cfg file in BOTH the bin and debug folders of OGRE_HOME
the problem is that the plugins file for debug is named plugins_d.cfg (instead of plugins.cfg). Copy this file and rename the copy to plugins.cfg
PS
I thought that debug builds would use plugins_d.cfg but some how they still need to use plugins.cfg which by the way must contain debug dlls eg RenderSystem_GL_d.dll and not RenderSystem_GL.dll.
Notice the "d" for debug
0 x

User avatar
JaJDoo
Gnome
Posts: 343
Joined: Wed Feb 04, 2009 9:15 pm

Re: ogre config dialog empty? (solved)

Post by JaJDoo » Sat Mar 27, 2010 6:30 pm

thanks, that did it.
0 x
some post from somewhere:
"So you basically want to make a car without a steering wheel because you don't know how to drive. I'd say learn how to use pointers"

Post Reply