Page 1 of 1

[SOLVED] Install Build Target doesn't work

Posted: Thu May 24, 2012 4:09 pm
by BrightBit
Hi Ogre community,

I am using Ogre 1.7 from Source/Repository under Windows 7 with Visual Studio 2010 Express. Everything compiles without problems. It's just the Install Build that reports an error:

Code: Select all

Error	1	error MSB3073: The command "setlocal
"C:\Program Files (x86)\CMake 2.8\bin\cmake.exe" -DBUILD_TYPE=Release -P cmake_install.cmake
if %errorlevel% neq 0 goto :cmEnd
:cmEnd
endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
:cmErrorLevel
exit /b %1
:cmDone
if %errorlevel% neq 0 goto :VCEnd
:VCEnd" exited with code 1.	C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppCommon.targets	113
I really have no idea what this is supposed to mean. Can you help me or show me a direction?


Greetings
BrightBit

Re: Install Build Target doesn't work

Posted: Thu May 24, 2012 4:21 pm
by Mind Calamity
What did you set CMAKE_INSTALL_PREFIX to ? Make sure it's not a directory in C:\Program Files\ or something protected like that, because chances are you have UAC enabled and unless you run Visual Studio as administrator, it will not be able to install the required files in that directory.

The above is what's caused this error for me lots of times, but it could be something else (which I doubt).

Re: Install Build Target doesn't work

Posted: Thu May 24, 2012 4:58 pm
by BrightBit
Thank you. I did know that the "Program Files" directory in Windows can cause problems but I forgot it, so you're right. I changed CMAKE_INSTALL_PREFIX and now the target works, too.


Thank you.

Re: [SOLVED] Install Build Target doesn't work

Posted: Wed Jul 31, 2019 7:04 pm
by ksr30040
Hello

I am having the following errors when i am trying to build my cmake project in visual studio could you please let me know the steps to resolve this issue.

error MSB3073: if %errorlevel% neq 0 goto :cmEnd
error MSB3073: :cmEnd
error MSB3073: endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
error MSB3073: :cmErrorLevel
error MSB3073: exit /b %1
error MSB3073: :cmDone