[2.1] OgreHlmsUnlitDatablock.h not found Topic is solved

Problems building or running the engine, queries about how to use features etc.
Post Reply
ven
Kobold
Posts: 35
Joined: Mon Sep 10, 2007 11:03 am
Location: St. Petersburg, Russia

[2.1] OgreHlmsUnlitDatablock.h not found

Post by ven » Thu Feb 08, 2018 2:31 pm

Trying to build MyGUI, it requires Ogre::HlmsUnlitDatablock (through #include <Hlms/Unlit/OgreHlmsUnlitDatablock.h>)
Found in API reference this: #include <OgreHlmsUnlitDatablock.h>, but this file is also not found anywhere.
What can be done?
0 x

Hrenli
Halfling
Posts: 43
Joined: Tue Jun 14, 2016 12:26 pm
x 8

Re: [2.1] OgreHlmsUnlitDatablock.h not found

Post by Hrenli » Thu Feb 08, 2018 4:05 pm

ven wrote:
Thu Feb 08, 2018 2:31 pm
this file is also not found anywhere.
In built Ogre 2.1 SDK it is located at <wherever you built it>/include/OGRE/Hlms/Unlit and the source is at <ogre>/Components/Hlms/Unlit/include (https://bitbucket.org/sinbad/ogre/src/2 ... e/?at=v2-1)
0 x

ven
Kobold
Posts: 35
Joined: Mon Sep 10, 2007 11:03 am
Location: St. Petersburg, Russia

Re: [2.1] OgreHlmsUnlitDatablock.h not found

Post by ven » Thu Feb 08, 2018 7:46 pm

I can not find the required directory <wherever you built it>/include/OGRE/Hlms/Unlit. In source <ogre>/Components/Hlms/Unlit/include is present.

The answer.

Directory <wherever you built it> is the directory wherever you installed OGRE by script "make install". The installation directory is specified in CMAKE_INSTALL_PREFIX. At least so on linux.
0 x

Post Reply