How to set up Ogre3d for CB+MinW?

Problems building or running the engine, queries about how to use features etc.
Post Reply
belladaisy2018
Gnoblar
Posts: 1
Joined: Thu Apr 12, 2018 11:52 am

How to set up Ogre3d for CB+MinW?

Post by belladaisy2018 » Fri Apr 13, 2018 6:47 am

I'm using Windows Vista Home Premium 64-bit.

I was able to successfully compile and run a simple c++ hello world file so CB appears to be working, but I can't get Ogre3d sample workspace to build.

I followed the Wiki here http://www.ogre3d.org/wiki/index.php/Co ... _and_MinGW and don't see what I have missed. I have run the Ogre3d SDK when CB was closed to make sure the environemnt variable OGRE_HOME gets installed properly. I have a feeling it didn't and am getting a whole slew of errors like this:
..\include\ExampleApplication.h|24|Ogre.h: No such file or directory

EDIT:

I see the Ogre.h sitting here in my C:\OgreSDK\include\ folder... I must need to setup CB further...

On this step:
http://www.ogre3d.org/wiki/index.php/Co ... stallation
it seems as though the workspace can be built with out any further setup.

I moved on to the step that says $(OGRE_HOME)\include so I did that but I have a set of directories listed here that only some exist (i.e I don't have a ..\..\Dependencies\Include Folder)

I tried making $(OGRE_HOME) appear in all of these paths and now when I try to build a project it's saying a new error:
=== Demo_CameraTrack, Debug ===
ld cannot find -lOgreMain_d
=== Build finished: 1 errors, 0 warnings ===
0 x

Post Reply