[SOLVED] Access violation on window creation using OpenGL render systems

Problems building or running the engine, queries about how to use features etc.
Post Reply
taigore
Gnoblar
Posts: 2
Joined: Wed Aug 01, 2018 5:05 pm

[SOLVED] Access violation on window creation using OpenGL render systems

Post by taigore » Wed Aug 01, 2018 5:28 pm

Ogre Version: 1.11.1
Operating System: Windows 10 x64
Render System: GL and GL3Plus

Hello everyone.

I just signed up to the forum to ask a question about a quite strange error.

I tried to call Ogre from a C++ application, and as long as I used the Direct3D11 render system no issues surfaced, until I tried to populate the SceneManager with some entities, but that's for another question.
I then switched to the OpenGL-based renderers, but both seem to fail at window creation, when an "0xC0000005: Access violation executing location 0x00000000" is thrown.

Indeed it seems that at window registration, NULL is set as the lpfnWndProc, and I confirmed it by trying to register a similarly configured window class, which raises the same error at window creation.
However, NULL is explicitly given as the value, so it looks somehow intentional.
What was the reason for doing so? Is still valid or due a fix?
For reference, the code is in the file OgreWin32Window.cpp, lines from 378 to 422, with the exception being thrown at 414.

I tried searching for a previous post about this, but after a quick search I found just this topic, without answers.
Last edited by taigore on Tue Aug 07, 2018 10:53 am, edited 1 time in total.
0 x

paroj
OGRE Team Member
OGRE Team Member
Posts: 572
Joined: Sun Mar 30, 2014 2:51 pm
x 83
Contact:

Re: Access violation on window creation using OpenGL render systems

Post by paroj » Wed Aug 01, 2018 10:45 pm

0 x

taigore
Gnoblar
Posts: 2
Joined: Wed Aug 01, 2018 5:05 pm

Re: [SOLVED] Access violation on window creation using OpenGL render systems

Post by taigore » Tue Aug 07, 2018 10:54 am

Yes, that fixes it indeed. Thanks for the reply
0 x

Post Reply