[1.11.3] Help to prepare simple environment to build bootstrap

Problems building or running the engine, queries about how to use features etc.
Post Reply
Zemtriz
Gnoblar
Posts: 9
Joined: Fri Jul 13, 2018 8:17 pm

[1.11.3] Help to prepare simple environment to build bootstrap

Post by Zemtriz » Sun Nov 04, 2018 2:30 pm

Ogre Version: 1.11.3
Operating System: Win10
Render System: GL3+

Code: Select all

...
...
...
 * PBuffer support: no
 * Vertex Array Objects: yes
 * Separate shader objects: yes
 * GLSL SSO redeclare interface block: yes
 * Debugging/ profiling events: yes
 * Map buffer storage: yes
Registering ResourceManager for type Texture
DefaultWorkQueue('Root') initialising on thread 14360.
DefaultWorkQueue('Root')::WorkerFunc - thread 11444 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 18396 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 4592 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 19656 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 13732 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 20016 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 12440 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 19368 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 3740 starting.Particle Renderer Type 'billboard' registered
DefaultWorkQueue('Root')::WorkerFunc - thread 5548 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 19480 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 12844 starting.

DefaultWorkQueue('Root')::WorkerFunc - thread 20192 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 19296 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 19660 starting.
DefaultWorkQueue('Root')::WorkerFunc - thread 13944 starting.
Added resource location '../../media' of type 'FileSystem' to resource group 'General'
Added resource location '../../media/materials/scripts' of type 'FileSystem' to resource group 'General'
Added resource location '../../media/materials/textures' of type 'FileSystem' to resource group 'General'
Added resource location '../../media/models' of type 'FileSystem' to resource group 'General'
Added resource location '../../media/materials/programs/GLSL120' of type 'FileSystem' to resource group 'General'
Added resource location '../../media/materials/programs/GLSL150' of type 'FileSystem' to resource group 'General'
Added resource location '../../media/materials/programs/GLSL400' of type 'FileSystem' to resource group 'General'
Added resource location '../../media/RTShaderLib/materials' of type 'FileSystem' to resource group 'General'
Added resource location '../../media/RTShaderLib/GLSL' of type 'FileSystem' to resource group 'General'
Parsing scripts for resource group General
Parsing script DualQuaternion.program
Parsing script Examples.program
Error: ScriptCompiler - invalid parameters in Examples.program(311): setting of constant failed
Parsing script Instancing.program
Parsing script StdQuad_vp.program
Parsing script AdaptivePNTrianglesTessellation.material
Parsing script ASCII.material
Parsing script AtomicCounters.material
Parsing script BlackAndWhite.material
Parsing script Bloom2.material
Parsing script CompositorDemo.material
Parsing script Compute.material
Parsing script DamagedHelmet.material
Error: ScriptCompiler - base object not found in DamagedHelmet.material(3): glTF2/PBR
Parsing script DepthShadowmap.material
Parsing script Dither.material
Parsing script DOF.material
Parsing script DualQuaternion.material
Parsing script Embossed.material
Parsing script Examples-Advanced.material
Parsing script Examples-DynTex.material
Parsing script Examples-Water.material
Parsing script Examples.material
Parsing script facial.material
Parsing script FluidSim.material
Parsing script Glass.material
Parsing script Hair.material
Parsing script Halftone.material
Parsing script hdr.material
Parsing script HeatVision.material
Parsing script Hurt.material
Parsing script HWInstancing.material
Parsing script HW_VTFInstancing.material
Parsing script HW_VTF_LUTInstancing.material
Parsing script instancing.material
Parsing script InstancingMisc.material
Parsing script Invert.material
Parsing script Island.material
Parsing script IsoSurf.material
Parsing script Laplace.material
Parsing script MotionBlur.material
Parsing script MRTtest.material
Parsing script NightVision.material
Parsing script Ocean.material
Parsing script OffsetMapping.material
Parsing script Ogre.material
Parsing script OldMovie.material
Parsing script OldTV.material
Parsing script ParticleGS.material
Parsing script Penguin.material
Parsing script Posterize.material
Parsing script pssm.material
Parsing script RadialBlur.material
Parsing script RasterizationOrder.material
Parsing script RZR-002.material
Parsing script ShaderInstancing.material
Parsing script ShaderSystem.material
Parsing script shadows.material
Parsing script SharpenEdges.material
Parsing script sibenik.material
Parsing script smoke.material
Parsing script Swizzle.material
Parsing script TerrainTessellation.material
Parsing script Tessellation.material
Parsing script Tiling.material
Parsing script VarianceShadowmap.material
Parsing script VTFInstancing.material
Parsing script DualQuaternionSkinning_Shadow.material
Parsing script HardwareSkinningShadow.material
Parsing script RTShaderSystem.material
Parsing script TriplanarTexturing.material
Parsing script Examples.compositor
Finished parsing scripts for resource group General
Creating resources for group General
All done
Parsing scripts for resource group OgreAutodetect
Finished parsing scripts for resource group OgreAutodetect
Creating resources for group OgreAutodetect
All done
Parsing scripts for resource group OgreInternal
Finished parsing scripts for resource group OgreInternal
Creating resources for group OgreInternal
All done
Mesh: Loading Sinbad.mesh.
Hello everyone,

I am not able to run bootstrap project to render simple sinbad.mesh model. Application closes after run.
I want to create my simple environment where I can learn Ogre and have it CMake ready.

My folder structure is:

OgreApp

Code: Select all

├── _build
|   ├── Generated files by CMake
|   └── _Release
|       ├── OgreApp.exe
|       ├── plugins.cfg
|       ├── resources.cfg
|       └── Copied dll files from sdk
├── _include
|   └── OgreApp.h
├── _media
|   └── Copied files from sdk
├── _src
|   └── OgreApp.cpp
└── CMakeLists.txt
My plugins.cfg is:

Code: Select all

# Defines plugins to load

# Define plugin folder
PluginFolder=.

# Define plugins
# Plugin=RenderSystem_Direct3D9
# Plugin=RenderSystem_Direct3D11
 Plugin=RenderSystem_GL
 Plugin=RenderSystem_GL3Plus
# Plugin=RenderSystem_GLES2
# Plugin=Plugin_ParticleFX
# Plugin=Plugin_BSPSceneManager
# Plugin=Plugin_CgProgramManager
# Plugin=Codec_EXR
# Plugin=Codec_STBI
# Plugin=Codec_FreeImage
# Plugin=Plugin_PCZSceneManager
# Plugin=Plugin_OctreeZone
# Plugin=Plugin_OctreeSceneManager
My resources.cfg is:

Code: Select all

[General]
FileSystem=../../media
FileSystem=../../media/materials/scripts
FileSystem=../../media/materials/textures
FileSystem=../../media/models
cpp and header files are same as in bootstrap

My CMakeLists.txt is:

Code: Select all

# CMakeList.txt : Top-level CMake project file, do global configuration
# and include sub-projects here.
#
cmake_minimum_required (VERSION 3.8)
project(OgreApp)

## [discover_ogre]
# Specify which version and components you need
find_package(OGRE 1.11 REQUIRED COMPONENTS Bites RTShaderSystem)

# Copy essential config files next to our binary where OGRE autodiscovers them
file(COPY ${OGRE_CONFIG_DIR}/plugins.cfg ${OGRE_CONFIG_DIR}/resources.cfg DESTINATION ${CMAKE_BINARY_DIR})
## [discover_ogre]

macro( add_recursive dir retVal )
	file( GLOB_RECURSE ${retVal} ${dir}/*.h ${dir}/*.cpp ${dir}/*.c )
endmacro()

include_directories( "./include" )

# Call a macro to include source and header files
add_recursive( ./src SOURCES )
add_recursive( ./include HEADERS )

# Add source to this project's executable.
#add_executable (OgreApp "DreamProjekt.cpp" "DreamProjekt.h")
add_executable( ${PROJECT_NAME} ${SOURCES} ${HEADERS} )
#add_executable( ${PROJECT_NAME} WIN32 MACOSX_BUNDLE ${SOURCES} ${HEADERS} ${RESOURCES} )
target_link_libraries( ${PROJECT_NAME} ${OGRE_LIBRARIES} )
I am able to run CMake, build solution and run application but application suddenly closes and nothing happens. Build is in Release as I am not compiling Ogre from source.

Thank you for your help
0 x

paroj
OGRE Team Member
OGRE Team Member
Posts: 917
Joined: Sun Mar 30, 2014 2:51 pm
x 205
Contact:

Re: [1.11.3] Help to prepare simple environment to build bootstrap

Post by paroj » Sun Nov 04, 2018 3:03 pm

you should enable "Plugin=Codec_STBI"

also try copying your application into the sdk/bin folder to exclude path issues.
0 x

Zemtriz
Gnoblar
Posts: 9
Joined: Fri Jul 13, 2018 8:17 pm

Re: [1.11.3] Help to prepare simple environment to build bootstrap

Post by Zemtriz » Sun Nov 04, 2018 3:28 pm

Thank you paroj.

When copied OgreApp.exe into sdk/bin then it worked. So I have copied all files in sdk/bin and put into my folder and replaced ../ in resources with ../../ and it worked. Now I think that I missed some dll files. I copied only some that I tough are required. Didn't want to copy everything.
0 x

Post Reply