[Solved] 1.11.5 to 1.12.0 robot animation

Problems building or running the engine, queries about how to use features etc.
Post Reply
saintnick
Halfling
Posts: 43
Joined: Tue Nov 27, 2018 1:41 am
x 1

[Solved] 1.11.5 to 1.12.0 robot animation

Post by saintnick » Sun Feb 10, 2019 8:48 pm

Ogre Version: 1.12.0 :?:
Operating System: windows 10 :?:
Render System: opengl :?:

I am using the robot mesh that comes with Ogre. In my code I create robots. The following code throws an ItemIdentityException since upgrading to 1.12.0. Nothing shows up in Ogre.log about the exception. The program exits after executing a catch statement in the main loop. This is how I determined it was an ItemIdentityException. Then I stepped through the robot creation code until I found the offending code.

Code: Select all

				Ogre::AnimationState *mAnimationState = mEntity->getAnimationState("Idle");
edit:
Just changed to 1.11.5 release and I am getting the same error. I never used 1.11.5 release and instead had a clone at the time. Nothing in my create robot code has changed recently, only the Ogre version I am compiling against.

edit2:
I looked at the Ogre.log file again this morning and noticed missing .skeleton file for robot mesh which disabled animation. I had recently stopped loading the resources that come with Ogre and started using my own resource path.
0 x

Post Reply