[Solved:] Can't seem to move mouse pointer.

Problems building or running the engine, queries about how to use features etc.
Post Reply
dirkmitt
Halfling
Posts: 40
Joined: Fri Sep 15, 2006 3:40 am
Contact:

[Solved:] Can't seem to move mouse pointer.

Post by dirkmitt » Mon Feb 18, 2019 11:03 am

Ogre Version: 1.11.5
Operating System: Linux, Debian 9
Render System: GL, GL3

I just tried to build OGRE 1.11.5 on my Debian / Stretch computer, and found that there were no compile errors, but that once I got the SampleBrowser to run, its own mouse-pointer remained stuck in the upper-left corner of the window. My real mouse and keyboard have no effect on the application. But otherwise, the sample browser seemed to have no complaints.

I tried to compile OGRE 1.10.12 as well, but obtained identical results.

I also find it odd that the CMake utility does not want to link with OIS, which I have installed, and which once handled Input of all kinds. There's no mention of any dependency on OIS.

OIS version: 1.3.0

What can be done to correct this problem?

Edit: How silly of me. The instructions at the beginning of the OGRE Web-site on how to build have changed, since the old days when I was compiling OGRE. Apparently, we now need to have libsdl2-dev, in order for the sample browser to receive input.

I'm in the process of recompiling.

Edit: Surely enough, the problem has gone away, as soon as I've installed the development packages / header files for SDL. Sorry to have wasted a question.

Dirk
0 x

Post Reply