OGRE with .NET Core doesnt find libOgre Topic is solved

Problems building or running the engine, queries about how to use features etc.
Post Reply
ferb300
Gnoblar
Posts: 2
Joined: Sat Dec 28, 2019 1:04 pm

OGRE with .NET Core doesnt find libOgre

Post by ferb300 »

Hi :)
I ran into some problems trying to use ogre with .NET Core. I downloaded the ogre 1.12.4 SDK and added all the files from bin and all the files from lib/cli to my .NET Core VS Project. When I try to execute a simple example program from github, I get the following runtime error telling me it didnt find a specific library "Unable to load shared library 'libOgre' or one of its dependencies.". I went thrpugh the binaries i added to my project and actually couldnt find it there nor anywhere else in the SDK Folder. Where can I find libOgre and where should i put it? Am I doing something completely wrong? I already tried building OGRE myself with CMake and SWIG but i ran into similar problems.

Thank you for your help :)

paroj
OGRE Team Member
OGRE Team Member
Posts: 1200
Joined: Sun Mar 30, 2014 2:51 pm
x 477
Contact:

Re: OGRE with .NET Core doesnt find libOgre

Post by paroj »

it is in the SDK at lib/cli/ogre-sharp-1.12.4/

however I have no idea where it really belongs. On Linux I just copied everything in the sample directory as stated here:
https://github.com/OGRECave/ogre/tree/v ... les/Csharp

ferb300
Gnoblar
Posts: 2
Joined: Sat Dec 28, 2019 1:04 pm

Re: OGRE with .NET Core doesnt find libOgre

Post by ferb300 »

Thank you so much for your answer. I found the libOgre.dll, but i still have no idea where to put it... Tried several locations but i always get the same error. It just cant seem to find it.

paroj
OGRE Team Member
OGRE Team Member
Posts: 1200
Joined: Sun Mar 30, 2014 2:51 pm
x 477
Contact:

Re: OGRE with .NET Core doesnt find libOgre

Post by paroj »

simplified .NET binding built in
https://github.com/OGRECave/ogre/pull/1449

Post Reply