Page 1 of 1

compile settings for SDL till Ogre 1.12.4

Posted: Wed Mar 25, 2020 10:23 am
by Pellaeon
Hi,

in Ogre 1.12.5, SDL is no longer delivered within the automatic downloaded dependencies in the cmake solution. First question: Why? This was really comfortable.

OK, now, I want to build Ogre 1.12.5 with VS2019 for x64 with SDL enabled. I downloaded the latest SDL version (2.0.12), opened the VC++ solution and build SDL. I set the proper paths in OgreBites and ... I got linker errors! The linker doesn't find the SDL functions.

When using the SDL delivered in Ogre 1.12.4, all works fine. So I suppose, that for this version some compiler flags were set which influences the library creation. So can anybody tell me, which flags were set for the VS version, when SDL is downloaded via ogre 1.12.4 cmake (and earlier versions)?

Best regards

Re: compile settings for SDL till Ogre 1.12.4

Posted: Wed Mar 25, 2020 4:06 pm
by paroj
Pellaeon wrote:
Wed Mar 25, 2020 10:23 am
in Ogre 1.12.5, SDL is no longer delivered within the automatic downloaded dependencies in the cmake solution. First question: Why? This was really comfortable.
Probably something on your side. SDL is still automatically built by CMake:
https://ci.appveyor.com/project/paroj/o ... g=true#L78

you can find the used build flags here:
https://github.com/OGRECave/ogre/blob/m ... cies.cmake

Re: compile settings for SDL till Ogre 1.12.4

Posted: Thu Mar 26, 2020 7:27 am
by Pellaeon
I use Cmake GUI 3.16.2, I unzipped Ogre 1.12.5 to a new empty directory, the result you can see in the attached image.

send_errorD:/projects/cpp/ogre-1.12.5/build/VS x64/Dependencies/bin/debug/cg.dll did not exist, can't install!
send_errorD:/projects/cpp/ogre-1.12.5/build/VS x64/Dependencies/bin/release/cg.dll did not exist, can't install!
CMake Warning at Components/Bites/CMakeLists.txt:151 (message):
SDL2 not found - no input handling and reduced window creation capabilites



The CG error is present since years, but can be handled by creating a Debug and release directory in the specified location and copying the CG.dll into this location by hand (although it would be cool if this also works automatically). But the SDL error is new in Ogre 1.12.5. I will check the newest cmake version 3.17., but I don't think this solves the problem.

Re: compile settings for SDL till Ogre 1.12.4

Posted: Thu Mar 26, 2020 7:36 am
by Pellaeon
CMake 3.17.0 also reports SDL errors, but the message is slightly different. It says:

c1 : fatal error C1083: Datei (Quelle) kann nicht ge”ffnet werden: "x64/SDL2-2.0.10/src/hidapi/hidapi": No such file or directory [D:\projects\cpp\ogre-1.12.5\build\VS x64\SDL2-build\SDL2main.vcxproj]

SDL_windows_main.c


Perhaps some small mistake when updating SDL from 2.0.8. to 2.0.10 from Ogre 1.12.4 to 1.12.5?

Re: compile settings for SDL till Ogre 1.12.4

Posted: Thu Mar 26, 2020 11:29 am
by paroj
seems like the SDL2 build failed because of an error in SDL2. Try updating
https://github.com/OGRECave/ogre/blob/m ... cies.cmake
to 2.0.12

Re: compile settings for SDL till Ogre 1.12.4

Posted: Thu Mar 26, 2020 1:55 pm
by Pellaeon
paroj wrote:
Thu Mar 26, 2020 11:29 am
seems like the SDL2 build failed because of an error in SDL2. Try updating
https://github.com/OGRECave/ogre/blob/m ... cies.cmake
to 2.0.12
I changed the version number of SDL to 2.0.12, same behaviour. So 2.0.8 will do the job for now.