migrate code from Ogre 1.9.x to 1.12.x

Problems building or running the engine, queries about how to use features etc.
Post Reply
ciberfred
Gnoblar
Posts: 5
Joined: Fri Feb 19, 2021 4:09 pm
x 2

migrate code from Ogre 1.9.x to 1.12.x

Post by ciberfred »

Ogre Version: :1.12.10:
Operating System: :Linux Debian 11:
Render System: :OpenGL:

Code: Select all

An Ogre3D exception has occured: InvalidParametersException: Named constants have not been initialised, perhaps a compile error in _findNamedConstantDefinition at ./OgreMain/src/OgreGpuProgramParams.cpp (line 1742)
Hello all, try move my code from 1.9 to 1.12 and get this error (after check and change some code to be compiled with this version of ogre).

First get the Media/ShadowVolume not found at run time and need to add the resourceLocation in the code (i dont' want to use ogre files like plugins.cfg and material, etc...)
I don't have any shader i just want to load and 'print' some vertex with textures from a file. how can i debug this and how to know what is missing ?

thanks.
paroj
OGRE Team Member
OGRE Team Member
Posts: 1513
Joined: Sun Mar 30, 2014 2:51 pm
x 696
Contact:

Re: migrate code from Ogre 1.9.x to 1.12.x

Post by paroj »

as the exception says: "perhaps a compile error". Please provide the full ogre.log.

Also please read: https://github.com/OGRECave/ogre/blob/m ... 2-Notes.md
loath
Platinum Sponsor
Platinum Sponsor
Posts: 216
Joined: Tue Jan 17, 2012 5:18 am
x 32

Re: migrate code from Ogre 1.9.x to 1.12.x

Post by loath »

if you're moving to 1.12 consider moving to 13 instead. it's very stable and these files moved again so you may as well just get them from the final 13 location. just my 2 cents. (still getting used to saying 13 instead of 1.13 :)
Post Reply