[IPhone] cmake, path and various problems.

Discussion of issues specific to mobile platforms such as iOS, Android, Symbian and Meego.
Post Reply
Vivien
Gnoblar
Posts: 9
Joined: Sun Apr 09, 2006 1:12 am

[IPhone] cmake, path and various problems.

Post by Vivien »

Hello,
i have a lot of difficulties to run Ogre on iPhone (simulator 3.1.2 for a simple start)

This page is deprecated, but you can't guess it by reading it.
http://www.ogre3d.org/tikiwiki/Download ... 0iPhone%29
It took me some time to discover that !


Pre-build sdk "OGRE 1.7.1 SDK for iPhone":
- there is NO readme file.
- OGRE.xcodeproj" tries to run a custom shell script 'CMake ReRun' (whyyyyyyy ?) it failed:

Code: Select all

make: *** /Users/(...)/Documents/iPhone: No such file or directory.
yhea, i can confirm this directory didn't exists. And i see no reason for that....
after some time (a lot…) i understand. Path with spaces are not supported and:
"/Users/(...)/Documents/iPhone Projects/OgreSDK" is cut..... Great !

After moving the SDK, another error:

Code: Select all

make: *** No rule to make target `/Applications/CMake 2.8-0.app/Contents/share/cmake-2.8/Modules/CMakeCCompiler.cmake.in', needed by `CMakeFiles/cmake.check_cache'.
Few hours later i discover this post: http://www.ogre3d.org/forums/viewtopic. ... 88&start=0
.... well.... should work with 2.8.0 but not with 2.6 or 2.8.1 or 2.8.2 (?!?!)
it's the first time i use cmake and it's just IMPOSSIBLE to guess.
Of course installation of cmake 2.8.0 failed …. i'm stuck !

Before discovering that workaround, i tried to build from the source:
- Getting ogre from mercurial and compil it were not a problem (with a help of BuildingOgre.txt), cmake 2.8.2 work fine here.
c++/link part is not the problem.

- At this step, i couldn't find any example project for iPhone in the directories !
'OgreTemplateProject' for iPhone help me to build an example project… but it never works.
I also tried to build my own project… without real success.
Today, this project starts and runs with some errors about finding textures and "- (void)renderOneFrame:(id)sender" is called repeatedly but... unfortunately nothing on screen ! (loading screen only…)


I'm missing something ? it's beta version ?
Vivien
(sorry for my bad english)
Last edited by Vivien on Tue Aug 31, 2010 9:08 am, edited 1 time in total.

cg76
Gnoblar
Posts: 24
Joined: Fri Feb 06, 2009 5:58 am
x 2

Re: [IPhone] cmake, path and various problems.

Post by cg76 »

Hi Vivien,

Did you try to follow this guide : http://www.ogre3d.org/tikiwiki/tiki-ind ... %20iPhone) ?

I have no problem running Ogre3D on iPhone using that guide.

Regards,
CG

Vivien
Gnoblar
Posts: 9
Joined: Sun Apr 09, 2006 1:12 am

Re: [IPhone] cmake, path and various problems.

Post by Vivien »

cg76 wrote: Did you try to follow this guide : http://www.ogre3d.org/tikiwiki/tiki-ind ... %20iPhone) ?
I have no problem running Ogre3D on iPhone using that guide.
Thanks, but the probleme is just after building ogre.
Yes i follow this guide, It's great to get a clean build of ogre for iPhone (same content as BuildingOgre.txt on mercurial).
But it didn't explain where to find a working example. Where can i find the .xcodeproj for that ?
(and i can't use the pre-build SDK)
Vivien

cg76
Gnoblar
Posts: 24
Joined: Fri Feb 06, 2009 5:58 am
x 2

Re: [IPhone] cmake, path and various problems.

Post by cg76 »

Hmmm... After building, the xcode project can be found in your build directory

Vivien
Gnoblar
Posts: 9
Joined: Sun Apr 09, 2006 1:12 am

Re: [IPhone] cmake, path and various problems.

Post by Vivien »

thx, i saw that... if i remember well, it build Ogre for iPhone, not examples.

After to much hours spend on this.
- can't build sdk
- with a build of ogre, can't run example (missing ressources, loading screen...)

I'm probably not the only one is this situation. It seems that the build system is complex enough to discourage some of us.
For example, i can't understand why the obscure "Run Custom Shell Script: CMake PostBuild Rules" complains not findind "libOIS.a". (i copied libOIS.a everywhere !)
Or why paths with spaces are not supported.

I don't have much experience on macintosh but maybe lack of simplicity affects the fiability.
I'm giving up and it's frustrating because it's the first time i'm stuck with a library build system.
Vivien

User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
Posts: 4270
Joined: Sun Feb 25, 2007 4:56 am
Location: Bloomington, MN
x 126
Contact:

Re: [IPhone] cmake, path and various problems.

Post by masterfalcon »

So, what errors are you actually getting? From your first post it sounds like you ran into some things but then got past them. You've also said that in your own project you get errors when you run it but you haven't said what those errors are. That makes it a little difficult to help you solve the problem.

Paths with spaces appears to be a CMake issue, not much we can do there.

Post Reply