lboost_thread not found with latest iPhoneDependencies

Discussion of issues specific to mobile platforms such as iOS, Android, Symbian and Meego.
Post Reply
el3ktro
Gnoblar
Posts: 5
Joined: Wed Jul 07, 2010 12:06 am

lboost_thread not found with latest iPhoneDependencies

Post by el3ktro »

Hi,
I just downloaded the latest iPhoneDependencies (from 201006) and when I build my project it says "ld: library not found for -lboost_thread". With the old iPhoneDependencies from 2009 it all worked fine.

How do I solve this? I didn't change anything in my project. I rebuilt Ogre with the new iPhoneDependencies and it didn't give me any errors.

User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
Posts: 4270
Joined: Sun Feb 25, 2007 4:56 am
Location: Bloomington, MN
x 126
Contact:

Re: lboost_thread not found with latest iPhoneDependencies

Post by masterfalcon »

Take a look at the lib folder. The boost libs are just built for release so there's no need to have two copies of them. Just add the iPhoneDependencies/lib folder as a library search path.

Post Reply