Trouble Building iOS Template Project

Discussion of issues specific to mobile platforms such as iOS, Android, Symbian and Meego.
Post Reply
Mike_F
Gnoblar
Posts: 2
Joined: Sat Feb 23, 2013 2:57 am

Trouble Building iOS Template Project

Post by Mike_F » Sat Feb 23, 2013 3:24 am

Hello,

I'm completely new to OGRE 3D and have mild experience with XCode, so please forgive me if I'm missing something simple here.

When I attempt to build a project based on the iOS Template within Xcode, I receive the build error:

Code: Select all

"OgreCamera.h" file not found
To me, I would think this means that the file is not being found within the Header Search Paths list. To give you an idea of how my stuff is setup, I have the prebuilt Ogre SDK installed at "/Developer/OgreSDK" and the additional iOS Dependencies installed inside of that folder at "/Developer/OgreSDK/iOSDependencies". Inside of my Xcode project, I have the following list for Header Search Paths:

Code: Select all

/Developer/OgreSDK/include/
/Developer/OgreSDK/include/OGRE/RenderSystems/GLES2
/Developer/OgreSDK/include/OGRE/RenderSystems
/Developer/OgreSDK/include/OGRE/iOS
/Developer/OgreSDK/include/OIS
/Developer/OgreSDK/iOSDependencies
/Developer/OgreSDK/include/boost
In addition, I have the following Library Search Paths:

Code: Select all

"/Developer/OgreSDK/lib/Release"
"/Developer/OgreSDK/iOSDependencies/lib/release"
"/Developer/OgreSDK/iOSDependencies/lib"
The "Always Search User Paths" option is selected and I also added all of the frameworks inside of /Developer/OgreSDK/lib/release/ to the target framework list (not even really sure if I should have done this, but I figured it couldn't hurt at this stage). I'm worried that I don't see an Ogre.framework anywhere in the /Developer/OgreSDK/ folder; could that be related to the problem I'm having?

Thanks for taking the time to read this and hopefully someone can help me get this figured out. :)
Last edited by Mike_F on Sat Feb 23, 2013 5:28 pm, edited 1 time in total.
0 x

User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
Posts: 4270
Joined: Sun Feb 25, 2007 4:56 am
Location: Bloomington, MN
Contact:

Re: Trouble Building iOS Template Project

Post by masterfalcon » Sat Feb 23, 2013 6:33 am

Could you post the build command from the log? It would help figure out if there is something wrong with the header search paths.
0 x

Mike_F
Gnoblar
Posts: 2
Joined: Sat Feb 23, 2013 2:57 am

Re: Trouble Building iOS Template Project

Post by Mike_F » Sat Feb 23, 2013 5:20 pm

So I actually found out that the Targets version of "Header Search Paths" was not prepending the leading slash in the directories. The files are now being found, so that problem is solved. However, now that I'm actually able to get further into compilation, I'm running into a weird bug that I'm not sure how to resolve. Any idea what this might be?

Error Output:

Code: Select all

Ld /Users/Mike/Library/Developer/Xcode/DerivedData/Work_In_Progress-eycogcviyiuwegedfspojkoxqorh/Build/Products/Debug-iphonesimulator/Work_In_Progress.app/Work_In_Progress normal i386
    cd /Users/Mike/Documents/Work_In_Progress
    setenv IPHONEOS_DEPLOYMENT_TARGET 6.1
    setenv PATH "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -arch i386 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator6.1.sdk -L/Users/Mike/Library/Developer/Xcode/DerivedData/Work_In_Progress-eycogcviyiuwegedfspojkoxqorh/Build/Products/Debug-iphonesimulator -L/Developer/OgreSDK/lib -L/Developer/OgreSDK/lib/Release -F/Users/Mike/Library/Developer/Xcode/DerivedData/Work_In_Progress-eycogcviyiuwegedfspojkoxqorh/Build/Products/Debug-iphonesimulator -filelist /Users/Mike/Library/Developer/Xcode/DerivedData/Work_In_Progress-eycogcviyiuwegedfspojkoxqorh/Build/Intermediates/Work_In_Progress.build/Debug-iphonesimulator/Work_In_Progress.build/Objects-normal/i386/Work_In_Progress.LinkFileList -Xlinker -objc_abi_version -Xlinker 2 -lOIS -lOgreMainStatic -lRenderSystem_GLES2Static -lOgreRTShaderSystemStatic -lmesaglsl2 -lboost_thread -lFreeType -lFreeImage -lzzip -lz -fobjc-link-runtime -Xlinker -no_implicit_dylibs -mios-simulator-version-min=6.1 -lRenderSystem_GLES2Static -lRenderSystem_GLESStatic -lSample_BezierPatch -lSample_BSP -lSample_CameraTrack -lSample_CelShading -lSample_Character -lSample_Compositor -lSample_CubeMapping -lSample_DeferredShading -lSample_Dot3Bump -lSample_DualQuaternion -lSample_DynTex -lSample_FacialAnimation -lSample_Fresnel -lSample_Grass -lSample_Instancing -lSample_Isosurf -lSample_Lighting -lSample_NewInstancing -lSample_Ocean -lSample_ParticleFX -lSample_ParticleGS -lSample_ShaderSystem -lSample_Shadows -lSample_SkeletalAnimation -lSample_SkyBox -lSample_SkyDome -lSample_SkyPlane -lSample_Smoke -lSample_SphereMapping -lSample_SSAO -lSample_Terrain -lSample_TextureArray -lSample_TextureFX -lSample_Transparency -lSample_VolumeTex -lSample_Water -lzzip -lOgrePagingStatic -lOgrePropertyStatic -lOgreRTShaderSystemStatic -lOgreTerrainStatic -lOIS -lPlugin_BSPSceneManagerStatic -lPlugin_OctreeSceneManagerStatic -lPlugin_OctreeZoneStatic -lPlugin_ParticleFXStatic -lPlugin_PCZSceneManagerStatic -lOgreMainStatic -lmesaglsl2 -lFreeType -lhlsl2glsl -lcppunit -lFreeImage -framework CoreGraphics -framework Foundation -framework OpenGLES -framework QuartzCore -framework UIKit -o /Users/Mike/Library/Developer/Xcode/DerivedData/Work_In_Progress-eycogcviyiuwegedfspojkoxqorh/Build/Products/Debug-iphonesimulator/Work_In_Progress.app/Work_In_Progress

ld: warning: ignoring file /Developer/OgreSDK/lib/Release/libcppunit.a, file was built for archive which is not the architecture being linked (i386): /Developer/OgreSDK/lib/Release/libcppunit.a
Undefined symbols for architecture i386:
  "boost::system::system_category()", referenced from:
      __GLOBAL__I_a in main.o
      boost::unique_lock<boost::recursive_mutex>::lock() in OgreDemoApp.o
      __GLOBAL__I_a in OgreDemoApp.o
      __GLOBAL__I_a in OgreFramework.o
      boost::unique_lock<boost::recursive_mutex>::lock() in libOgreMainStatic.a(OgreConfigFile.o)
      boost::recursive_mutex::recursive_mutex() in libOgreMainStatic.a(OgreConfigFile.o)
      __GLOBAL__I_a in libOgreMainStatic.a(OgreConfigFile.o)
      ...
  "boost::system::generic_category()", referenced from:
      __GLOBAL__I_a in main.o
      __GLOBAL__I_a in OgreDemoApp.o
      __GLOBAL__I_a in OgreFramework.o
      __GLOBAL__I_a in libOgreMainStatic.a(OgreConfigFile.o)
      __GLOBAL__I_a in libOgreMainStatic.a(OgreLogManager.o)
      __GLOBAL__I_a in libOgreMainStatic.a(OgreQuaternion.o)
      __GLOBAL__I_a in libOgreMainStatic.a(OgreString.o)
      ...
ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)
Thanks for your help!
0 x

Post Reply