Page 1 of 1

Error with "ndk-build all"

Posted: Sun Aug 04, 2013 2:44 pm
by Cydonia
I'm following this guide and have finally gotten to the stage where "nmake" successfully builds everything (as far as I can tell). However I'm now stuck on the next step, running "ndk-build all" throws the following errors:

Code: Select all

The process cannot access the file because it is being used by another process.
"Compile++ thumb : OgreSampleBrowser <= SampleBrowser.cpp
In file included from C:/Libraries/sinbad-ogre/Build/Samples/include/SampleBrowser.h:31:0,
                 from C:/Libraries/sinbad-ogre/Samples/Browser/src/SampleBrowser.cpp:35:
C:/Libraries/sinbad-ogre/Build/Samples/include/SampleContext.h:49:0: warning: "USE_RTSHADER_SYSTEM" redefined [enabled by default]
<command-line>:0:0: note: this is the location of the previous definition
C:/Libraries/sinbad-ogre/Samples/Browser/src/SampleBrowser.cpp:128:1: fatal error: opening dependency file ./obj/local/armeabi/objs/OgreSampleBrowser/SampleBrowser.o.d: No such file or directory
compilation terminated.
make: *** [obj/local/armeabi/objs/OgreSampleBrowser/SampleBrowser.o] Error 1
Any thoughts?

Re: Error with "ndk-build all"

Posted: Sun Aug 11, 2013 9:18 am
by smotko
I've tried to use the sample GLES2 app from Ogre Android SDK. It runs fine, but when I try to change something I get stuck at the same step as you, although with a slightly different error:

Code: Select all

Android NDK: /home/smotko/gamedev/ogre-android-demo2/jni/ Cannot find module with tag 'lib-android-ogre-3d/lib' in import path    
Android NDK: Are you sure your NDK_MODULE_PATH variable is properly defined ?    
Android NDK: The following directories were searched:    
Android NDK:         
/home/smotko/gamedev/ogre-android-demo2/jni/ *** Android NDK: Aborting.    .  Stop.
I've also tried googling what this "lib-android-ogre-3d/lib" could be, but I had no success.