[Solved] CMake: Could NOT find PkgConfig

Minor issues with the Ogre API that can be trivial to fix
Post Reply
ISJTrigger
Gnoblar
Posts: 2
Joined: Thu Jul 18, 2013 6:57 am

[Solved] CMake: Could NOT find PkgConfig

Post by ISJTrigger » Fri Jul 19, 2013 9:22 am

Hello, I am new here to Ogre and was wondering how I could fix this error when setting up CMake:

Code: Select all

Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
I already went through multiple problems (such as installing VC++ 2012 instead of 2010) and having the main Ogre directory listed in the wrong place. I could really use some help, I haven't the slightest idea what to do. I poked around a bit to see if anyone else had answered my questions but sadly all questions close to mine have had curveballs that don't quite fit my situation.

I am running Windows 8 32bit with OgreSDK_vc10_v1-8-1 and CMake 2.8.11.2 if that helps

Code: Select all

Looking for OGRE...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Found Ogre Byatis (1.8.1)
Found OGRE: optimized;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/release/OgreMain.lib;debug;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/debug/OgreMain_d.lib
Looking for OGRE_Paging...
Found OGRE_Paging: optimized;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/release/OgrePaging.lib;debug;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/debug/OgrePaging_d.lib
Looking for OGRE_Terrain...
Found OGRE_Terrain: optimized;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/release/OgreTerrain.lib;debug;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/debug/OgreTerrain_d.lib
Looking for OGRE_Property...
Found OGRE_Property: optimized;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/release/OgreProperty.lib;debug;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/debug/OgreProperty_d.lib
Looking for OGRE_RTShaderSystem...
Found OGRE_RTShaderSystem: optimized;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/release/OgreRTShaderSystem.lib;debug;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/debug/OgreRTShaderSystem_d.lib
Looking for OIS...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Found OIS: optimized;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/release/OIS.lib;debug;C:/OgreSDK/OgreSDK_vc10_v1-8-1/lib/debug/OIS_d.lib
Configuring done
I am generating for Visual Studio 10
Last edited by ISJTrigger on Sat Jul 20, 2013 3:24 am, edited 1 time in total.
0 x

User avatar
kulik
Gremlin
Posts: 183
Joined: Sun May 01, 2005 2:00 pm
Contact:

Re: CMake: Could NOT find PkgConfig

Post by kulik » Fri Jul 19, 2013 10:05 am

You are not supposed to use PkgConfig on Windows.

see http://www.freedesktop.org/wiki/Software/pkg-config/

The error is not really an error, it's an informative message. It's completely harmless. Please keep in mind that Ogre has many optional dependencies, you don't need to satisfy all of them.

HTH
0 x
mpreisler on IRC | CEGUI team member, CEGUI Unified Editor developer, OISB founder

ISJTrigger
Gnoblar
Posts: 2
Joined: Thu Jul 18, 2013 6:57 am

Re: CMake: Could NOT find PkgConfig

Post by ISJTrigger » Sat Jul 20, 2013 3:23 am

Thank you very much. Thank you for the quick reply, you have saved me quite a bit of time. I am pretty sure I understand where to go from here!
0 x

Post Reply