compiling ogre 2.1 windows 10

Discussion area about developing with Ogre2 branches (2.1, 2.2 and beyond)
Post Reply
User avatar
nevarim
Gnoll
Posts: 655
Joined: Mon Jul 05, 2010 6:16 pm
Location: Pavia Italy
Contact:

compiling ogre 2.1 windows 10

Post by nevarim » Sat Aug 20, 2016 12:08 am

hi all i have a problem with ogre 2.1

compiling ogre i have following errors

Code: Select all

Configuring OGRE 1.10.0unstable
Search path: Dependencies;D:/code/compiled/ogre/Dependencies;D:/code/source/ogre/Dependencies;D:/code/compiled/ogre/../Dependencies;D:/code/source/ogre/../Dependencies
Looking for ZLIB...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Found ZLIB: optimized;zlib;debug;zlib
Looking for ZZip...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Found ZZip: optimized;zziplib;debug;zziplib
Looking for FreeImage...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Found FreeImage: optimized;FreeImage;debug;FreeImage
Looking for FREETYPE...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
CMAKE_PREFIX_PATH: Dependencies;D:/code/compiled/ogre/Dependencies;D:/code/source/ogre/Dependencies;D:/code/compiled/ogre/../Dependencies;D:/code/source/ogre/../Dependencies
CMAKE_PREFIX_PATH: Dependencies;D:/code/compiled/ogre/Dependencies;D:/code/source/ogre/Dependencies;D:/code/compiled/ogre/../Dependencies;D:/code/source/ogre/../Dependencies
Found FREETYPE: optimized;freetype;debug;freetype
Looking for DirectX9...
Found DirectX9: C:/Program Files (x86)/Microsoft DirectX SDK (June 2010)/Lib/x64/d3d9.lib
Looking for DirectX11...
Found DirectX11: d3d11.lib;dxgi.lib;dxguid.lib
Looking for Cg...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Found Cg: optimized;D:/code/source/ogre/Dependencies/src/Cg/lib64/cg.lib;debug;D:/code/source/ogre/Dependencies/src/Cg/lib64/cg.lib
CMake Warning at D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:743 (message):
  Imported targets not available for Boost version
Call Stack (most recent call first):
  D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:842 (_Boost_COMPONENT_DEPENDENCIES)
  D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:1395 (_Boost_MISSING_DEPENDENCIES)
  CMake/Dependencies.cmake:180 (find_package)
  CMakeLists.txt:233 (include)


CMake Warning at D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:743 (message):
  Imported targets not available for Boost version
Call Stack (most recent call first):
  D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:842 (_Boost_COMPONENT_DEPENDENCIES)
  D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:1395 (_Boost_MISSING_DEPENDENCIES)
  CMake/Dependencies.cmake:180 (find_package)
  CMakeLists.txt:233 (include)


CMake Warning at D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:743 (message):
  Imported targets not available for Boost version
Call Stack (most recent call first):
  D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:842 (_Boost_COMPONENT_DEPENDENCIES)
  D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:1395 (_Boost_MISSING_DEPENDENCIES)
  CMake/Dependencies.cmake:189 (find_package)
  CMakeLists.txt:233 (include)


CMake Warning at D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:743 (message):
  Imported targets not available for Boost version
Call Stack (most recent call first):
  D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:842 (_Boost_COMPONENT_DEPENDENCIES)
  D:/code/cmake/share/cmake-3.6/Modules/FindBoost.cmake:1395 (_Boost_MISSING_DEPENDENCIES)
  CMake/Dependencies.cmake:189 (find_package)
  CMakeLists.txt:233 (include)


Looking for POCO...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Could not locate POCO
Looking for TBB...
Could not locate TBB
Looking for GLSL_Optimizer...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Could not locate GLSL_Optimizer
Looking for HLSL2GLSL...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Could not locate HLSL2GLSL
Looking for OIS...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Found OIS: optimized;OIS;debug;OIS
Could NOT find Doxygen (missing:  DOXYGEN_EXECUTABLE) 
Looking for Softimage...
Could not locate Softimage
Could NOT find TinyXML (missing:  TINYXML_INCLUDE_DIR TINYXML_LIBRARIES) 
Looking for CppUnit...
Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
Could not locate CppUnit
Looking for DirectX...
Found DirectX: C:/Program Files (x86)/Windows Kits/10/Lib/10.0.14393.0/um/x64/d3d9.lib
DX lib dir: C:/Program Files (x86)/Windows Kits/10/Lib/10.0.14393.0/um/x64
DX lib dir: C:/Program Files (x86)/Windows Kits/10/Lib/10.0.14393.0/um/x64

-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ zlib
+ zziplib
+ freeimage
+ freetype
+ OpenGL
+ OpenGL 3+
+ OpenGL ES 1.x
+ OpenGL ES 2.x
+ OpenGL ES 3.x
+ DirectX9
+ DirectX11
+ cg
+ OIS
-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
+ boost: Boost (general) <http://boost.org>
+ boost-thread: Used for threading support <http://boost.org>
+ boost-date_time: Used for threading support <http://boost.org>
+ POCO: POCO framework <http://pocoproject.org/>
+ tbb: Threading Building Blocks <http://www.threadingbuildingblocks.org/>
+ GLSL Optimizer: GLSL Optimizer <http://github.com/aras-p/glsl-optimizer/>
+ HLSL2GLSL: HLSL2GLSL <http://hlsl2glslfork.googlecode.com/>
+ Doxygen: Tool for building API documentation <http://doxygen.org>
+ Softimage: Softimage SDK needed for building XSIExporter <FALSE>
+ TinyXML: TinyXML needed for building OgreXMLConverter <FALSE>
+ CppUnit: Library for performing unit tests <http://cppunit.sourceforge.net>
-----------------------------------------------------------------------------

send_errorD:/code/source/ogre/Dependencies/src/bin/debug/OIS_d.dll did not exist, can't install!
send_errorD:/code/source/ogre/Dependencies/src/bin/release/OIS.dll did not exist, can't install!
send_errorD:/code/source/ogre/Dependencies/src/bin/debug/cg.dll did not exist, can't install!
send_errorD:/code/source/ogre/Dependencies/src/bin/release/cg.dll did not exist, can't install!

----------------------------------------------------------------------------
  FEATURE SUMMARY
----------------------------------------------------------------------------

Building components:
  + Paging
  + MeshLodGenerator
  + Property
  + Terrain
  + RTShader System
  + RTShader System Core Shaders
  + RTShader System Extensions Shaders
  + Volume
  + Overlay
  + HLMS
Building plugins:
  + BSP scene manager
  + Cg program manager
  + Octree scene manager
  + Portal connected zone scene manager
  + Particle FX
Building rendersystems:
  + Direct3D 9
  + Direct3D 11
  + OpenGL
Building executables:
  + Samples
  + Tools
Building core features:
  + Mesh Lod
  + DDS image codec
  + FreeImage codec
  + ZIP archives

Build type:                      dynamic
Threading support:               none
Use double precision:            disabled
Nodes inherit transform:         disabled
Assert mode:                     standard
Allocator type:                  standard
STL containers use allocator:    enabled
Strings use allocator:           disabled
Memory tracker (debug):          disabled
Memory tracker (release):        disabled
Use Boost:                       disabled

----------------------------------------------------------------------------

Configuring done
i'm using
https://bitbucket.org/sinbad/ogre/branch/v2-1
https://bitbucket.org/cabalistic/ogrede ... ch/default
dependencies are downloaded in subfolder Dependencies

thanks
Nevarim
0 x
i'm a noob until proven otherwise :D
used in my project ;) and thanks to everyone :D
Ogre 3d
Mygui
Skyx
Hydrax
MOC
CCS

User avatar
Thyrion
Goblin
Posts: 224
Joined: Wed Jul 31, 2013 1:58 pm
Location: germany

Re: compiling ogre 2.1 windows 10

Post by Thyrion » Sat Aug 20, 2016 12:33 am

check OGRE_BUILD_SAMPLES2
uncheck OGRE_BUILD_SAMPLES (not working)

only the following is working:
Building components:
+ MeshLodGenerator
+ Overlay
Building plugins:
+ Particle FX
Building rendersystems:
+ Direct3D 11
+ OpenGL 3.3+

you'll need SDL2 for samples2, too.

good luck :)
0 x

User avatar
dark_sylinc
OGRE Team Member
OGRE Team Member
Posts: 3985
Joined: Sat Jul 21, 2007 4:55 pm
Location: Buenos Aires, Argentina
x 184
Contact:

Re: compiling ogre 2.1 windows 10

Post by dark_sylinc » Sat Aug 20, 2016 12:35 am

The CMake log you posted says you're using Ogre 1.10

For compiling under Windows:
  • Checkout the repository via Mercurial. Don't use the feature "download as zip" from Bitbucket (this is important!).
  • See the CMake Quick Start Guide for compiling on Windows. There's a video as well.
  • For Ogre 2.1, leave the default CMake Ogre settings (except OGRE_BUILDS_SAMPLES2 to enable compiling the samples)
Cheers.
0 x

User avatar
Thyrion
Goblin
Posts: 224
Joined: Wed Jul 31, 2013 1:58 pm
Location: germany

Re: compiling ogre 2.1 windows 10

Post by Thyrion » Sat Aug 20, 2016 12:38 am

ups, correct. first line in log...
Configuring OGRE 1.10.0unstable
0 x

User avatar
nevarim
Gnoll
Posts: 655
Joined: Mon Jul 05, 2010 6:16 pm
Location: Pavia Italy
Contact:

Re: compiling ogre 2.1 windows 10

Post by nevarim » Sat Aug 20, 2016 11:51 am

Thyrion wrote:ups, correct. first line in log...
Configuring OGRE 1.10.0unstable
what you mean? i'm compiling ogre 2.1 not 1.10 untable why cmake is trying to compile 1.10?
0 x
i'm a noob until proven otherwise :D
used in my project ;) and thanks to everyone :D
Ogre 3d
Mygui
Skyx
Hydrax
MOC
CCS

User avatar
Thyrion
Goblin
Posts: 224
Joined: Wed Jul 31, 2013 1:58 pm
Location: germany

Re: compiling ogre 2.1 windows 10

Post by Thyrion » Sat Aug 20, 2016 12:32 pm

nevarim wrote:what you mean? i'm compiling ogre 2.1 not 1.10 untable why cmake is trying to compile 1.10?
because you checked out the default branch?
I'm using sourcetree for bitbucket. you should select the v2-1 branch.
sourcetree.jpg
Else check your cmake sourcefolder setting again ;)
My cmake log says "Configuring OGRE 2.1.0unstable", so yours is definitly not 2.1.
0 x

User avatar
nevarim
Gnoll
Posts: 655
Joined: Mon Jul 05, 2010 6:16 pm
Location: Pavia Italy
Contact:

Re: compiling ogre 2.1 windows 10

Post by nevarim » Sat Aug 20, 2016 4:02 pm

solved thanks for help :D now i have to learn what's new in this version :D
0 x
i'm a noob until proven otherwise :D
used in my project ;) and thanks to everyone :D
Ogre 3d
Mygui
Skyx
Hydrax
MOC
CCS

Post Reply