[News] Ogre 1.8.1 [Byatis] released!

News, announcements and important global threads from the Ogre3D Team.
Post Reply
User avatar
OgreNewsBot
Your source of official Ogre news
Posts: 33
Joined: Mon Mar 21, 2011 10:56 am

[News] Ogre 1.8.1 [Byatis] released!

Post by OgreNewsBot » Sun Sep 02, 2012 8:37 pm

The first maintenance release for the 1.8 stable branch (codenamed ‘Byatis’) is now available. You can find a list of all the bug fixes after the jump. There have been quite a few, so if you are having trouble with the previous release, check this one out. Maybe your problem has already been fixed. If not, let us know.
Meanwhile, most of this year’s GSoC projects have been merged into the unstable v1-9 branch – which of course you can grab from Mercurial if you want to join us on the bleeding edge.

So far the source releases are ready for download for 1.8.1, the SDK releases are currently being prepared and will be available within the next few days. If you don’t want to wait, give the source release a try :)
Read the full change log here: http://www.ogre3d.org/2012/09/02/ogre-1 ... s-released
0 x

notNullGothik
Gnoblar
Posts: 13
Joined: Thu Jul 07, 2011 4:16 pm

Re: [News] Ogre 1.8.1 [Byatis] released!

Post by notNullGothik » Thu Sep 06, 2012 2:56 pm

Sorry, regarding the crash I get to Run SampleBrowser for x64 target, Win7

Code: Select all

 OGRE EXCEPTION(5:ItemIdentityException): Cannot find an archive factory to deal with archive of type Zip in ArchiveManager::load at src/OgreARchiveManager.cpp
And considering the response I got in this Dependencies thread, is this a known problem for this version? or do I need to get the dependencies from here to verify? http://www.bitbucket.org/cabalistic/ogredeps
0 x

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7142
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 9

Re: [News] Ogre 1.8.1 [Byatis] released!

Post by Kojack » Fri Sep 07, 2012 3:34 pm

I'm not sure where that dependency package came from (I don't have admin access to the sourceforge page), but I've taken a look at it and it's broken in several ways.
For example, the contents are over 4 months out of date, the post build events have problems (it renames cg.dll to debug instead of putting it in a debug directory, there's missing path errors when built), the zlib vc2010 project file is in the visualc6 directory, includes are installed but binaries and libs fail.

(Ok, I think I see where it came from now, it was a slight update to an old dep package that shouldn't be used anymore. Back in 2009 we used deps like that, but now it's all done with cmake and mercurial)

So basically the deps package OgreDependencies_MSVC_20120819.zip shouldn't be used. The repository at http://www.bitbucket.org/cabalistic/ogredeps is the official one we use.
0 x

notNullGothik
Gnoblar
Posts: 13
Joined: Thu Jul 07, 2011 4:16 pm

Re: [News] Ogre 1.8.1 [Byatis] released!

Post by notNullGothik » Fri Sep 07, 2012 3:46 pm

Thank you Kojack!
Am going to re-compile using the sources from the official repository, hope this will be enough to fix the issue. Keep you up to date.

Edit: it compiled and executed good with official dependencies for me, a bit more steps than before but x64 is running ;)
0 x

Zero_Zero
Gnoblar
Posts: 4
Joined: Thu Sep 13, 2012 6:09 pm

Re: [News] Ogre 1.8.1 [Byatis] released!

Post by Zero_Zero » Mon Sep 24, 2012 9:25 pm

Using the official Deps didn't work for me. I get the same Ogre Exception 5
0 x


Zero_Zero
Gnoblar
Posts: 4
Joined: Thu Sep 13, 2012 6:09 pm

Re: [News] Ogre 1.8.1 [Byatis] released!

Post by Zero_Zero » Tue Sep 25, 2012 12:09 pm

Okay I got Ogre 1.8.1 to build with OgreDependencies_MSVC_20120819. It may build with offical Deps. The problem I was having was that C-Make was putting the dependencies in every project instance, so I ignorantly went about taking them out of the ones I thought that didn't need them. C-Make also seems to not put the Ogre lib path into any of the projects. I'm probably not setting up C-Make with Ogre correctly, but in my defense, the C-Make build documentations for Ogre and it's dependencies are pretty confusing...
0 x

Zero_Zero
Gnoblar
Posts: 4
Joined: Thu Sep 13, 2012 6:09 pm

Re: [News] Ogre 1.8.1 [Byatis] released!

Post by Zero_Zero » Tue Sep 25, 2012 12:11 pm

Transporter: I have seen that topic thread, and I will probably end up building OgreMain again with one of your Dep packages. Thanks for your support :)
0 x

ivador
Gnoblar
Posts: 12
Joined: Sun Oct 07, 2012 10:37 am

Re: [News] Ogre 1.8.1 [Byatis] released!

Post by ivador » Sun Oct 07, 2012 11:13 am

Hello. I have a problem. I would like to execute "SampleBrowser.exe" but I can´t find it! Could you help me, please?
0 x

Post Reply