[News] Ogre 1.9 RC1 is here

News, announcements and important global threads from the Ogre3D Team.
User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

[News] Ogre 1.9 RC1 is here

Post by spacegaier » Sun Apr 21, 2013 11:03 pm

All the details as well as the changelog can be found here: http://www.ogre3d.org/2013/04/21/ogre-1-9-rc1-is-here
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

User avatar
Wolfmanfx
OGRE Team Member
OGRE Team Member
Posts: 1525
Joined: Fri Feb 03, 2006 10:37 pm
Location: Austria - Leoben
x 1
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by Wolfmanfx » Sun Apr 21, 2013 11:08 pm

Finally its out!
0 x

User avatar
Jefferian
Halfling
Posts: 63
Joined: Sun Jun 12, 2011 12:53 am
Location: Italy

Re: [News] Ogre 1.9 RC1 is here

Post by Jefferian » Sun Apr 21, 2013 11:17 pm

Oh, quite nice indeed. Is an SDK for MinGW planned as well, by chance?
0 x

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by spacegaier » Sun Apr 21, 2013 11:39 pm

Jefferian wrote:Oh, quite nice indeed. Is an SDK for MinGW planned as well, by chance?
We discussed it internally, but decided against it, because it would mean that we'd need to create 10+ SDK versions as there are so many different (compiler) versions out there and chances are that many users would have to build Ogre themselves anyway.

A little extract from the discussions:
There will not be a 1.9 SDK for MinGW.
It simply won't work for the majority of people, each using different compiler versions. It only leads to confused users, asking why the SDK does not work, when the answer in 99% of cases is incompatibility with the MinGW version*.
In most cases, it's the fault of that blasted Code::Blocks coming with its own outdated MinGW version :/
*Heck, even when two versions state "GCC 4.7.0", they can still be incompatible when coming from different sources, one being from mingw-w64, for example.

And 1) I do not want to create 10+ SDKs for current versions (most new-to-programming users would probably not know which one to pick anyway)
and 2) I do not want to force users to use specific compiler versions if they want to use the SDK.
There was talk about some sort of intelligent installer at some point that will detect your environment and then prepare a matching download, but that is future-talk of course ;) .

So for now, we can only point you to this good guide that explains all necessary steps: http://www.ogre3d.org/tikiwiki/tiki-ind ... +and+MinGW
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

scrawl
OGRE Expert User
OGRE Expert User
Posts: 1119
Joined: Sat Jan 01, 2011 7:57 pm
x 2

Re: [News] Ogre 1.9 RC1 is here

Post by scrawl » Mon Apr 22, 2013 12:18 am

So state caching won't make it into 1.9? :(
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by jacmoe » Mon Apr 22, 2013 12:30 am

Very cool!
Congratulations, Ogre Team! :D
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
Posts: 4270
Joined: Sun Feb 25, 2007 4:56 am
Location: Bloomington, MN
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by masterfalcon » Mon Apr 22, 2013 4:18 am

State caching is in but initially just for GLES 1 and 2.
0 x

TheSHEEEP
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 972
Joined: Mon Jun 02, 2008 6:52 pm
Location: Berlin

Re: [News] Ogre 1.9 RC1 is here

Post by TheSHEEEP » Mon Apr 22, 2013 7:00 am

spacegaier wrote:
There will not be a 1.9 SDK for MinGW.
It simply won't work for the majority of people, each using different compiler versions. It only leads to confused users, asking why the SDK does not work, when the answer in 99% of cases is incompatibility with the MinGW version*.
In most cases, it's the fault of that blasted Code::Blocks coming with its own outdated MinGW version :/
*Heck, even when two versions state "GCC 4.7.0", they can still be incompatible when coming from different sources, one being from mingw-w64, for example.

And 1) I do not want to create 10+ SDKs for current versions (most new-to-programming users would probably not know which one to pick anyway)
and 2) I do not want to force users to use specific compiler versions if they want to use the SDK.
There was talk about some sort of intelligent installer at some point that will detect your environment and then prepare a matching download, but that is future-talk of course ;) .
Adding to that, I am actually working on that installer. I try to shuffle one day free for that each weekend. Right now, it already asks the user some questions (like pointing to your MinGW & CMake if it can't detect it, desired install location, etc.) and downloads boost. It will take some weeks until I can release a first public version, but I'm positive that we will see it happen :)

One mistake in spacegaier's post, though. It will not download the SDK, it will download boost (optionally), the dependencies and Ogre sources, then build it, using the user's MinGW version.

The first version will be only MinGW, but I see no reason that it should stay that way forever.
0 x
My site! - Have a look :)
Also on Twitter - extra fluffy

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7146
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 14

Re: [News] Ogre 1.9 RC1 is here

Post by Kojack » Mon Apr 22, 2013 7:34 am

Some more notes on 1.9 RC1.

The main purpose of a Release Candidate like this is for users to help us do the last minute testing on a wide range of hardware before we do the 1.9 final release. So if there's any bugs in the sample browser, please report them. Especially if you have ATI/AMD or Intel gpus, they tend to be the most fussy with shaders. The sooner we can knock off any important final shader bugs, the sooner 1.9 Final can be released.

This is also the first time we've included 64 bit sdks for visual studio. So there are 6 sdks to choose from, 32bit and 64bit versions for VC++2008, VC++2010 and VC++2012.
When using a 64 bit sdk, everything you use with it MUST be 64 bit as well (every other library such as audio, physics, etc). You can't mix and match 32 bit code with 64 bit code. Using the 32bit sdks on 64bit windows is fine though.
32bit is better tested too, so it's probably preferable if you don't need the extra memory support. I haven't done any tests on performance between 32bit and 64bit yet.

Finally, the Visual C++ 2008 and 2010 sdks require the matching Visual Studio service pack 1 to be installed.
Edit: The Visual C++ 2012 sdks require Visual Studio 2012 Update 2 to be installed.
0 x

User avatar
AshMcConnell
Silver Sponsor
Silver Sponsor
Posts: 605
Joined: Fri Dec 14, 2007 11:44 am
Location: Northern Ireland
x 3
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by AshMcConnell » Tue Apr 23, 2013 8:40 pm

Hi Folks,

Anyone else getting linking errors with the VS 2012 SDK (I'm using Update 2)? It seems to be having trouble with Vector3::ZERO and Vector3::UNIT_SCALE. I just wanted to check if it was just me (perhaps doing something silly) or a more general problem. I am trying to build in release mode. I'll continue investigating.

Edit - Same problems in debug mode

An example: -

Code: Select all

Error	1	error LNK2019: unresolved external symbol "public: static class Ogre::Vector3 const Ogre::Vector3::ZERO" (?ZERO@Vector3@Ogre@@2V12@B) referenced in function "public: __thiscall Ogre::AxisAlignedBox::AxisAlignedBox(float,float,float,float,float,float)" (??0AxisAlignedBox@Ogre@@QAE@MMMMMM@Z)	I:\downloads\Coding\Ogre\OgreSDK_vc11_v1-9-0unstable\Samples\VolumeTex\ThingRenderable.obj
All the best,
Ash
0 x

Transporter
Minaton
Posts: 933
Joined: Mon Mar 05, 2012 11:37 am
Location: Germany
x 1

Re: [News] Ogre 1.9 RC1 is here

Post by Transporter » Tue Apr 23, 2013 9:00 pm

It's working. See the Topic in my signature.
0 x

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7146
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 14

Re: [News] Ogre 1.9 RC1 is here

Post by Kojack » Tue Apr 23, 2013 10:43 pm

It's probably the update thingy. I don't have any updates to vs2012 installed (I didn't realise they've dropped the service pack concept and use the term update now). I'll upgrade and rebuild.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by jacmoe » Tue Apr 23, 2013 11:13 pm

You are right, Kojack: now updates to Ms products is done by Microsoft Update.
In order to receive those, you need to turn Ms Update on - otherwise you'll be using Windows Update (not the same thing). :)
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7146
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 14

Re: [News] Ogre 1.9 RC1 is here

Post by Kojack » Wed Apr 24, 2013 12:27 am

jacmoe wrote:You are right, Kojack: now updates to Ms products is done by Microsoft Update.
In order to receive those, you need to turn Ms Update on - otherwise you'll be using Windows Update (not the same thing). :)
Or just go to http://www.microsoft.com/visualstudio/eng/downloads
:)

Hmm, I just installed Update 2 (this is on a different computer to the one I built the sdk on) and it can build all the samples fine with the non updated sdks.

There's already a community tech preview release of Update 3, it came out only 11 days after Update 2.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by jacmoe » Wed Apr 24, 2013 12:57 am

Kojack wrote:Hmm, I just installed Update 2 (this is on a different computer to the one I built the sdk on) and it can build all the samples fine with the non updated sdks.
Sounds like the updates didn't touch VC then.
What is not broken, should not be fixed, IMO. :)
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7146
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 14

Re: [News] Ogre 1.9 RC1 is here

Post by Kojack » Wed Apr 24, 2013 1:23 am

There's a bunch of VC fixes in it. http://support.microsoft.com/kb/2797912
They just don't seem to be related to linking errors in ogre's vector3 constants.
0 x

User avatar
AshMcConnell
Silver Sponsor
Silver Sponsor
Posts: 605
Joined: Fri Dec 14, 2007 11:44 am
Location: Northern Ireland
x 3
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by AshMcConnell » Wed Apr 24, 2013 7:47 am

Kojack wrote: Hmm, I just installed Update 2 (this is on a different computer to the one I built the sdk on) and it can build all the samples fine with the non updated sdks.
Thanks Kojack, sorry for wasting your time, it must be something particular to my setup. I didn't have much time to debug last night (fatherly duties!), hopefully I'll get more time tonight.

I did notice that some of the samples were crashing (I downloaded transporter's pre-compiled samples). I've got a fairly modern card (560Ti). I'll run through all the samples and report back tonight (hopefully!)

Thanks!
Ash
0 x

User avatar
Herb
Orc
Posts: 412
Joined: Thu Jun 04, 2009 3:21 am
Location: Kalamazoo,MI
x 1

Re: [News] Ogre 1.9 RC1 is here

Post by Herb » Wed Apr 24, 2013 3:15 pm

Great job guys! I'm excited to look into the OpenGL 3 rendering system for some Linux performance gains. I see in the news it's still experimental and under heavy development. Does that mean 1.9 officially will be released with it tagged experimental, or is there a goal to stabilize that during this RC time?
0 x

User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
Posts: 4270
Joined: Sun Feb 25, 2007 4:56 am
Location: Bloomington, MN
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by masterfalcon » Wed Apr 24, 2013 3:26 pm

The plan is to make it stable but to still be experimental. With improvements being made throughout the 1.9 series.
0 x

User avatar
AshMcConnell
Silver Sponsor
Silver Sponsor
Posts: 605
Joined: Fri Dec 14, 2007 11:44 am
Location: Northern Ireland
x 3
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by AshMcConnell » Wed Apr 24, 2013 7:46 pm

Hi Folks,

I haven't managed to get it to link, I have checked all the global include / lib folders in case it's trying to link with an old version of ogre, but there is nothing there. In any case I tried all the samples with the d3d11 renderer. It seems that it might not be detecting my card properly (it's a 560Ti with Drivers 311.06)

BSPS - Wouldn't load, says my card can't handle it
Bezier Patch - Works
Bump Mapping - Works
Camera Tracking - Works
Cel-Shading - Works
Character - Works
Compositor - Works
Cube Mapping - Works
Deferred Shading: -
OGRE EXCEPTION(7:InternalErrorException): Unable to compile Cg program 1ddfe90d-ceb7-9407-6ddc-25ee88b6d581_VS: The compile returned an error.
(651) : error C5102: output semantic attribute "TEXCOORD" has too big of a numeric index (8)
(652) : error C5102: output semantic attribute "TEXCOORD" has too big of a numeric index (9)
(653) : error C5102: output semantic attribute "TEXCOORD" has too big of a numeric index (10)
(654) : error C5102: output semantic attribute "TEXCOORD" has too big of a numeric index (11)
(655) : error C5102: output semantic attribute "TEXCOORD" has too big of a numeric index (12)
(656) : error C5102: output semantic attribute "TEXCOORD" has too big of a numeric index (13)
in CgProgram::compileMicrocode at ..\..\..\PlugIns\CgProgramManager\src\OgreCgProgramManagerDll.cpp (line 67)
19:12:30: OGRE EXCEPTION(2:InvalidParametersException): Could not create gpu programs from render state in ProgramManager::acquireGpuPrograms at ..\..\..\Components\RTShaderSystem\src\OgreShaderProgramManager.cpp (line 109)

Quaternion Skinning - Works
Dynamic Texturing - Works
Endless World - Works - but no WASD movement
Facial Animation - Works
Geometry Shader - Says card can't handle it
Grass - Works
Instancing - Works
IsoSurf - Says card can't handle it
Lighting - Works
MeshLoad - Works
New Instancing - Works
Ocean - Works
Particles - Works
SSAO - Works
Shader System - Works
Textured Fog - Works
Multi Light - Works
Shadows - Works
Skeletal Animation - Works
Sky Box - Works
Sky Dome - Works
Sky Plane - Works
Smoke - Works with good framerate 2000+ FPS, but has bad jerking where it stops for perhaps 0.5 secs every few seconds.
Sphere Mapping - Works
Terrain - Works
Tessellation - Says card can't handle it
Texture Array - Unknown texture type
Texture Effects - Works
Transparency - Works
Volume CSG and RTSS triplanar texturing - Works
Volume Terrain - Works
Volume Textures - Works
Water - Works

Hope this helps!
All the best,
Ash
0 x

User avatar
saejox
Goblin
Posts: 260
Joined: Tue Oct 25, 2011 1:07 am

Re: [News] Ogre 1.9 RC1 is here

Post by saejox » Wed Apr 24, 2013 10:15 pm

Let me perform my civic duty.
I have a gtx560 and driver 314.07
here are the results:

- Overlays have visible seams. Gets worse after unload/load few samples`
- dual quaternion skinning, crashes at start up
- dynamic texture, ice texture is red not white
- endless world, pitch black with pauses every second and never shows anything
- facial animation, horrifying teeth man :O
-fresnel, stop rendering underwater when camera is inside water plane.(find in dx9)
- instancing, exception. null program bound
- isosurf, pitch black
- new instancing, does not render any robots
- ssao, exception null program bound
- shader system, light billboards rendered incorrectly, shadow throws exception Unable to set dc311 vertex declaration
- shadows, attempted to render to a d3d11 decive without both vertex and fragment shaders ...
- skeletal animation, can't do hardware skinning
- terraan, there is no terrain only houses
- tessellation, triangle is renderer but there is any tessellation happening
- volume terrain, error creating texture invalid parameters were passed

Samples not metioned are working fine.
Samples worked fine in dx9
0 x
Nimet - Advanced Ogre3D Mesh/dotScene Viewer
asPEEK - Remote Angelscript debugger with html interface
ogreHTML - HTML5 user interfaces in Ogre

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7146
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 14

Re: [News] Ogre 1.9 RC1 is here

Post by Kojack » Wed Apr 24, 2013 11:34 pm

There's a gsoc project that's been fixing up the dx11 renderer and the samples. But it's fork hasn't been merged into the 1.9 branch yet (it's still being worked on). So hopefully all the dx11 sample bugs will be fixed when that happens.
0 x

User avatar
robert_sasu
Google Summer of Code Student
Google Summer of Code Student
Posts: 238
Joined: Mon Apr 02, 2012 11:07 am

Re: [News] Ogre 1.9 RC1 is here

Post by robert_sasu » Thu Apr 25, 2013 8:53 am

All the GSoC 2012 work was merged after the summer ended last year. It was a much more bigger project then it could be done in one GSoC (the change set after GSoC 2012 contained more then 20K lines and touched more then 200 files). I have continued to work on DX11 after that and made a few pull request. Everything was accepted. If you look at pull request #98 there is the next part of corrected samples, RS and a new tessellation sample (PN-Patches). The pull request was created 10 days ago and will be merged probably tomorrow (as @Assaf said).
If you want to be in touch with the work then follow the http://www.ogre3d.org/forums/viewtopic. ... &start=675 topic.
0 x
Google Summer of Code 2013 Student
Topic: "DirectX 11 & Tessellation samples"
Project links: Project thread, WIKI page, Code fork for the project
Mentor: Assaf Raman

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7146
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 14

Re: [News] Ogre 1.9 RC1 is here

Post by Kojack » Thu Apr 25, 2013 11:54 am

Awesome. I wasn't following the full progress but I was hoping the recent fixes you mentioned in the dx11 thread would be able to get into 1.9 before it turns final.
0 x

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: [News] Ogre 1.9 RC1 is here

Post by spacegaier » Fri Apr 26, 2013 4:28 pm

SDKs (32bit and 64bit) for Visual Studio 2012 / VC11 have been updated. Can be downloaded from the same link as before.
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

Post Reply