[Announcement] Ogre3D 1.9 released as 'stable'

News, announcements and important global threads from the Ogre3D Team.
User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

[Announcement] Ogre3D 1.9 released as 'stable'

Post by spacegaier » Sun Nov 24, 2013 1:49 pm

Good news! We finally tagged the Ogre 1.9 branch as 'stable', making it the new current and recommended version. We would advise you to update wherever possible, to benefit from all the fixes and improvements that made their way into the new release.

Right now, we don't have any published SDKs yet, since we still rely on team and community members to help with the building and packaging process and that takes some time of course (we have it on our list to automate that process, but so far there always were more pressing topics to tackle ;) ). But I have already heard that Windows SDKs are well underway and I expect the other ones to surface soon as well. We will update the download page as they become available and also try to update the announcement post in the forums.

For an outline of the changes, have a look at the collected Ogre 1.9 change log in the wiki and at our JIRA tracker for all tickets fixed/solved by 1.9.

So what's next? We are already working on Ogre 1.10 which will contain the changes from three of our five GSoC 2013 projects (details in the planning thread). In parallel, the work on the revamped Ogre 2.0 will continue as well...we've also got a related news post upcoming that will support those efforts. But as usual, we heavily rely on you as he community to support us with JIRA tickets, tracking down bugs and creating patches and adding new features. So chime in, whenever possible. Thanks!

BTW: With the release of Ogre 1.9 and the start of development for Ogre 1.10, we took the opportunity to get back to properly using the 'default' branch, meaning Ogre 1.9 has been merged into it as well as Ogre 1.10 (which then was closed off), so 'default' is once again our bleeding edge for development and preparation of Ogre 1.10. Please use it as the target for all pull-requests unless they are specifically meant for either Ogre 1.9 (only bug fixes) or Ogre 2.0.

-----------------------------------------------------

Reference: http://www.ogre3d.org/2013/11/24/ogre3d ... -as-stable
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7144
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 14

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by Kojack » Sun Nov 24, 2013 6:41 pm

Timezones and work commitments of various team members involved mean it's hard to get all the sdks out at the same time.

But 32 bit VC2008, VC2010 and VC2012 should be out within the next 24 hours, 64 bit sdks soon after. IOS and OSX have had test builds done, final release builds won't be up for at least a day or two.

MingW binaries aren't being released, because slightly different versions of MingW will cause way too many hard to track down problems. You really need both ogre and your own stuff built with the exact same version of MingW, so it's best to do it via source.

No idea about the others, but they should be on the way soon.
0 x

User avatar
Klaim
Old One
Posts: 2565
Joined: Sun Sep 11, 2005 1:04 am
Location: Paris, France
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by Klaim » Sun Nov 24, 2013 7:24 pm

Congrats guys!
BTW: With the release of Ogre 1.9 and the start of development for Ogre 1.10, we took the opportunity to get back to properly using the 'default' branch, meaning Ogre 1.9 has been merged into it as well as Ogre 1.10 (which then was closed off), so 'default' is once again our bleeding edge for development and preparation of Ogre 1.10. Please use it as the target for all pull-requests unless they are specifically meant for either Ogre 1.9 (only bug fixes) or Ogre 2.0.
Were you using the gitflow model before? Did you have bad experience with it?
0 x

User avatar
cybereality
Hobgoblin
Posts: 563
Joined: Wed Jul 12, 2006 5:40 pm

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by cybereality » Sun Nov 24, 2013 11:29 pm

Awesome work! Can't wait to give this a go.
0 x

Shtuka
Greenskin
Posts: 146
Joined: Mon Jan 10, 2011 7:39 pm

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by Shtuka » Mon Nov 25, 2013 10:59 am

What about VC++ 2013?
0 x

User avatar
chaosavy
Silver Sponsor
Silver Sponsor
Posts: 570
Joined: Mon Jun 15, 2009 8:29 pm
x 5
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by chaosavy » Mon Nov 25, 2013 3:03 pm

Great! Void Destroyer has been recently upgraded to 1.9 RC1 - so looking forward to stable :)
0 x
Visit http://www.VoidDestroyer.com to check out my space sim project - Void Destroyer

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by spacegaier » Fri Nov 29, 2013 7:46 pm

Update: First SDKs for VS2008/2010/2012 32-bit are online.
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

User avatar
Kojack
OGRE Moderator
OGRE Moderator
Posts: 7144
Joined: Sun Jan 25, 2004 7:35 am
Location: Brisbane, Australia
x 14

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by Kojack » Sat Nov 30, 2013 5:00 am

The stand alone 1.9 sample browser (just binaries, using VC2010 so you'll need appropriate vc runtime and directx runtime) is also now available in the Demo section of the main ogre website.
0 x

RigoCL
Greenskin
Posts: 114
Joined: Mon Oct 14, 2013 1:41 am
Location: Chile

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by RigoCL » Sat Nov 30, 2013 3:08 pm

Downloading&testing VC10 and porting my own apps.

Great work guys!!!

Thanks a lot for making this possible.
0 x
Integrated: Ogre3D + dotScene (Blender loader) + MyGUI (UI) + RakNet (Client/Server) + Leap Motion (The future is here!) + StereoManager (3D Anaglyph red-cyan)
WIP: StereoManager (Real 3D) + CCS (Camera Control System) + Sound, experimenting with Android.

RigoCL
Greenskin
Posts: 114
Joined: Mon Oct 14, 2013 1:41 am
Location: Chile

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by RigoCL » Sat Nov 30, 2013 3:11 pm

Shtuka wrote:What about VC++ 2013?
Go, make it and upload it!!

That's what this is all about, isn't it?

:wink:
0 x
Integrated: Ogre3D + dotScene (Blender loader) + MyGUI (UI) + RakNet (Client/Server) + Leap Motion (The future is here!) + StereoManager (3D Anaglyph red-cyan)
WIP: StereoManager (Real 3D) + CCS (Camera Control System) + Sound, experimenting with Android.

scrawl
OGRE Expert User
OGRE Expert User
Posts: 1119
Joined: Sat Jan 01, 2011 7:57 pm
x 2

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by scrawl » Sat Nov 30, 2013 6:52 pm

There is a showstopper crash on linux (at least with GCC 4.8 ), and only in the Release configuration. http://www.ogre3d.org/forums/viewtopic. ... 19#p499219
Any help with tracking down the issue would be appreciated.
0 x

scrawl
OGRE Expert User
OGRE Expert User
Posts: 1119
Joined: Sat Jan 01, 2011 7:57 pm
x 2

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by scrawl » Sat Nov 30, 2013 9:55 pm

I found the issue :) Pull request is here: https://bitbucket.org/sinbad/ogre/pull- ... in-19/diff

How do you want to handle this? Re-tag 1.9.0 or create a 1.9.1 tag? I'd say that we don't need to keep a broken tag.
0 x

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by spacegaier » Sat Nov 30, 2013 11:29 pm

Initially, I would have said "stay with 1.9.0" since in the past we always made bug fixes in the released branch and then from time to time bundled them in a new minor release. But then again, this seems to be a rather drastic bug and we probably need to rebuild all SDKs either way.

Slightly OT: I general I would not too much focus on the tags itself, regardless of whether we decide to go for a new Ogre release v1.9.1 or not. I would never advise someone to grab the source from the specific tagged version, but the latest from the respective branch. Just a general comment...
scrawl wrote:How do you want to handle this? Re-tag 1.9.0 or create a 1.9.1 tag? I'd say that we don't need to keep a broken tag.
I notified the other team members of this thread, to also gauge their opinion.
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

User avatar
lingfors
Hobgoblin
Posts: 505
Joined: Mon Apr 02, 2007 12:18 am
Location: Sweden

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by lingfors » Sun Dec 01, 2013 12:59 am

I'd say definitely don't re-tag, that's a recipe for disaster...
0 x

fabio71
Gnoblar
Posts: 11
Joined: Thu May 12, 2011 10:18 am

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by fabio71 » Mon Dec 02, 2013 9:55 am

Thank you very much guys, I was looking at the pre-built SDKs and they are coming. But there is one thing I'm curious to ask: why you keep adding the .Net word to the Visual C++ versions? I mean "Visual C++ .Net 2012", "Visual C++ .Net 2010" and so on. I remember the .Net word disappeared from the product name starting from Visual Studio 2005. Have a look here
http://en.wikipedia.org/wiki/Visual_studio and here http://en.wikipedia.org/wiki/Visual_C%2B%2B
I know, it's not very important but it could be interpreted as a .Net library which of course it isn't.
0 x

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by spacegaier » Mon Dec 02, 2013 10:25 am

Copy/Paste is the culprit ;) . But you are correct. I just changed it.
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

fabio71
Gnoblar
Posts: 11
Joined: Thu May 12, 2011 10:18 am

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by fabio71 » Mon Dec 02, 2013 10:55 am

Thank you spacegaier, now it looks perfect! :)
0 x

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by spacegaier » Mon Dec 02, 2013 10:59 am

fabio71 wrote:Thank you spacegaier, now it looks perfect! :)
We aim to please :D .
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

User avatar
chaosavy
Silver Sponsor
Silver Sponsor
Posts: 570
Joined: Mon Jun 15, 2009 8:29 pm
x 5
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by chaosavy » Wed Dec 04, 2013 4:56 am

Tried out 1.9.0 stable (was previously using 1.9 RC1 ok)


Tried compiling CEGUI and Particle Universe with the new 1.9 stable - dlls, libs, include etc - I get an error message (while building CEGUI) that Ogre::TexturePtr is undefined. I looked through OgreTexture.h and compared them between 1.9 RC1 and 1.9 stable and found that TexturePtr doesn't appear - to appear - in 1.9 stable include (while it does appear in the unstable - here's a copy paste of what doesn't appear in 1.9 stable) copied from 1.9 RC1

Code: Select all

    /** Specialisation of SharedPtr to allow SharedPtr to be assigned to TexturePtr 
    @note Has to be a subclass since we need operator=.
    We could templatise this instead of repeating per Resource subclass, 
    except to do so requires a form VC6 does not support i.e.
    ResourceSubclassPtr<T> : public SharedPtr<T>
    */
    class _OgreExport TexturePtr : public SharedPtr<Texture> 
    {
    public:
        TexturePtr() : SharedPtr<Texture>() {}
        explicit TexturePtr(Texture* rep) : SharedPtr<Texture>(rep) {}
        TexturePtr(const TexturePtr& r) : SharedPtr<Texture>(r) {} 
        TexturePtr(const ResourcePtr& r) : SharedPtr<Texture>()
        {
			// lock & copy other mutex pointer
            OGRE_MUTEX_CONDITIONAL(r.OGRE_AUTO_MUTEX_NAME)
            {
			    OGRE_LOCK_MUTEX(*r.OGRE_AUTO_MUTEX_NAME)
			    OGRE_COPY_AUTO_SHARED_MUTEX(r.OGRE_AUTO_MUTEX_NAME)
                pRep = static_cast<Texture*>(r.getPointer());
                pUseCount = r.useCountPointer();
                if (pUseCount)
                {
                    ++(*pUseCount);
                }
            }
        }

        /// Operator used to convert a ResourcePtr to a TexturePtr
        TexturePtr& operator=(const ResourcePtr& r)
        {
            if (pRep == static_cast<Texture*>(r.getPointer()))
                return *this;
            release();
			// lock & copy other mutex pointer
            OGRE_MUTEX_CONDITIONAL(r.OGRE_AUTO_MUTEX_NAME)
            {
			    OGRE_LOCK_MUTEX(*r.OGRE_AUTO_MUTEX_NAME)
			    OGRE_COPY_AUTO_SHARED_MUTEX(r.OGRE_AUTO_MUTEX_NAME)
                pRep = static_cast<Texture*>(r.getPointer());
                pUseCount = r.useCountPointer();
                if (pUseCount)
                {
                    ++(*pUseCount);
                }
            }
			else
			{
				// RHS must be a null pointer
				assert(r.isNull() && "RHS must be null if it has no mutex!");
				setNull();
			}
            return *this;
        }
    };
	/** @} */
	/** @} */

}
In RC1 - there are 504 lines and in stable there are 444 lines in source include. There is a reference to TexturePtr on line 263 in the 1.9 stable - so maybe it was moved somewhere?



Any help appreciated

thanks :)
0 x
Visit http://www.VoidDestroyer.com to check out my space sim project - Void Destroyer

User avatar
masterfalcon
OGRE Team Member
OGRE Team Member
Posts: 4270
Joined: Sun Feb 25, 2007 4:56 am
Location: Bloomington, MN
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by masterfalcon » Wed Dec 04, 2013 6:57 am

It is defined in OgrePrerequisites.h line 319.
0 x

User avatar
chaosavy
Silver Sponsor
Silver Sponsor
Posts: 570
Joined: Mon Jun 15, 2009 8:29 pm
x 5
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by chaosavy » Thu Dec 05, 2013 6:13 am

OgrePrerequisites.h is included in the CEGUI and Particle universe, but I still can't build them.


In particle universe I get:

Error 2 error C2440: 'initializing' : cannot convert from 'Ogre::Resource *' to 'Ogre::Material *' (..\src\ParticleUniverseTechnique.cpp) d:\sdev\ogresdk_vc11_v1-9-0\include\ogre\OgreSharedPtr.h 203
Error 3 error C2439: 'Ogre::SharedPtr<T>::pRep' : member could not be initialized d:\sdev\ogresdk_vc11_v1-9-0\include\ogre\OgreSharedPtr.h 203


seems like the above errors are suggesting that the SDK's includes don't have enough info, but I'm a noob at this aspect of C++.
0 x
Visit http://www.VoidDestroyer.com to check out my space sim project - Void Destroyer

scrawl
OGRE Expert User
OGRE Expert User
Posts: 1119
Joined: Sat Jan 01, 2011 7:57 pm
x 2

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by scrawl » Thu Dec 05, 2013 1:03 pm

I have already ported particle universe to 1.9, take a look here https://github.com/scrawl/particleunive ... its/master

Something similar needs to be done with CEGUI. Just tell them about it and they'll probably react fast :)

Note, MyGUI 3.2 already works as-is with 1.9.
0 x

User avatar
Thoran
Halfling
Posts: 94
Joined: Mon Dec 01, 2008 2:04 pm
Location: Germany
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by Thoran » Thu Dec 05, 2013 1:45 pm

scrawl wrote:I have already ported particle universe to 1.9, take a look here https://github.com/scrawl/particleunive ... its/master
The last commit is 2 months ago, is that correct?
0 x

scrawl
OGRE Expert User
OGRE Expert User
Posts: 1119
Joined: Sat Jan 01, 2011 7:57 pm
x 2

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by scrawl » Thu Dec 05, 2013 2:32 pm

Correct, but it should work with the final 1.9 too. There haven't been any other breaking changes.
0 x

User avatar
chaosavy
Silver Sponsor
Silver Sponsor
Posts: 570
Joined: Mon Jun 15, 2009 8:29 pm
x 5
Contact:

Re: [Announcement] Ogre3D 1.9 released as 'stable'

Post by chaosavy » Thu Dec 05, 2013 3:05 pm

Cool I'll take a look - thanks. With CEGUI one issue might be that I'm using 7 and now the latest 8. But maybe I'll be able to muddle my way through seeing how you fixed PU and learn somethin :)
0 x
Visit http://www.VoidDestroyer.com to check out my space sim project - Void Destroyer

Post Reply