[News] Review of 2014 & Outlook into 2015

News, announcements and important global threads from the Ogre3D Team.
Post Reply
User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

[News] Review of 2014 & Outlook into 2015

Post by spacegaier » Mon Jan 05, 2015 11:29 pm

First off: Happy New Year to everyone!

As the old year starts to slowly fade away in our rear view mirror, we want to look back on what 2014 had in store for Ogre3D and at the same time look ahead what 2015 might bring. So strap in for this ride back to the beginning of last year…
Complete news post: Link
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

User avatar
Klaim
Old One
Posts: 2565
Joined: Sun Sep 11, 2005 1:04 am
Location: Paris, France
Contact:

Re: [News] Review of 2014 & Outlook into 2015

Post by Klaim » Tue Jan 06, 2015 2:05 pm

Cool!
I'm reading but must report that I see nothing in Chrome there: http://coderabbit.at/webgl/viewer
I mean I see grey background with fps overlay but no model. It runs fine otherwise.
0 x

al2950
OGRE Expert User
OGRE Expert User
Posts: 1093
Joined: Thu Dec 11, 2008 7:56 pm
Location: Bristol, UK
x 40

Re: [News] Review of 2014 & Outlook into 2015

Post by al2950 » Tue Jan 06, 2015 2:14 pm

Klaim wrote:Cool!
I'm reading but must report that I see nothing in Chrome there: http://coderabbit.at/webgl/viewer
I mean I see grey background with fps overlay but no model. It runs fine otherwise.
Even after you click "Download and load model"? Works fine for me (chrome Version 39.0.2171.95 m)
0 x

User avatar
Klaim
Old One
Posts: 2565
Joined: Sun Sep 11, 2005 1:04 am
Location: Paris, France
Contact:

Re: [News] Review of 2014 & Outlook into 2015

Post by Klaim » Tue Jan 06, 2015 2:18 pm

Ah yes it works, I switched immediately the fullscreen option and didn't notice the text.
Sorry for the noise.

Nice read! I hope to have my project's demo in the list of interesting releases before the end of 2015, and seeing Ogre going forward is motivating to get there.
0 x

User avatar
Herb
Orc
Posts: 412
Joined: Thu Jun 04, 2009 3:21 am
Location: Kalamazoo,MI
x 1

Re: [News] Review of 2014 & Outlook into 2015

Post by Herb » Tue Jan 06, 2015 2:27 pm

Thanks for posting the overview of last year and plans for this year. I've been trying to follow 1.10 and 2.0 development and this is a really concise and clear direction posted. Also, REALLY excited to hear about 2.0 information/documentation going to get some focus as that will be very helpful for porting and just understanding the changes. :)

The continous integration server will be great to keep builds stable and getting Coverity (static code analysis) going should help in stability.

@Klaim - I ran in Chrome on both Ubuntu 14.04 and Win7 an it worked without issue, not sure what's going in with your setup...
0 x

User avatar
Klaim
Old One
Posts: 2565
Joined: Sun Sep 11, 2005 1:04 am
Location: Paris, France
Contact:

Re: [News] Review of 2014 & Outlook into 2015

Post by Klaim » Tue Jan 06, 2015 3:30 pm

Herb wrote: @Klaim - I ran in Chrome on both Ubuntu 14.04 and Win7 an it worked without issue, not sure what's going in with your setup...

It works, don't mind my message ^^;
0 x

paroj
OGRE Team Member
OGRE Team Member
Posts: 525
Joined: Sun Mar 30, 2014 2:51 pm
x 72
Contact:

Re: [News] Review of 2014 & Outlook into 2015

Post by paroj » Tue Jan 20, 2015 4:41 pm

I get

Code: Select all

XMLHttpRequest cannot load http://136.243.13.140/webgl/sinbad.zip. No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://coderabbit.at' is therefore not allowed access.
when clicking download..

works when I change the request to "/webgl/sinbad.zip"
0 x

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: [News] Review of 2014 & Outlook into 2015

Post by spacegaier » Tue Jan 20, 2015 11:48 pm

I can confirm this issue and notified wolfmanfx from CodeRabbit to have a look at it.
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

User avatar
Wolfmanfx
OGRE Team Member
OGRE Team Member
Posts: 1525
Joined: Fri Feb 03, 2006 10:37 pm
Location: Austria - Leoben
x 1
Contact:

Re: [News] Review of 2014 & Outlook into 2015

Post by Wolfmanfx » Tue Jan 20, 2015 11:52 pm

fixed
0 x

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4291
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 2
Contact:

Re: [News] Review of 2014 & Outlook into 2015

Post by spacegaier » Tue Jan 20, 2015 11:53 pm

I can confirm that it works now again.
0 x
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

Post Reply