Editor requests/proposals

What it says on the tin: a place to discuss proposed new features.
Post Reply
User avatar
SunSailor
Gnoll
Posts: 699
Joined: Sun Jan 02, 2005 5:45 pm
Location: Velbert, Germany
Contact:

Editor requests/proposals

Post by SunSailor » Tue Oct 07, 2008 11:15 am

Hi,
I'm currently reimplementing our inhouse editor, which was developed with Java and SWT until now. After being very unhappy with SWT (Lacks of object oriented design) and the discontinueation of the rendering tool we aimed to use for lightmaps, I decided to port the editor to wxWidgets, which I'm very happy with at the moment. I'd like to use this thread as a collector for smaller (or bigger, time will tell ;) ) requests or discussion for new features, which tie better into an editor. Even as I'm going to implement them by myself, I really would like to discuss them first to ensure, that they are going to find their place in the official source tree, as maintaining some kind of fork is a real pain and I would like to avoid things, which don't fit into the basic design of OGRE.
I started the reimplementation with features, which I always wanted to add to the editor, but didn't have the time, or that they would break the editor in an unacceptable way. So, here I started with a more convenient way to edit the resource backend.
So, here are my first points:
1) I would like to add a method named resourceGroupExists to check, if a resource group of the given name is already existing. The reason behind this is, that there are predefined resource groups on the one hand and that I would like to enable the user to specify a custom name - and users are making mistakes. Would that be acceptable? A simple "yes" from one core developer would be enough for me to start. Done
2) Would a method called "renameResourceGroup" break anything internal? Currently, my approach would be to create a new ResourceGroup, move all entries into that and delete the old one, but I think, if I could rename the group more easily, that would make this process more stable and reliable.[/b]
Last edited by SunSailor on Wed Oct 08, 2008 4:07 pm, edited 1 time in total.
0 x

User avatar
SunSailor
Gnoll
Posts: 699
Joined: Sun Jan 02, 2005 5:45 pm
Location: Velbert, Germany
Contact:

Post by SunSailor » Wed Oct 08, 2008 3:03 pm

3) A method ArchiveFactoryMapIterator getArchiveFactoryIterator(); for the ArchiveManager class to retrieve the registered Archive-types. In this context, I aim to add an extra method to the ArchiveFactory class, which returns an enumeration, if the archive is directory, file or string based. E.G. the FileSystemArchive is directory based, the ZipArchive is file based and a database backend would be string based. This would allow me to enable the user to choose different archive types without loosing property editor access. Done

Edit: I have implemented two of the three items yet in good hope, as they shouldn't harm too much. Finally, it would be really nice, if someone of the core developers could comment on the missing item, as I expect a bit more work there, if it is possible at all.
0 x

User avatar
sinbad
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 19265
Joined: Sun Oct 06, 2002 11:19 pm
Location: Guernsey, Channel Islands
x 2
Contact:

Post by sinbad » Wed Oct 08, 2008 11:02 pm

I'm certainly open to practical suggestions found when making editors.

Right now isn't the best time of course since I'm concentrating on finishing 1.6 :) But queue them up, and prod me with a stick if I go quiet for too long...
0 x

User avatar
SunSailor
Gnoll
Posts: 699
Joined: Sun Jan 02, 2005 5:45 pm
Location: Velbert, Germany
Contact:

Post by SunSailor » Fri Oct 10, 2008 11:03 am

Actually, I'm not asking for a big involvement, only for a short assumption, if renaming a resource group would affect deeper parts of the code. As mentioned, the other two points are already implemented and I'm only waiting with a patch for this information.
0 x

Post Reply