Compiling Ogre with VS2013 (RC, then RTM)

Discussion area about developing or extending OGRE, adding plugins for it or building applications on it. No newbie questions please, use the Help forum for that.
Post Reply
User avatar
Klaim
Old One
Posts: 2565
Joined: Sun Sep 11, 2005 1:04 am
Location: Paris, France
Contact:

Compiling Ogre with VS2013 (RC, then RTM)

Post by Klaim » Wed Sep 11, 2013 7:31 pm

Today I decided to try see the cost of converting my project to VS2013. To my surprise it was far easier than VS2010->VS2012 (except having to get Boost from trunk and recompile all of it completely). Here is the part relative to Ogre:

1. Very Good News: Ogre 1.9 sources (2f4fcc6507123ac6eca1ede7da4af45c736542c9) compiles (32bit) and run just fine in my current setup without any modification to the sources nor CMake! Congrats! :D
2. Less Good News: Ogre Dependencies don't compile but the fix is easy - basically min() and max() calls in FreeImage are missing inclusion of the algorithm header in several CPP files (I suppose it's not missing in FreeImage headers as these headers don't seem to expose standard C++ headers). The following is the list of the cpp files that need to add '#include <algorithm>', as I don't know exactly where it should be reported, here or in the repo or to FreeImage (is it directly taken from them or is it a modified version?):

ImfAcesFile.cpp in ogre_dependencies\src\FreeImage\Source\OpenEXR\IlmImf
ImfOutputFile.cpp in ogre_dependencies\src\FreeImage\Source\OpenEXR\IlmImf
ImfScanLineInputFile.cpp in ogre_dependencies\src\FreeImage\Source\OpenEXR\IlmImf
ImfTiledMisc.cpp in ogre_dependencies\src\FreeImage\Source\OpenEXR\IlmImf
ImfTiledOutputFile.cpp in ogre_dependencies\src\FreeImage\Source\OpenEXR\IlmImf

3. Once this is fixed, my app seems to run the same way than with VS2012, so I guess that's a success. :mrgreen:
4. However I didn't try to compile the full Ogre sources, with samples, yet. I'm preparing to do so (also to hunt another bug I pointed there: http://www.ogre3d.org/forums/viewtopic.php?f=2&t=78894).

I'll report here if I find more errors.
Last edited by Klaim on Sat Oct 19, 2013 12:55 am, edited 1 time in total.
0 x

User avatar
Klaim
Old One
Posts: 2565
Joined: Sun Sep 11, 2005 1:04 am
Location: Paris, France
Contact:

Re: Compiling Ogre with VS2013 (RC)

Post by Klaim » Thu Sep 12, 2013 6:06 pm

1. I compiled the all Ogre targets with no problem (32bit) other than the dependencies needing the previously mentionned fix;
2. By default, the CMake config will never generate the Sample projects if you dont turn OGL3+ renderer on;
3. OGL3+ renderer fails to load into the Sample Browser at the moment;

I tried in Release and ReleaseWithDebugInfo modes, just run the Sample Browser and started a random sample. I didn't try all samples.
0 x

Transporter
Minaton
Posts: 933
Joined: Mon Mar 05, 2012 11:37 am
Location: Germany
x 1

Re: Compiling Ogre with VS2013 (RC)

Post by Transporter » Mon Oct 07, 2013 8:47 am

Wait for the release of VS2013. I had the same issue with a few headers at VS2012 RC.
0 x

User avatar
Klaim
Old One
Posts: 2565
Joined: Sun Sep 11, 2005 1:04 am
Location: Paris, France
Contact:

Re: Compiling Ogre with VS2013 (RC, then RTM)

Post by Klaim » Sat Oct 19, 2013 12:59 am

Got the VS2013 RTM, and after reporting errors in Boost I'm getting back here but I didn't have time to get in depths. Quick preview:

1. OgreMain compiles (at least in my project's build) but it's not a recent revision of 1.9, I didn't change it since my initial message (other than the patches I provided);
2. RenderSystem GL compiles (in my project, same revision)
3. In my project, all Ogre projects relying on tbb seem to not be able to link with it (in Debug at least, didn't find the time to test other builds) but I think it's more related to my project;

I'll try to compile the sample browser this weekend instead of my project, but globally it looks good.
0 x

Post Reply