Page 1 of 1

Ogre 1.9RC2 + VS2013 Express, ZM option not working

Posted: Sun Oct 20, 2013 9:41 pm
by lingfors
The ZM option in CMake (that allows VS to use more memory for PCH using the /Zm256 flag) doesn't seem to work. I've tried generating project using CMake both with the option checked and unchecked, without getting the /ZM256 flag to show up in my OgreMain compile command line.

Also, the description of the option in CMake is confusing... "Switch off flag" or something like that. So, if I check it, I should not use the /Zm256 flag, or? Enable an option to turn something off? IMHO, it would be better to have an option to turn the flag on, that is checked by default.

Re: Ogre 1.9RC2 + VS2013 Express, ZM option not working

Posted: Sun Oct 20, 2013 9:52 pm
by spacegaier
I will fix that in a second. The issue is, that our CMake scripts do not allow to set Zm with VS2013 yet (only VS2012). The script detects an invalid VS version for /Zm and then displays that slightly confusing tooltip you mention.

Re: Ogre 1.9RC2 + VS2013 Express, ZM option not working

Posted: Sun Oct 20, 2013 10:06 pm
by spacegaier
I just pushed a fix. Can you please try again with the latest revision: https://bitbucket.org/sinbad/ogre/commi ... 16da054e4c

Re: Ogre 1.9RC2 + VS2013 Express, ZM option not working

Posted: Mon Oct 21, 2013 10:48 am
by lingfors
spacegaier wrote:I just pushed a fix. Can you please try again with the latest revision: https://bitbucket.org/sinbad/ogre/commi ... 16da054e4c
I will try again tonight when I get home from work.

Re: Ogre 1.9RC2 + VS2013 Express, ZM option not working

Posted: Mon Oct 21, 2013 6:14 pm
by lingfors
Yup, seems to be working better. :)