Problem compiling OgreODE on Mac OS X

A place for users of OGRE to discuss ideas and experiences of utilitising OGRE in their games / demos / applications.
Post Reply
User avatar
sevensevens
Gnoblar
Posts: 21
Joined: Sat May 07, 2005 4:41 am

Problem compiling OgreODE on Mac OS X

Post by sevensevens »

I'm having trouble compiling OgreODE on my Mac OS 10.3 with XCode 1.5 system. I followed the instructions in the Ogre Addons and downloaded it through CVS (along with the other addons). I've read through the instructions, and searched the forum for information, but no luck. I get well over 200 errors (generally undefined externals) - I know its probably a problem with the library and framework settings, but I don't know which ones to change. Any advice would be greatly appreciated.

User avatar
Project5
Goblin
Posts: 245
Joined: Mon Nov 22, 2004 11:56 pm
Location: New York, NY, USA
Contact:

Post by Project5 »

Ok, from a clean install, put all the deps into your /library/Frameworks/ folder.

Install the x11 sdk from Panther disc #3.

Put ogrenew anywhere you'd like.

Open up the project in xcode. There may be some files/libraries in red, option-click on those and point xcode to wherever they actually reside.

Compile. It may complain that it can't find one or another sdl file. Add that particular file to the ogre project manually, making sure to add it to every target just to be safe. (not efficient, I know, but it worked for me).

If that file resides in a framework, you will find that xcode is unable to traverse the directory if that framework is all ready added. The solution is to find that file manually in Finder, and make an alias to the folder it resides in, and put the alias on your desktop. Now back in xcode, you can traverse the alias just fine and manually add the file. Now you can actually get rid of the alias and things still work.

Compile it up.

This process worked for me on OS 10.3, xcode 1.5, Ogre 1.0.1.

:-)

--Ben

User avatar
sevensevens
Gnoblar
Posts: 21
Joined: Sat May 07, 2005 4:41 am

Post by sevensevens »

Thanks for the advice, but I've managed to compile the Ogre framework (using a method much like you suggested). The problem is I cannot compile the OgreODE addon, which is a popular physics engine wrapper for Ogre. I know its possible tho (people on this board have done it).

User avatar
monster
OGRE Community Helper
OGRE Community Helper
Posts: 1098
Joined: Mon Sep 22, 2003 2:40 am
Location: Melbourne, Australia
Contact:

Post by monster »

What undefined externals are you getting? Are you linking to Ogre and ODE?

User avatar
sevensevens
Gnoblar
Posts: 21
Joined: Sat May 07, 2005 4:41 am

Post by sevensevens »

Firstly, I have to remove the "ode/" in front of the include files to get it to find the ode headers. Once I've made that change, dTerrainCallbackClass is still undefined.

I'm trying to create a framework for OgreODE. I've added the Ogre.framework as a linked framework, as well as adding the Ogre and SDL headers to the search paths. I've also made all the changes the OgreODE document suggested to the Ogre source code.

User avatar
sevensevens
Gnoblar
Posts: 21
Joined: Sat May 07, 2005 4:41 am

Post by sevensevens »

I've done a search, and I've seen a few post from mac users using OgreODE, could one of you post an XCode project, or something of that nature?

Post Reply