Ogre AppWizards 1.8.0

A place for users of OGRE to discuss ideas and experiences of utilitising OGRE in their games / demos / applications.
iuridosanjos
Gnoblar
Posts: 10
Joined: Sat Apr 24, 2010 6:11 pm

Re: Ogre AppWizards 1.7.0

Post by iuridosanjos » Sun May 02, 2010 6:35 pm

jacmoe wrote:Which version of it?
VC10 SDK with VC10 (not express) AppWizard.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.0

Post by jacmoe » Sun May 02, 2010 6:42 pm

I just tested it again: no problems.
vc10appwizsettings1.png
vc10appwizsettings2.png
I'll do a test against the one you downloaded, just in case.
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

iuridosanjos
Gnoblar
Posts: 10
Joined: Sat Apr 24, 2010 6:11 pm

Re: Ogre AppWizards 1.7.0

Post by iuridosanjos » Sun May 02, 2010 8:40 pm

jacmoe wrote:I just tested it again: no problems.
vc10appwizsettings1.png
vc10appwizsettings2.png
I'll do a test against the one you downloaded, just in case.

I had to add this line:
"$(OGRE_HOME)\lib\$(Configuration);"
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.0

Post by jacmoe » Sun May 02, 2010 8:55 pm

iuridosanjos wrote:I had to add this line:
"$(OGRE_HOME)\lib\$(Configuration);"
I just tested it, and everything was in order, as illustrated above.
Are you telling me that Visual Studio 2010 is handling this differently from Visual C++ 2010 Express?
You are not viewing the configuration page with all configurations set ?
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

iuridosanjos
Gnoblar
Posts: 10
Joined: Sat Apr 24, 2010 6:11 pm

Re: Ogre AppWizards 1.7.0

Post by iuridosanjos » Sun May 02, 2010 9:53 pm

jacmoe wrote:
iuridosanjos wrote:I had to add this line:
"$(OGRE_HOME)\lib\$(Configuration);"
I just tested it, and everything was in order, as illustrated above.
Are you telling me that Visual Studio 2010 is handling this differently from Visual C++ 2010 Express?
You are not viewing the configuration page with all configurations set ?
I dont know if vc10 express or not make difference on that, but I wouldn't say it.
For the matter of all the configurations set, everything is sucessfully set in my projects properties except with that only thing I said.
Maybe it's something wrong that happenned exclusively here. :/

I dont understand what you say about 'viewing the configuration page' sorry.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.0

Post by jacmoe » Sun May 02, 2010 10:33 pm

That's odd :)
But if that's all it takes, let's just leave it hanging, until someone else experiences the same issue.

The configuration screen I referred to is the one you can see in the attached screenshots above: Project - Properties - Configuration Properties - Linker - General
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

MrPaul
Gnoblar
Posts: 14
Joined: Sat May 01, 2010 3:59 pm

Re: Ogre AppWizards 1.7.0

Post by MrPaul » Tue May 04, 2010 9:27 pm

Can someone kindly pop the links into the WIKI? I was looking in the wiki for a version for VS 8.0 to no avail until i found it here :) thanks
0 x

User avatar
JKFOZZY
Halfling
Posts: 78
Joined: Thu Apr 22, 2010 3:40 pm

Re: Ogre AppWizards 1.7.0

Post by JKFOZZY » Mon May 10, 2010 5:23 pm

Hi,

I downloaded and installed the Ogre AppWizzard for my VS 2008. When i try to make a new project i couldn't locate Ogre SDK Application icon. But i could find the Ogre Application icon.

I read the wiki and the forum posts but is says just hit the installer and you're finished. Is there something that i could do to fix this problem?

Regards,
JKFOZZY.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.0

Post by jacmoe » Mon May 10, 2010 5:52 pm

There's no problem: the wizard is the same.
Just make sure that you build the Ogre INSTALL project if you're using Ogre source.
Then point OGRE_HOME to ogre_source/sdk, or where you've built it.
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
JKFOZZY
Halfling
Posts: 78
Joined: Thu Apr 22, 2010 3:40 pm

Re: Ogre AppWizards 1.7.0

Post by JKFOZZY » Mon May 10, 2010 9:19 pm

Hi jacmoe,

i did exactly what you told me to do. I did build the Ogre Install project and i did set my enviroment variable. But i didn't succeed to get the Ogre SDK Application icon.

Regards,
JKFOZZY.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.0

Post by jacmoe » Mon May 10, 2010 9:25 pm

There is only one icon: OGRE.
That's it. :)

In the old days, there was an icon called the 'Ogre SDK Application icon', but it has now been retired.
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
JKFOZZY
Halfling
Posts: 78
Joined: Thu Apr 22, 2010 3:40 pm

Re: Ogre AppWizards 1.7.0

Post by JKFOZZY » Mon May 10, 2010 9:32 pm

Hi jacmoe,

Thank you for your'e quick response. So there is only just one option, "Ogre Application"? Hmm ok. Thank you very much. Tommorow after school i'll start with my new ogre project. :D

Regards,
JKFOZZY.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.0

Post by jacmoe » Sun May 23, 2010 12:27 am

Tada! :)

Here's the new Code::Blocks AppWizard:
Ogre AppWizard 1.7.0 for Code::Blocks
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
Raygoe
Gnoblar
Posts: 18
Joined: Fri Nov 16, 2007 4:05 am

Re: Ogre AppWizards 1.7.0

Post by Raygoe » Sat Jun 05, 2010 3:55 pm

jacmoe wrote:Tada! :)

Here's the new Code::Blocks AppWizard:
Ogre AppWizard 1.7.0 for Code::Blocks
Thanks Jacmoe!

The AppWizard worked perfectly in C::B 10.05.
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.0 (Visual Studio and Code::Blocks)

Post by jacmoe » Thu Jun 24, 2010 4:06 pm

The Ogre AppWizards 1.7.1 are out! :D

This time featuring a new project type: Minimal Ogre Application.
All in one class.

And a new option: don't use configuration files (but configure Ogre in code).

Enjoy. :wink:
OgreAppwizards171.png
Links updated - see the first post.
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by jacmoe » Fri Aug 13, 2010 8:33 am

Wizards for Visual Studio 2010 have been updated to include two different minimal application options:
One class based : same as BaseApplication, but only one class.
One function based: all code in one function, like before.

You will definitely want to update to this one! :)

Also, one important small change: $(OGRE_HOME)/include is now added to the list of include directories, which makes it even more foolproof.

VC9, VC8 and Code::Blocks wizards will follow later.
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by jacmoe » Sat Aug 14, 2010 6:10 am

VC9 and VC8 updated to 1.7.1_1 - see previous post for details - and the very first post for updated download links.
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by jacmoe » Thu Aug 19, 2010 6:02 pm

VC8, VC9 and VC10 Wizards updated to 1.7.1_2 - links updated in first post.
Wizards now handles project names with spaces correctly. :wink:
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

kiwibonga
Gnoblar
Posts: 4
Joined: Sun Sep 12, 2010 9:04 pm

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by kiwibonga » Sun Sep 12, 2010 9:27 pm

Just a note in case someone else missed this:

(I'm using Windows 7 64 bit with VC++ 2010 Express)

You have to set the OGRE_HOME environment variable BEFORE you run the AppWizard installer. If you didn't set it, or you set it after installing the AppWizard, any new project you create with the AppWizard will have no additional library or include directories set (along with other missing stuff that will prevent the build process from finishing successfully).

To fix it, just uninstall the AppWizard from "Programs and Features" ("Add/Remove Programs"), make sure OGRE_HOME is set properly, and reinstall.

Works like a charm now :)
0 x

hedphelym
Gremlin
Posts: 169
Joined: Tue Nov 25, 2008 10:58 am
Location: Kristiansand, Norway
x 10
Contact:

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by hedphelym » Mon Nov 29, 2010 8:54 am

hi, just wanted to say thanks for this.
It works great!
So much better then to pick apart a sample application and strip code etc.

I run it on Win7 x64 \ VS2008.
0 x

mude
Halfling
Posts: 47
Joined: Tue Dec 21, 2010 1:46 pm

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by mude » Tue Dec 21, 2010 3:11 pm

I'm running windows 7 64bit with VS 2010 Ultimate.

I'm trying to set up vs for Ogre 1.7.2 but I have problems with Ogre_d.lib (OGRE_HOME has been set)

so I'm trying appwizard for 1.7.1 but VS can't find the libraries.

Do I need to resete the OGRE_HOME variable or the app is incompatible with the latest version of ogre sdk?


EDIT: problem solved. now i'm missing cg.dll
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by jacmoe » Tue Feb 08, 2011 12:40 pm

Wizards for VC8 and VC9 updated (to using Boost 1.44) - links in first post updated. :wink:
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

dalequigleye
Gnoblar
Posts: 1
Joined: Tue Feb 08, 2011 5:21 pm

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by dalequigleye » Tue Feb 08, 2011 5:23 pm

good info..lost of help for the Ogre newbie..thank you!
0 x

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
Contact:

Re: Ogre AppWizards 1.7.1 (Visual Studio and Code::Blocks)

Post by jacmoe » Sun Mar 27, 2011 9:13 pm

Ogre Appwizards for KDevelop 4.x Linux are ready. :)
First post updated.
0 x
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

Apprentice123
Gnoblar
Posts: 13
Joined: Wed Sep 15, 2010 2:24 am

Re: Ogre AppWizards 1.7.2

Post by Apprentice123 » Tue May 24, 2011 8:14 pm

I used the ogre3d and got the following errors:

In Code::Blocks

Code: Select all

||=== OgreTeste, Debug ===|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\Threading\OgreThreadHeadersBoost.h|29|error: boost/thread/tss.hpp: No such file or directory|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\Threading\OgreThreadHeadersBoost.h|30|error: boost/thread/recursive_mutex.hpp: No such file or directory|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\Threading\OgreThreadHeadersBoost.h|31|error: boost/thread/condition.hpp: No such file or directory|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\Threading\OgreThreadHeadersBoost.h|32|error: boost/thread/thread.hpp: No such file or directory|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\Threading\OgreThreadHeadersBoost.h|33|error: boost/thread/shared_mutex.hpp: No such file or directory|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\Threading\OgreThreadHeadersBoost.h|34|error: boost/thread/locks.hpp: No such file or directory|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreIteratorRange.h|34|error: boost/range.hpp: No such file or directory|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreIteratorRange.h|109|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreIteratorRange.h|109|error: ISO C++ forbids declaration of 'iterator_range' with no type|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreIteratorRange.h|109|error: typedef name may not be a nested-name-specifier|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreIteratorRange.h|109|error: ISO C++ forbids nested type 'iterator_range' with same name as enclosing class|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreIteratorRange.h|109|error: expected ';' before '<' token|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|746|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|746|error: ISO C++ forbids declaration of 'recursive_mutex' with no type|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|746|error: expected ';' before 'mutex'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h||In member function 'Ogre::String Ogre::NameGenerator::generate()':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|756|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|756|error: expected ';' before 'ogreAutoMutexLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h||In member function 'void Ogre::NameGenerator::reset()':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|765|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|765|error: expected ';' before 'ogreAutoMutexLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h||In member function 'void Ogre::NameGenerator::setNext(long long unsigned int)':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|772|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|772|error: expected ';' before 'ogreAutoMutexLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h||In member function 'long long unsigned int Ogre::NameGenerator::getNext() const':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|780|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|780|error: expected ';' before 'ogreAutoMutexLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|797|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|797|error: ISO C++ forbids declaration of 'recursive_mutex' with no type|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|797|error: expected ';' before 'mutex'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h||In member function 'virtual std::pair<bool, T> Ogre::Pool<T>::removeItem()':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|807|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|807|error: expected ';' before 'ogreAutoMutexLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h||In member function 'virtual void Ogre::Pool<T>::addItem(const T&)':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|826|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|826|error: expected ';' before 'ogreAutoMutexLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h||In member function 'virtual void Ogre::Pool<T>::clear()':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|832|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreCommon.h|832|error: expected ';' before 'ogreAutoMutexLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|67|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|67|error: ISO C++ forbids declaration of 'recursive_mutex' with no type|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|67|error: expected ';' before '*' token|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h||In constructor 'Ogre::SharedPtr<T>::SharedPtr()':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|74|error: 'mutex' was not declared in this scope|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h||In constructor 'Ogre::SharedPtr<T>::SharedPtr(Y*, Ogre::SharedPtrFreeMethod)':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|87|error: 'mutex' was not declared in this scope|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|90|error: expected type-specifier before 'boost'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|90|error: expected ';' before 'boost'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|98|error: 'mutex' was not declared in this scope|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|101|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|101|error: expected ';' before 'ogrenameLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h||In constructor 'Ogre::SharedPtr<T>::SharedPtr(const Ogre::SharedPtr<Y>&)':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|129|error: 'mutex' was not declared in this scope|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|132|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|132|error: expected ';' before 'ogrenameLock'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h||In member function 'void Ogre::SharedPtr<T>::bind(T*, Ogre::SharedPtrFreeMethod)':|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|169|error: 'mutex' was not declared in this scope|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|169|error: expected type-specifier before 'boost'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|169|error: expected ';' before 'boost'|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|170|error: 'boost' has not been declared|
E:\OgreSDK_mingw_v1-7-2\include\OGRE\OgreSharedPtr.h|170|error: expected ';' before 'ogreAutoMutexLock'|
||More errors follow but not being shown.|
||Edit the max errors limit in compiler options...|
||=== Build finished: 50 errors, 0 warnings ===|
0 x

Post Reply