Page 1 of 1

Problem with BSP scenes under directx 9 renderer

Posted: Fri Mar 11, 2005 4:20 pm
by Treize
Hey all, I'm new to this community. I only recently started experimenting with this awesome 3d engine. I simply started by looking at all the samples and then I tried to modify the BSP sample to load a test map I made in GtkRadiant. Now I have a few really weird problems and I was hoping if anyone has any clue as to why they're occuring. See the included Chiroptera map works fine. So I made a very simple map in GtkRadiant: Just made a brush, hollowed it, and put some lights inside. I tried to load this in the BSP sample and it loads fine, but the thing is that if I use the DirectX 9 renderer I don't get to see anything. Well.. when I fly up to a wall (blindly) and I get very close to the wall sometimes I suddenly get to see it, but when I turn the camera it will suddenly go black again untill I turn the camera back, it's really very strange. Also weird is that this works fine when I use the OpenGL renderer, no problems there. I just want it to work with DirectX 9 as well.

So.. any ideas what could be wrong?

Posted: Sat Mar 12, 2005 2:16 am
by haffax
No idea really, but have you tried a different BSP compiler? q3map2 works quite well. Maybe this helps.

Posted: Sat Mar 12, 2005 2:37 pm
by Treize
Thanks for the reply but I doubt that would work seeings GtkRadiant actually uses that same q3map2 binary to compile the bsps..

Posted: Sat Mar 12, 2005 11:43 pm
by sinbad
Actually it doesn't. GtkRadiant uses a custom version which has caused issues in the past because our BSP scene manager is based on the original Quake3 format.

Posted: Mon Mar 21, 2005 6:40 pm
by Treize
Ok first thanks for the reply. I figured the bsp compiler for GtkRadiant was the same as the one someone posted above because it was the same filesize, had the same name and the same icon. But just in case it does have differences I replaced the one in the GtkRadiant directory with the one posted above. I recompiled the map and, put it in a pk3 and ran the sample again. Same thing happens. It might just be me doing something wrong to my map (even though I don't see what it could be..) but somethings not right here. It works fine under OpenGL. So I'll attach here a link to a zip that contains the map file to open in GtkRadiant and the pk3 (so the compiled map), maybe someone can try running it and see if it does the same thing for them under DirectX9 renderer, and if it does, maybe someone can figure out why?
If you want me to post a vidcap of what I'm seeing exactly I'll be glad to as well.


Posted: Mon Mar 21, 2005 7:02 pm
by Treize
Well, now that I'm talking deficiencies I might as well mention a few other things I've noticed. I don't wanna be the one to bring the bad news but.. I simply tried to render a bsp map, even the sample, and ran into all sorts of quirks/bugs.

Now this is probably related, but when running the BSP sample with the chiroptera map I noticed two things.

1. When I approached the blue swirly effects they suddenly vanished on me, and I'm not talking getting really close to them, just.. closer.

(Sorry for the big screenshots)

Further away:

As u can see it works fine.

But then, getting closer:

2. When I approach the lava like pools, I don't see the lava texture, just black:

But when I increase my distance, and am in fact looking through other geometry, the lava suddenly pops up:


These problems occur under Debug as well as Release.

I just seriously hope that it's not just me.. since that would.. well, suck.