Comparing Ogre with other rendering engines

A place for users of OGRE to discuss ideas and experiences of utilitising OGRE in their games / demos / applications.
nitekrawler
Gnoblar
Posts: 23
Joined: Mon Apr 04, 2005 6:55 am

Post by nitekrawler »

Thanks, I got it to compile now.

But now when I try to run the viewer on my scene file I just get a gray screen with the Ogre overlays. I copied the .material, .scene, and .mesh files into DSISceneViewer.exe's directory. I get that same "versionFormat attribute is not 0.2.0..." warning but other than that it doesn't complain about anything else.

Anyone know what I'm doing wrong?

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Post by jacmoe »

nitekrawler wrote:I get that same "versionFormat attribute is not 0.2.0..." warning but other than that it doesn't complain about anything else.
That warning means that it tried to read the .scene file, but couldn't recognise it's format.
You should change "versionFormat" in the .scene file - look at the source for DSI to see what it expects (can't remember it atm) - but you will get a grey screen until you fix it. :wink:
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

JeDi
Gnome
Posts: 351
Joined: Thu Oct 21, 2004 1:34 pm
Location: Diepenbeek, Belgium
x 3
Contact:

Post by JeDi »

Actually, the warning has nothing to do with the gray screen you get. You can change the versionFormat in the .scene file to get rid of the warning though.
What I forgot to mention is that I had to change the .material file, cause the material colors were all black (but shouldn't the opaque textures overwrite that color?

Greetz,
JeDi

Post Reply