[Solved] FSAA issue

A place for users of OGRE to discuss ideas and experiences of utilitising OGRE in their games / demos / applications.
Post Reply
kubatp
Gnome
Posts: 342
Joined: Tue Jan 06, 2009 1:12 pm
x 7

[Solved] FSAA issue

Post by kubatp » Thu Mar 30, 2017 6:54 pm

Hi,
I have an interesting problem with FSAA. Because a picture is worth a thousand words, I attach three screenshots.
Basically, I have static geometry (trees) and they have fake shadows (those are actually quads with semitransparent textures - tree "shadow"). These fake shadows have depth_write off, so they are displayed even there is (for example) terrain, which would otherwise cut the quads. This works absolutely fine and I am happy with the results.

The problem appeared when I had turned on FSAA - for higher FSAA values, the shadows are almost not displayed at all and for lower values, parts of shadows are "dotted".
Can somebody tell me what is wrong and how to avoid this?

Thank you in advance.
Attachments
fsaa16.png
FSAA 16
fsaa16.png (116.27 KiB) Viewed 969 times
fsaa4.png
FSAA 4
fsaa4.png (116.91 KiB) Viewed 969 times
fsaa0.png
FSAA 0
fsaa0.png (113.91 KiB) Viewed 969 times
Last edited by kubatp on Sat Apr 08, 2017 1:22 pm, edited 1 time in total.
0 x

kubatp
Gnome
Posts: 342
Joined: Tue Jan 06, 2009 1:12 pm
x 7

Re: FSAA issue

Post by kubatp » Wed Apr 05, 2017 1:40 pm

Bit surprised that noone has ideas about this :?
0 x

farrer
Halfling
Posts: 63
Joined: Mon Sep 12, 2011 7:35 pm
x 6

Re: FSAA issue

Post by farrer » Wed Apr 05, 2017 7:40 pm

I don't have a clue on solving this one. But, as you're having some problems with 1.7 (although I believe you already measured the pros-and-cons of that) is there any big reason to not update to use some more up-to-date Ogre's version? (I have 1.9 or 1.10 in mind). This way you can have more help from Ogre developers than using the old 1.7.x version.
0 x

kubatp
Gnome
Posts: 342
Joined: Tue Jan 06, 2009 1:12 pm
x 7

Re: FSAA issue

Post by kubatp » Wed Apr 05, 2017 9:00 pm

Hi Farrer,
I would love to upgrade to 2.0 but unfortunately I am using Mogre, for which the latest stable version is 1.7.4. That's the reason why I have to stick to this version:-/
0 x

kubatp
Gnome
Posts: 342
Joined: Tue Jan 06, 2009 1:12 pm
x 7

Re: FSAA issue

Post by kubatp » Sat Apr 08, 2017 1:21 pm

I was playing with this for quite some time and it seems like the problem was in alpha_rejection property in tree shadow material. Once I removed this property if FSAA > 0, it looked as it should.
0 x

Post Reply