Page 1 of 1

Compositor cull meshes

Posted: Fri Dec 08, 2017 1:50 pm
by andreahmed
Hi all,

I have a strange problem.. I tried to load models, whenever I use ANY compositor that is used in the samples, the meshes are culled and some parts of it are invisible.. I tried to disable depth checking in the material of the compositor but still no luck. ANY mesh it's culled and some parts of it are visible.

Re: Compositor cull meshes

Posted: Fri Dec 08, 2017 2:58 pm
by dark_sylinc
Read the forum rules and also read How To Ask Questions The Smart Way.

Your post, as is written, tells us nothing on your problem, what you're doing, how you're doing it, why it could be happening, and what we could suggest to fix it. Not even a picture to help illustrate the problem.

Cheers
Matias

Re: Compositor cull meshes

Posted: Fri Dec 08, 2017 5:58 pm
by andreahmed
Thanks for your reply.

What I'm doing is just renderWindow->AddViewPort(); I'm adding two viewports for double vision mode.

Then I'm using a compositor from the samples as it is, like the glass, and then I add the compositor to the two view ports. I have a rendered mesh. The mesh is culled, some parts of it are invisible. and I "see" through it. I tried in the material to disable depth checking, depth write off, but still the mesh is not rendered correctly.

Re: Compositor cull meshes

Posted: Fri Dec 08, 2017 7:20 pm
by andreahmed
what I noticed is the depth is destroyed when I use the compositor... however I set depth check on but nothing happens, the depth is never checked

Re: Compositor cull meshes

Posted: Fri Dec 08, 2017 7:57 pm
by andreahmed
Here is a picture
the depth is not written at all, even If I enable it in the material of the compositor

Image