Page 1 of 1

Does anybody use Ragdolls in OgreOde?

Posted: Mon Apr 25, 2005 10:26 am
by Bobo7581
I was wondering whether anybody uses monster's new radoll functionality from OgreOde, i've tried with mulitple models including robot.mesh etc. from the samples and can't get any other mesh bar the zombie to build a proper ragdoll structure...

The zombies work great but others don't even create all the bones or the bones fly off in weird directions. I was just wondering whether anybody else had got any other models to work as ragdolls and its just a problem with my code / ogre / ode etc. or whether its just some kinda bug with monster's OgreOde code??

cheers

Posted: Mon Apr 25, 2005 2:37 pm
by monster
I can't really see why other models wouldn't work as long as you send the right hints to the ragdoll building code. To get the zombie to work I did have to edit the model slightly to get it into a more compatible form, but that just involved scaling it to a sensible size and naming the bones so that I could refer to them by proper names.

Having said that, I haven't actually tried it with other models so I'm perfectly willing to believe that there are issues with it. The first thing is to use the debug geometry display to check that the right geometries are being created. If they're not, and you can't hint the automatic creation to do it properly, then I'm afaraid you'll have to delve into the code and have a look around yourself.

Posted: Tue Apr 26, 2005 2:26 pm
by monster
Billthe4th sent me this PM, I hope it's OK, but I thought I'd reply here for the benefit of other people.
Billthe4th wrote:I'm having the same troubles as Bobo7581 with rag dolls. Would it be ok for you to try it out with one of the other example meshes, such as the robot? just to check I'm using it the correct way.
Unfortunately I simply don't currently have time to look into this.

I'm sorry, I know it's probably frustrating that I'm not supporting OgreOde as well as I could, but I have mentioned in the past that I'll no longer be developing it because I'm working on it's replacement. In the medium term the goal is to port all the OgreOde demos to the Gangsta Wrapper, and I'll make sure and test the ragdoll functionality on the other meshes when I do that. In the short term I'm afraid that if you find any issues with OgreOde it'll be up to you to solve them. I'll help if and when I can, but I simply don't have the spare bandwidth to delve too deeply into it.

Sorry.

Posted: Tue May 03, 2005 6:09 am
by RTsa
I got OgreODE working now. I've also been testing these ragdoll things and I've been using ODE in my earlier projects. Anyway, the 'jittering' of ragdolls is most likely caused by the joints getting over their limits. For example the arms can rotate 360 degrees even though there're limits to the rotating (at least I think there are). When the joints go over limits, there's a force applied to correct it. And this force is sometimes too big, which causes the whole body to move unexpectedly.
There're at least two ways to correct this.
1) Set the forces, which are applied to be smaller and not so rough. Then you won't have the 'jittering', though this might lead to other unwanted phenomenons.
2) Change the limits for the joints. Decreasing them and also doing something I mentioned in 1) might fix this issue almost perfectly. Removing the limits would most likely also work, but that's not neccessarily what we want.