Lightwave to Ogre3D 1.0.1 - source opened

The place for artists, modellers, level designers et al to discuss their approaches for creating content for OGRE.
Post Reply
P
OGRE Expert User
OGRE Expert User
Posts: 421
Joined: Fri Jan 07, 2005 9:49 pm
Location: UK
x 2
Contact:

Post by P »

Hi,

Sorry to be a ghost again but i'm afraid the situation will not change before the end of december

I put here a link to the really OLD beta 0.5 version :

http://pierreblanc.eu/downloads/lw2ogre_beta0.5.rar

Be aware there are few bugs in that version.

And later on, when i'll have again a bit more time, I'll clean and release that version i'm using at the moment.

Best regards!

Emmanuel
Gnoblar
Posts: 4
Joined: Sun Apr 03, 2005 8:11 pm

Post by Emmanuel »

Thanks, very nice !! Can't wait to see this thing finished (..and start a project that requires it ;) )

hemimotorz
Gnoblar
Posts: 2
Joined: Mon Oct 23, 2006 2:51 pm
Contact:

Post by hemimotorz »

8) Running v9 here gonna download it and give it a try :D

Gorlist
Gnoblar
Posts: 15
Joined: Tue Oct 10, 2006 10:38 am

Post by Gorlist »

Slight problem, ive tried exporting a simple cube and find that the file is saved as .mesh.xml? If remove the XML extension then it crashes Ogre.

Any suggestions?

Regards!

broli
Halfling
Posts: 48
Joined: Fri Mar 31, 2006 5:08 pm

Post by broli »

Gorlist wrote:Slight problem, ive tried exporting a simple cube and find that the file is saved as .mesh.xml? If remove the XML extension then it crashes Ogre.

Any suggestions?

Regards!
You'll need to convert it with the xml to mesh converter you find on the website.

@P That's really bad to here :( , but as long as you still work on it then it's fine :D.

EDIT: Can you also please check your PM, P.

GPM
Halfling
Posts: 42
Joined: Thu Aug 10, 2006 12:08 am

Post by GPM »

Bug Report

FYI, for the record the exporter won't write a UV Map to the material file unless the blending mode in LightWave is set to Normal. For example, if you set the blend mode for a surface as Multiply, the UV Map is not witten into the material file.
Obviously, there are other work arounds for this problem.

P
OGRE Expert User
OGRE Expert User
Posts: 421
Joined: Fri Jan 07, 2005 9:49 pm
Location: UK
x 2
Contact:

Post by P »

GPM, that's not a bug, that's a current limitation, and it's written in the manual.

Next version, which is on the way ( and rewritten totally from scratch ) supports multiply blending mode.

the improvements are :

- new options for exporting uv which allow now to export them in order to have exactly the same result as the one visible in lightwave, without having to check every vertices are uvmapped for a given submesh
- better anim support
- smoothing correction
- poses
- global options, bug corrections
- more than 1000 % speed improvement ( in fact i haven't measured, but it's not possible to compare, it's much more fast and allow to export 200k tris meshes in few seconds )
- and much more :)


But you will have to wait a bit more, at the moment i'm beginning to write the interface, i think it can be ready around April and will come with an external mesh/animation viewer.

GPM
Halfling
Posts: 42
Joined: Thu Aug 10, 2006 12:08 am

Post by GPM »

P,
That sounds great. I look forward to the improvements.
Also I appreciate your hard work on this.

GPM
Halfling
Posts: 42
Joined: Thu Aug 10, 2006 12:08 am

Post by GPM »

I have some objects in my scene that don't export. I can see the nodes and entities in the interface, but the they don't export to the .scene file.

Is it possble to parent a node to an entity? for example a sword parented to a hand?
Or a eyeballs parented to a head?

Any help would be apprecaited.

RA/pdx
Halfling
Posts: 47
Joined: Thu Dec 28, 2006 4:55 pm
Location: Nuernberg, Germany
Contact:

Post by RA/pdx »

We use your converter since two days and we have a problem:

- lightwave layouter crashes when trying to convert some of our objects with uv maps (last message in the log file: "Processing smoothing groups (please wait ... )")

and a suggestion for improvement:

- would be great if the converter memorise the settings (like scaling, path)

Thanks for your efforts on this converter and hope to see a new version soon. ;-)

RA/pdx
Halfling
Posts: 47
Joined: Thu Dec 28, 2006 4:55 pm
Location: Nuernberg, Germany
Contact:

Post by RA/pdx »

And a question: Is it possible to compile the converter that it can be used with Lightwave on OSX, too?

GPM
Halfling
Posts: 42
Joined: Thu Aug 10, 2006 12:08 am

Post by GPM »

The Mac OS issue is something that the author is aware of: It has been posted as a request, but I think someone with knowledge of the mac os will need to assist.

On the crashing problem, all of my objects are uv mapped and I have had no problems. Are your objects dense? i.e. a lot of geometry? More information might be helpful.


Processing Smoothing Groups occurs before UV maps are filled.

Below is information from the manual:

"Processing smoothing groups
Once the data are loaded, the exporter will scan the object, in order to build smoothing groups, using the
Max Smoothing Angle value from each surface. This step is needed because when you want an hard edge
between 2 triangles, you have to split a new vertex for each triangle with a different normal for each one.
This step can take several seconds on high poly objects."

RA/pdx
Halfling
Posts: 47
Joined: Thu Dec 28, 2006 4:55 pm
Location: Nuernberg, Germany
Contact:

Post by RA/pdx »

I am using a Mac and i am a programmer but my knowledges about OSX are not very good, but if i could help or even just testing i will do it!

Now we could convert all our objects - the problem was that some of them had vetices with just 2 points (artefacts from merging). So we removed them and it works.
Still 4 objects from about 20 are not shown in ogre like they should. There is no texture to see, even there is one in the material file. It looks like the first pixel of the texture is used for the whole object. :?:
Last edited by RA/pdx on Wed Mar 21, 2007 9:40 am, edited 1 time in total.

GPM
Halfling
Posts: 42
Joined: Thu Aug 10, 2006 12:08 am

Post by GPM »

It sounds like a something is wierd with your UV map. You might want to change the color of this iamge to make sure that the 1 pixel really is being uv'd to the whole object.

You might also want to look at the lightwave to ogre manual. there are some limitiations on blend modes for textures.

GPM
Halfling
Posts: 42
Joined: Thu Aug 10, 2006 12:08 am

Exporting Baked IK - LightWave to Ogre

Post by GPM »

I found that when baking IK into FK, you will need to remove your IK goals before you export the bone animation, otherwise the Bone translation for the items previously under IK control will not export.

RA/pdx
Halfling
Posts: 47
Joined: Thu Dec 28, 2006 4:55 pm
Location: Nuernberg, Germany
Contact:

Post by RA/pdx »

Till now we don´t have any bones or animations in our meshes.

I changed the first pixel of the texture and this one is really used for the whole mesh. :?:

GPM
Halfling
Posts: 42
Joined: Thu Aug 10, 2006 12:08 am

Post by GPM »

I would open the object in LightWave Modeler and check the UV map. I suspect that your texture has been stretched accross the entire mesh.
Use UV texture View to see how the UV map looks. You may need to remap the object and resave it. Make sure you update all assets involved in this mesh: Materail, mesh, and image.
It might also a be something with the image type you are using. I use .tga 24-bit.

RA/pdx
Halfling
Posts: 47
Joined: Thu Dec 28, 2006 4:55 pm
Location: Nuernberg, Germany
Contact:

Post by RA/pdx »

The meshes and the uv-mapping looks perfect in Lightwave.
We are using "tif" for textures but we have also tested "bmp" and "tga". Always the same result after converting to Ogre...

P
OGRE Expert User
OGRE Expert User
Posts: 421
Joined: Fri Jan 07, 2005 9:49 pm
Location: UK
x 2
Contact:

Post by P »

Totally new version of the plugin available. First post updated.

@RA/pdx : the problem you have is due to a limitation of the old plugin, which made it mandatory to have all vertices of a resulting submesh mapped to get the vertex map exported. This limitation is done in the new version.

User avatar
sinbad
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 19265
Joined: Sun Oct 06, 2002 11:19 pm
Location: Guernsey, Channel Islands
x 66
Contact:

Post by sinbad »

Nice one P :)

Do you have any plans to make the source for this exporter available under an open source licence? If so we can host it for you.

RA/pdx
Halfling
Posts: 47
Joined: Thu Dec 28, 2006 4:55 pm
Location: Nuernberg, Germany
Contact:

Post by RA/pdx »

Hello P, great to hear there is a new version.

Today we have installed it like it was mentioned in the manual but Lightwave 8.5 couldn´t find the plugin. :( We have tried it several times with manual selection and with autoscan.
It was no problem to install the old 0.5 version.

Any hints?

P
OGRE Expert User
OGRE Expert User
Posts: 421
Joined: Fri Jan 07, 2005 9:49 pm
Location: UK
x 2
Contact:

Post by P »

Sorry about that, I had provided a wrong version of the vcredist_x86.exe. I also recompiled the plugin removing a part of wxWidgets I was not using anymore.

Download the new version (0.9.6) and execute again vcredist_x86.exe, the plugin should then install properly.


@Sinbad :

When I began to write the plugin that was my plan, to make it opensource. But finaly I see that it's near to be a in a 1.0 state and since i'm available to maintain it at the moment and ready to implement anything needed, I don't see the need to open the source for now. If in the future for any reason I stop maintaining it, then yes, I will make it opensource so someone can take the relay.

What is sure is that it will remain free, and unless someone find a bug I missed, it is ready for production.

P
OGRE Expert User
OGRE Expert User
Posts: 421
Joined: Fri Jan 07, 2005 9:49 pm
Location: UK
x 2
Contact:

Post by P »

Please tell me if it doesn't work for someone, I planned to try to switch to Mingw and that may accelerate the process :P

RA/pdx
Halfling
Posts: 47
Joined: Thu Dec 28, 2006 4:55 pm
Location: Nuernberg, Germany
Contact:

Post by RA/pdx »

It works with version 0.96! :D

Thanks a lot for this great tool!!! I especially like the batch converting and the optional use of OgreXmlConverter.exe.

P
OGRE Expert User
OGRE Expert User
Posts: 421
Joined: Fri Jan 07, 2005 9:49 pm
Location: UK
x 2
Contact:

Post by P »

Great ! Thank you.

Using the Vertex Map Policies requires to understand the structure of an Ogre mesh, I tried to speak about it in the manual, but if anything need to be cleared, just make a call !

Artists coming from offline 3D are used to use as many Texture Map as textures for an object, it's absolutly possible to follow that way but I strongly recommend to learn to use "global" Texture Maps ( as they are internally ), per instance one for the diffuse texture, one for the Lightmap, shared by all Surfaces and all Object. It simplifies a lot the mapping and later allows a straight forward export.

Post Reply