Page 1 of 8

Lightwave to Ogre3D 1.0.1 - source opened

Posted: Sun Feb 05, 2006 12:51 am
by P
Lightwave to Ogre3D is a Lightwave plugin to export meshes, skeletons, skeletal animations, pose animations and scenes to Ogre.


Features :

- Mesh Export including materials, skeletons, skeletal animations, poses and poses animations.
- Batch Mesh Export to export all meshes at once.
- New way to easily manage the export of Vertex Maps.
- Scene export to dotScene format including most dotScene elements.
- Global options saved between uses.
- Non modal native interface.
- OgreXmlConverter frontend including all options.


Please read the manual carefully.


You can find the plugin here : lw2ogre1.0.1

The plugin is Windows only. I have tested it on Lightwave 9.0 but it should work on Lightwave 7.5 and above.

Please report any bug or ask any question in this forum thread instead of sending me a mail, so everybody can benefit from answers.


Happy exporting !

Posted: Sun Feb 05, 2006 12:58 am
by sinbad
Congrats P, I know you've been chewing on this one for a while ;)

Posted: Sun Feb 05, 2006 12:16 pm
by dennis
Way to go P!

Posted: Sun Feb 05, 2006 4:27 pm
by P
Thanks.

@Sinbad : yes :) and I haven't been able to reproduce the problem I had with exporting skeletal animations, when I rewrote that part.

notes :

- forum thread updated, it's in fact the beta 0.1, and not 1.0
- working on a fix for a bug I found this morning, new version before the end of the day.

edit :

New version beta 0.2 uploaded, initial post updated.

(btw Sinbad, is it possible to delete the old thread about my old plugin ? I was thinking this new version which have nothing to do with the old one deserves a new thread, but the old one could be confusing).

Posted: Sun Feb 05, 2006 7:15 pm
by sinbad
I don't normally delete threads unless they're offensive or in error, just post a link to this thread at the bottom and edit the first post to do the same.

Posted: Mon Feb 06, 2006 6:05 am
by krabbity
kool, P,
we'll be looking at this very soon :)

Posted: Mon Feb 06, 2006 3:31 pm
by P
Updated the manual with 2 new pages, analyzing step by step the information messages you can read inside the monitor while exporting a mesh.

(only updated in the direct link, i'll update the archive later, for the next version)

Posted: Mon Feb 06, 2006 5:06 pm
by Gaffeghan
Absolutly fantastic P! Congrats, the long awaited exporter will quickly become a huge relief to the lightwave-using ogre community. I'm glad you decided to stick with lightwave, I love it, and I'm really happy to be able to use it to design my models for Ogre!

Thank you P!

[to self] Darn, now I have no more excuses for my slow progress with Ogre.[/to self]

Posted: Mon Feb 06, 2006 11:36 pm
by Gaffeghan
Seems that when I try to open the plugin (master plugins::lightwave2ogre::properties) it crashes layout. Is there a step I'm missing?
LW2Ogre_Manual wrote: How to install the plugin
First of all, go to the /VCCRT directory and launch the file vccrt.msi if you haven't Microsoft Visual Studio
8.0 installed.
Create a new directory inside your Lightwave's plugin directory, and copy the file lw2ogre.p here.
Copy all dlls from the /Dlls directory coming with the archive, inside your Lightwave /Programs directory.
( Here I copied all these dll to C:\Program Files\LightWave [8]\Programs\ ).
Open the Layout and add the plugin. (locate the file lw2ogre.p).
I've done that, but I'm curious, is anything supposed to happen when I open 'vccrt.msi?' for me, all it does is open a small message box "MSI to REDISTRIBUTE MY APP" with a loading bar, when the bar is full the box closes and nothing else happens. Is this normal?

Posted: Mon Feb 06, 2006 11:43 pm
by IFASS
Amazing stuff P!

Posted: Tue Feb 07, 2006 1:28 am
by P
@ Gaffeghan :

Yes it's normal. If you hadn't done that, you would not be able to add the plugin from the Layout.

I just corrected a bug I hadn't noticed (beta0.3) which could maybe cause the problem you are having, but someone tomorrow told me he tried the plugin and it was working.

Once the plugin is in the list of Master Plugins, it's loaded and active. When you double-click on it, or right-click and choose properties, it synchronizes the data and open the main panel. So, have you tried it with an empty scene ? Or with different scenes ? There might be a problem i'm not aware of.

What is your version of Windows ? Have you the service pack 2 installed if it's Windows XP Pro (I'm not sure it's required) ? What Lightwave version are you using ?



If someone tried the plugin and it works, please tell me. I must leave home in 2 days for at least 1 week, and I would like to be sure everything works fine before.

Posted: Tue Feb 07, 2006 1:46 am
by Gaffeghan
The properties window opens fine with an empty scene. When I add models and then try to open the properties window, it crashes lightwave.

I'm using Windows XP, service pack 2. Lightwave version 7. I'll try beta 0.3

Posted: Tue Feb 07, 2006 1:57 am
by P
beta 0.3 will not help here, I was thinking you were not able to open the panel with an empty scene. It seems there is a problem while loading the data.

I just tried to add 40 models from Lightwave content directory and to open the plugin main panel, then the mesh exporter panel : it works here.

Btw you should download the 7.5 patch if you don't have the 8.0 license :
http://www.newtek.com/lightwave/downloa ... wave75.php

Posted: Tue Feb 07, 2006 4:54 pm
by Gaffeghan
Question: does the exporter handle procedural textures or will I have to bake them? I used a regular model in testing as well as one with procedurals and they both crashed lightwave.

Posted: Tue Feb 07, 2006 5:32 pm
by P
No it doesn't handle procedural textures, but this only means no texture will be exported when they are procedural, not that it will crash the Layout.

Tried it again several times this morning without problem, but here I have Lightwave version 8.5.

Have you updated your version of Lightwave to 7.5 ? Anyway, there should be no specific 8.0 code inside the plugin, but I'll check again.

Posted: Tue Feb 07, 2006 7:49 pm
by Gaffeghan
I tried the plugin with lightwave 8 and it still crashed. Maybe it's my system? I can't use some programs no matter what, because they're incompatible with me setup.

Posted: Tue Feb 07, 2006 7:55 pm
by P
Sorry I have no idea then apart reinstalling a clean system.

Maybe you could try to debug it, but for that you will need the source code, which I will release anytime soon.

Posted: Thu Feb 09, 2006 3:48 am
by P
@Gaffeghan : You aren't the only one who has the problem.

I spent 1 hour this evening with Leandro who has exactly the same problem, and who is using Lightwave 7.5.
One of his friend tried the plugin with 8.0 without problem.

I have identify the problem, but not found the solution yet.

I'm using several functions of the SDK to get infos about objects, I can't do without it, I need to get their data. And it appears that requesting the LWOBJECTINFO_GLOBAL fails and returns a NULL. In others words, it doesn't work and it should work exactly the same way since the version 6.0.

Also, with my old plugin, I was using the same functions, and it was working.

So, maybe it comes from the fact i'm using MSVC8.0, or something else I don't know.

What I do know is I will ask the question on the lwdev yahoo group, to see if someone experienced the same problem, and I will look at it again in 10 days when I will come back.

If someone is using Lightwave 7.x and have no problem with the plugin, I would be happy to know it.

Posted: Thu Feb 09, 2006 11:26 am
by P
Here is a fix for Lightwave 7.5 users.

Lightwave to Ogre beta 0.3 - Lw7.5

The archive only contains the plugin file, you still need to download the archive from the first post if you are installing for the first time.

I only changed the version of the global I was talking about, but this may be not the only one who has changed with the Lightwave 8 SDK. I don't have the time right now, but in few days, I'll finish the global requesting part, to handle these kind of problems, and display a nice message to the user at least.

Tell me if it works.

edit :

the fix is in fact only working with 7.5. Try the next one which should work for any version between 7.0 and 8.5.

Posted: Thu Feb 09, 2006 12:44 pm
by P
Ok the fix in my previous post should in fact only work for Lightwave 7.5 users.

Here is a fix for Lightwave 7.0 users.

Lightwave to Ogre beta 0.3 - Lw7.0

(this one should work for version 7.0 to 8.5)

Waiting for your comments.

Posted: Fri Feb 10, 2006 1:25 am
by Gaffeghan
I'm leaning toward the possiblilty that I'll have to either 1: format my computer and clean-install XP, or 2: try on a different computer. The exporter (7.0 fix) still won't work for me in either LW7 or 8. Later tonight or tomorrow night I'll test it on my laptop. If it works on my laptop I'll just use that for exporting.

Posted: Sat Feb 11, 2006 2:10 am
by P
Sorry to hear that.

I will implement a logging feature when requesting lw globals as soon as I come back home, to try to track where is hapenning the problem. It could be a mistake of mine.

Someone just told me on msn, that the second fix I provided, made the plugin work with Lightwave 7.5.

I still hope to have more feedback.

A missing feature, something you would like to do differently, something you like/dislike, not enough explainations in the manual : any comment will be appreciated.

Posted: Mon Feb 13, 2006 9:33 am
by BoX
I've tried to use the plugin but never got it to run properly. First of all, I used LW 7.0b and then LW 7.5d (upgraded, just to run the exporter). All three plugin versions fail to export the scene. And the problem seems to be the same: exporter runs correctly when a scene is empty (i.e. displays plugin interface), but fails to initialize (and crashes LW) if there is an object in the scene (doesn't matter how complex the object is).

I'll try to use it with LW8 as soon as I can, and will post a feedback here.

Is there a log I can send you that will help you identify the problem?

Posted: Mon Feb 13, 2006 11:33 am
by P
ok, so it means i'm using globals which have been updated in 8.0 8.2 or 8.5.

I'm afraid it works only on 8.5

When i'll be back home at the end of the week, I ll write a log for each global i'm requesting. I'm not using any function from the Lightwave SDK which have introduced lately, but since I have only the 8.5 SDK, I need to check which globals have been updated, and request previous versions.

Sorry about that. I'll update it as soon as I will be back home.

Posted: Tue Feb 14, 2006 10:14 pm
by BoX
P wrote:I'm afraid it works only on 8.5
I'm affraid too. I finally got a chance to try the plugin in LW8, and it showed exactly the same behavior as earlier. Plugin interface initializes in case of a clear scene, but fails to initialize if the scene contains any nymber of objects.

I hope that you will solve this problem as soon as possible. If there is any of you that succeded in using this exporter, help me, please! ;)