Problem seen UV in Ogre??

The place for artists, modellers, level designers et al to discuss their approaches for creating content for OGRE.
Post Reply
Mhiriacor
Gnoblar
Posts: 12
Joined: Thu Nov 06, 2003 12:48 pm

Problem seen UV in Ogre??

Post by Mhiriacor »

I have export with plugins of 3DStudio MAX an object with UV texture but a part of it (head) is not good defined in Ogre but yes in 3DStudio MAX. Do you know reason???. Thank you for your time guys.

User avatar
Banania
Gremlin
Posts: 150
Joined: Wed Oct 20, 2004 2:35 pm
Location: Paris, France
Contact:

Post by Banania »

Which exporter are you using ? If you downloaded it on the website, you might want to upgrade to the CVS version and try again.

And if it doesn't work, you might want to give a little more details.....
Banania

MikeF
Gnoblar
Posts: 11
Joined: Sun Nov 21, 2004 2:20 am

Post by MikeF »

Not sure if it's the same problem i have, but sounds similar. Certain areas of the model have extreemely distorted uv's in Ogre, but are fine in Max. This comes from exporting with the latest exporter build. Not sure what's causing this, it seemed to work fine with the last set of exporters....

User avatar
Banania
Gremlin
Posts: 150
Joined: Wed Oct 20, 2004 2:35 pm
Location: Paris, France
Contact:

Post by Banania »

Is it possible for one of you to send me a model so I can test this ?

I once had an example with some UV problems but it is corrected now.

bananupheNOSPAM@hotmail.com (without NOSPAM)

Are you sure you are using the latest version ? (latest version is always in cvs)
Banania

MikeF
Gnoblar
Posts: 11
Joined: Sun Nov 21, 2004 2:20 am

Post by MikeF »

unfortuanately because i'm under a NDA i cannot send you the model. All i can say is that i am using version 0.15.1 of the exporter... sorry i cant give you much information

User avatar
Banania
Gremlin
Posts: 150
Joined: Wed Oct 20, 2004 2:35 pm
Location: Paris, France
Contact:

Post by Banania »

unfortuanately because i'm under a NDA i cannot send you the model. All i can say is that i am using version 0.15.1 of the exporter... sorry i cant give you much information
Then, try using cvs version of the exporter. The uv problem I was talking about was not solved in 0.15.1. I did solve it later so it might very well be the same problem.
Banania

MikeF
Gnoblar
Posts: 11
Joined: Sun Nov 21, 2004 2:20 am

Post by MikeF »

Thank you so much, everything is working great now

User avatar
Banania
Gremlin
Posts: 150
Joined: Wed Oct 20, 2004 2:35 pm
Location: Paris, France
Contact:

Post by Banania »

Nice !
Banania

Mhiriacor
Gnoblar
Posts: 12
Joined: Thu Nov 06, 2003 12:48 pm

Post by Mhiriacor »

i haven´t used CVS, can you explain me sortly how to download the latest version of 3DStudio MAX exporter??.
Thank you for your time guys.

User avatar
Banania
Gremlin
Posts: 150
Joined: Wed Oct 20, 2004 2:35 pm
Location: Paris, France
Contact:

Post by Banania »

I am afraid there is no "short and easy way" to get the CVS version. You will have to setup a CVS access to do that. And you should if you seriously plan on using Ogre because fixes are usually available in CVS a long time before they officially released.

However, there is two ways you can download the exporter without CVS.

First, by downloading the cvs snapshot in the download section. A 30MB download but a sure way to get an up-to-date version.

You can also download my version here :

http://bananialair.ifrance.com/bananial ... xport2.zip

It is almost always up-to-date with CVS. It is not right now, but should be close enough.

EDIT : This download is up-to-date now. (January, 3rd 2005)
Banania

Post Reply