blender: character's pose not exported correctly

The place for artists, modellers, level designers et al to discuss their approaches for creating content for OGRE.
Post Reply
Akrisios
Gnoblar
Posts: 17
Joined: Fri Sep 07, 2012 2:20 pm

blender: character's pose not exported correctly

Post by Akrisios » Tue Oct 16, 2012 5:26 pm

Hello,

I've created a human character with makehuman and successfully imported it into blender. There it has its standard T pose for beginning, feet on the ground. I now try to make the character sit on a cube. While everything looks fine in Blender, things get scary after exporting Ogre: The mesh is sitting, but the skeleton is not. To be more specific: The skeleton still stands in T pose. I've tested with the T posed mesh and all works fine. So since I don't need legs to animate this wouldn't be a problem if the bones from the upper part of my sitting character would fit the mesh, but because of the sitting position, feet still on the ground, the mesh is somewhere below its skeleton, so bone transitions (manually set in ogre) look quite scary.
I tried modifying the skeleton in Blender's edit mode as well as in the pose mode, but it looks to me as if the Blender2Ogre exporter doesn't work for exporting altered skeletons.

Any suggestions on this?
0 x

User avatar
Waruck
Goblin
Posts: 210
Joined: Mon Dec 12, 2011 12:52 pm
Location: Germany

Re: blender: character's pose not exported correctly

Post by Waruck » Wed Oct 17, 2012 8:47 am

sounds like a mismatch between blender's mesh-data and skeleton data. This comes by multiple reasons but for me it soudns like you built the sitting-pose for your mesh in blender's edit-mode making it the default-position and then adjusting your skeleton in 'pose-mode' to that position before binding them together, thus making the sitting-pose not the 'binding-pose' of your skeleton, but keeping the T-pose. Blender can handle this so it still looks good, but the exporter only looks at the rest-pose of your mesh (the one you see in edit mode) and the binding-pose of your skeleton (which you see in pose-mode if you clear all rotations, locations, scales).
If these positions are mismatched:
- disband your skeleton from your model to make them independent again.
- go to pose-mode, clear all bone's transformation,
- (to be sure you should also go to object mode and clear all transformations on your skeleton and your mesh).
- After that go to edit mode and match the skeleton to your pose
- bind your skeleton to your mesh

A more common way would be to export both, mesh and skeleton in T-pose, export the sitting-pose as an animation and blend other animations over it.

Also if you require further help it would be helpful if you'd offer your .blend file or exported .mesh and .skeleton to figure out what's exactly your problem.

P.S. after thinking about it a blender skeleton might have an option to apply a pose from pose-mode as the new binding-pose, but I'm not sure about that right now.
0 x

Akrisios
Gnoblar
Posts: 17
Joined: Fri Sep 07, 2012 2:20 pm

Re: blender: character's pose not exported correctly

Post by Akrisios » Wed Oct 17, 2012 9:36 am

thanks for your answer, but I figured out, that the T posed skeleton in Ogre comes from the original mesh. :?
I've exported the sitting character into a subfolder of my T posed character, not thinking about Ogre's loading algorithm. Because I need the T posed character in another situation, I load it into Ogre. Ogre then keeps this skeleton for my sitting character since it's skeleton has the same name, but is in the subfolder and obviously ignored by Ogre because there's already one skeleton loaded that is named like that. :roll:

Anyway, after renaming stuff, my character now has a sitting skeleton - that is still not yet fitting, while looking fine in Blender, it's quite in front of my mesh. So I'll try to fix that as you mentioned. If nothing works, I'll post the mesh to beg you for having a look at.
0 x

Post Reply