Can't compile ogitor editor

The place for artists, modellers, level designers et al to discuss their approaches for creating content for OGRE.
Post Reply
neighborlee
Halfling
Posts: 44
Joined: Sun Dec 08, 2002 10:16 pm
Contact:

Can't compile ogitor editor

Post by neighborlee »

Trying to compile ogitor from source and having trouble. I posted on ogitor forum website, but its a rather dead place, so I thought posting here 'might' yield faster results given Im trying to move forward not idle in place ;)
Ogitor seems to be a very nice editor but I can't wait days for a reply when I need to get things done, so I wanted to be clear why I was posting here, not there.

Here are my current errors that I need some help with, as Ive tried all I can think of ,but getting nowhere.

EDIT EDIT EDIT: I just went with gtk+bundle is allowing pkg_config exe to finally work, but cmake . still isn't getting very far:
C:\Users\Gaillard Lee\Downloads\ogitor_src>cmake .
-- Building for: Visual Studio 11
-- Building Ogitor version 0.5.4
-- OGITOR_DIST is set to OFF
-- Looking for OGRE...
-- OGRE_PREFIX_WATCH changed.
-- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
-- Could not locate OGRE
CMake Error at CMakeModules/FindPkgMacros.cmake:110 (message):
Required library OGRE not found! Install the library (including dev
packages) and try again. If the library is already installed, set the
missing variables manually in cmake.
Call Stack (most recent call first):
CMakeModules/FindOGRE.cmake:222 (findpkg_finish)
CMakeLists.txt:138 (find_package)


-- Configuring incomplete, errors occurred!

I do have pkgconfig installed, and it works from console, so I've no idea what could be wrong.

thx
lee
========================================
all our tomorrows hold to hope we remember the past and make today a bright reminder of our humanity and what we have to look fwd to and become..

Transporter
Minaton
Posts: 933
Joined: Mon Mar 05, 2012 11:37 am
Location: Germany
x 110

Re: Can't compile ogitor editor

Post by Transporter »

Have you set the environment variables for Ogre?

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Can't compile ogitor editor

Post by jacmoe »

Did you take a look at the guide?
https://bitbucket.org/jacmoe/ogitor/wik ... _-_Windows

Transporter recently created havoc in our code, so you might want to use OGRE_HOME instead of OGRE_GHADAMON.

And, yes: you need Ogre 1.9.

If you are on Ogre 1.8, you need to travel back in time.

Ogitor is preparing for the Ogre 1.9 release, and after that our 0.5 branch will stay compatible with it.
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

neighborlee_
Gnoblar
Posts: 7
Joined: Wed Mar 13, 2013 5:11 pm

Re: Can't compile ogitor editor

Post by neighborlee_ »

THe guide says nothing about 1.9 being a necessity, as it clearly says I can use 1.8, which I have ( and I have used the correct ENV VAR FOR that version, as noted on the guide). If 1.8 is no longer doable,maybe the guide should be updated.

I have several ENV variables set. Boost_DIR, and any others that were noted on that website. I only got as far as I did, by referring to that guide in the first place , so ya.

I'll wait for a reply,before having to again, download more content which I don't look fwd to at all.

And what is the translation regarding I need to travel back in time if Im using 1.8, when I need 1.9...did you mean travel forward :)

I will change the env var as noted.

thx
nl

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4293
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 127
Contact:

Re: Can't compile ogitor editor

Post by spacegaier »

1.8 and 1.9 should be possible. Transporter and I paid attention to make it possible to use both IIRC.
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

neighborlee_
Gnoblar
Posts: 7
Joined: Wed Mar 13, 2013 5:11 pm

Re: Can't compile ogitor editor

Post by neighborlee_ »

ok ty so much for verify.

nl

neighborlee_
Gnoblar
Posts: 7
Joined: Wed Mar 13, 2013 5:11 pm

Re: Can't compile ogitor editor

Post by neighborlee_ »

I am getting a lot further now that I have the right QT ( I had downloaded qt sdk supposedly the right one, but even it had ming in it though nothing about ming showing in download name_.

However I have a new problem which has cmake=gui unable to find qt in its entirety.

As seen below,

Code: Select all

CMake Error at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:97 (message):
  Could NOT find Qt4 (missing: QT_QMAKE_EXECUTABLE QT_MOC_EXECUTABLE
  QT_RCC_EXECUTABLE QT_INCLUDE_DIR QT_LIBRARY_DIR QT_QTSVG_INCLUDE_DIR
  QT_QTSVG_LIBRARY) (Required is at least version "4.5.0")
, many var's apparently are needed ?

The only one I have set is as noted on the ogitor wiki .
If I need to set all these that's fine, I just want to verify there isn't a quicker way to achieve this.
thx
nl

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Can't compile ogitor editor

Post by jacmoe »

You need to read the guide to compiling Ogitor. :)

https://bitbucket.org/jacmoe/ogitor/wik ... qt-toolkit

Two steps needed for Qt: add the Qt/bin directory to your PATH, and create a QTDIR environment variable.
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

neighborlee_
Gnoblar
Posts: 7
Joined: Wed Mar 13, 2013 5:11 pm

Re: Can't compile ogitor editor

Post by neighborlee_ »

I didn't mean to imply I only had ONe set in variables list as I clearly read the guide ( as I already told you, so no need to repeat yourself ) which indicates setting PATH:bin( for QT) and qtdir, but I think I simply forgot to 'reset' the bin, because I had to RE download qtsdk because the version 4.8 I had included MING and that conflicted with VS2011 according to cmake-gui error.

Ill repoint the bin path to correct sdk and update this post if its fixed.

thx
nl

neighborlee_
Gnoblar
Posts: 7
Joined: Wed Mar 13, 2013 5:11 pm

Re: Can't compile ogitor editor

Post by neighborlee_ »

Ok, at least its getting further, and while obviously, I have set PATH: bin for qt and have set QTDIR to qt home, I am still getting this:

CMake Warning at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindQt4.cmake:615 (message):
C:/QtCommercial/QtCommercial5.0.1/5.0.1/msvc2010/bin/qmake.exe reported
QT_INSTALL_LIBS as "C:/QtCommercial/QtCommercial5.0.1/5.0.1/msvc2010/lib"
but QtCore could not be found there. Qt is NOT installed correctly for the
target build environment.
Call Stack (most recent call first):
Dependencies/ImageConverter/CMakeLists.txt:8 (find_package)


CMake Error at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindQt4.cmake:619 (message):
Could NOT find QtCore. Check C:/Users/Gaillard
Lee/Projects/Ogitor_build/CMakeFiles/CMakeError.log for more details.
Call Stack (most recent call first):
Dependencies/ImageConverter/CMakeLists.txt:8 (find_package)

QT5core.dll is there, but no 'qtcore'.

thx anyone for help with this.

nl

Transporter
Minaton
Posts: 933
Joined: Mon Mar 05, 2012 11:37 am
Location: Germany
x 110

Re: Can't compile ogitor editor

Post by Transporter »

neighborlee_ wrote:CMake Warning at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindQt4.cmake:615 (message):
C:/QtCommercial/QtCommercial5.0.1/5.0.1/msvc2010/bin/qmake.exe reported
QT_INSTALL_LIBS as "C:/QtCommercial/QtCommercial5.0.1/5.0.1/msvc2010/lib"
but QtCore could not be found there. Qt is NOT installed correctly for the
target build environment.
Call Stack (most recent call first):
Dependencies/ImageConverter/CMakeLists.txt:8 (find_package)


CMake Error at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindQt4.cmake:619 (message):
Could NOT find QtCore. Check C:/Users/Gaillard
Lee/Projects/Ogitor_build/CMakeFiles/CMakeError.log for more details.
Call Stack (most recent call first):
Dependencies/ImageConverter/CMakeLists.txt:8 (find_package)

QT5core.dll is there, but no 'qtcore'.
Ogitor is not ready for QT5! You have to use QT4 at the moment.

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Can't compile ogitor editor

Post by jacmoe »

D'oh - no, not yet. :)
Qt5 is not even available for Debian AFAIK.
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

neighborlee_
Gnoblar
Posts: 7
Joined: Wed Mar 13, 2013 5:11 pm

Re: Can't compile ogitor editor

Post by neighborlee_ »

Trouble is there is no 4.8 version that has a sdk binary as I recall..the only one uses MINGw and that's not compatible with VS2011.

Please make a note ? on the wiki for ogitor that 5 wont work...it says; " Ogitor depends on the Qt Framework, OGRE, a few specific plugins that come bundled with OGRE, and Boost-regex.

Currently:
•Qt version 4.6 and up.
"
Anyone have a url for a non mingw i'd appreciate it. I checked the email I got to download qt and im not seeing anything short of having to compile and i'd rather avoid it if possible.

thx
nl

Transporter
Minaton
Posts: 933
Joined: Mon Mar 05, 2012 11:37 am
Location: Germany
x 110

Re: Can't compile ogitor editor

Post by Transporter »

neighborlee_ wrote:Trouble is there is no 4.8 version that has a sdk binary as I recall..the only one uses MINGw and that's not compatible with VS2011.
First, look at the offical QT page http://qt-project.org/downloads. You can find binaries for Windows from mingw, VS2010 and VS2008. If you like to have VS2012, you can compile it.

Compiling QT4 is really easy. QT5 is a pain!
  1. Download QT source code (http://releases.qt-project.org/qt4/sour ... -4.8.4.zip)
  2. Extract the source code
  3. Open an Visual Studio Command Line
  4. Go to source dir, like
    cd C:\qt\qt-everywhere-opensource-src-4.8.4
  5. Modify target file: http://stackoverflow.com/questions/1211 ... tudio-2012
  6. configure -opensource -confirm-license -platform win32-msvc2010 -nomake demos -nomake examples -no-opengl -no-qt3support -arch windows -mp
    nmake
    nmake clean
    cd translations
    nmake
    nmake clean
    cd ..\lib
    del *.dll

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Can't compile ogitor editor

Post by jacmoe »

Wait a second: VS2011 doesn't even exist. :)
I guess you mean VS2012, right? (VC11)
Then you are out of luck.

However, VC2010 works. And is tested by the Ogitor team. It's the officially supported version.And the precompiled Qt sdk works with that.

I've heard that there will be a precompiled sdk for VS2012 "shortly".
But that's not tested by the Ogitor team.

Qt5, though, is not supported.
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Can't compile ogitor editor

Post by jacmoe »

If you can get VS2012 to work, great. ;)
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

neighborlee_
Gnoblar
Posts: 7
Joined: Wed Mar 13, 2013 5:11 pm

Re: Can't compile ogitor editor

Post by neighborlee_ »

Seems Im very close to finally getting this mess compiled LOL

I have QT484 & VS2010, done.

I don't have a successful cmake session though, as given:

Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Found OIS: optimized;C:/Users/Gaillard Lee/Downloads/OgreSDK_vc10_v1-8-1/lib/release/OIS.lib;debug;C:/Users/Gaillard Lee/Downloads/OgreSDK_vc10_v1-8-1/lib/debug/OIS_d.lib
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Boost_REGEX_LIBRARY (ADVANCED)
linked by target "qtOgitor" in directory C:/Users/Gaillard Lee/Downloads/ogitor_src/qtOgitor

Configuring incomplete, errors occurred!

The VAR's ( precisely by wiki guide!) ; boost library points to boost/lib and boost regex points to the boost dir/regex location which I presume are the intended values ?

Also in case it matters,I get 2 errors for ogre:

Looking for OGRE_Volume...
Could not locate OGRE_Volume
Looking for OGRE_Overlay...
Could not locate OGRE_Overlay

thx
nl

Transporter
Minaton
Posts: 933
Joined: Mon Mar 05, 2012 11:37 am
Location: Germany
x 110

Re: Can't compile ogitor editor

Post by Transporter »

This is a small tutorial to explain how to compile Ogitor using QT 4.x and VS2010.
Prerequisites I have the following folder structure:
  • C:\dev\qt-everywhere-opensource-src-4.8.4 - Qt source code or Qt SDK
  • C:\dev\boost-1.54-rev83369-vc100-x86-09.03.2013 - Boost SDK with binaries and libraries in stage\lib subfolder
  • C:\dev\OGRE-SDK-1.9.0-vc100-x86-09.03.2013 - Ogre SDK
  • C:\dev\ogitor - Ogitor source code
Qt 4.x
First, look at the offical QT page http://qt-project.org/downloads. You can find VS2010 binaries for Windows and also the source code to compile it:
  1. Download QT source code (http://releases.qt-project.org/qt4/sour ... -4.8.4.zip)
  2. Extract the source code
  3. Open a Visual Studio Command Prompt
  4. Go to source dir

    Code: Select all

    cd C:\dev\qt-everywhere-opensource-src-4.8.4
  5. Build the configuration of Qt

    Code: Select all

    configure -opensource -confirm-license -platform win32-msvc2010 -nomake demos -nomake examples -no-opengl -no-qt3support -arch windows -mp
  6. Build Qt

    Code: Select all

    nmake
    nmake clean
  7. Build translations

    Code: Select all

    cd translations
    nmake
    nmake clean
  8. Clean up

    Code: Select all

    cd ..\lib
    del *.dll
Ogitor
  1. Open a Visual Studio Command Prompt
  2. Download Ogitor code and move to the directory

    Code: Select all

    cd C:\dev
    hg clone https://bitbucket.org/jacmoe/ogitor
    cd ogitor
  3. Due to Source Control Changes for heavy binaries, "RunPath/Media" and "RunPath/Projects" are now excluded from repository. Instead they are supplied as extra downloads from: Please download and extract them to your SOURCE path's "RunPath" directory (C:\dev\ogitor\RunPath) in order to build and install Ogitor.
  4. Setup environmental variables (if not set already)

    Code: Select all

    SET QTDIR=C:\dev\qt-everywhere-opensource-src-4.8.4
    SET OGRE_HOME=C:\dev\OGRE-SDK-1.9.0-vc100-x86-09.03.2013
    SET BOOST_ROOT=C:\dev\boost-1.54-rev83369-vc100-x86-09.03.2013\stage\lib
    SET Boost_REGEX_LIBRARY=%BOOST_ROOT%
  5. Create output directory

    Code: Select all

    mkdir build
    cd build
  6. Run CMake

    Code: Select all

    C:\dev\cmake-2.8.10.2-win32-x86\bin\cmake.exe -D CPACK_BINARY_NSIS:BOOL=OFF -D CPACK_SOURCE_ZIP:BOOL=OFF -D OGITOR_MESHMAGICK_INTERFACE:BOOL=OFF -D OGITOR_MSVC_ENABLE_MP:BOOL=ON -D CMAKE_INSTALL_PREFIX:PATH=C:\dev\ogitor\bin -D BOOST_LIBRARYDIR:PATH=C:\dev\boost-1.54-rev83369-vc100-x86-09.03.2013\stage\lib -D Boost_DIR:PATH=C:\dev\boost-1.54-rev83369-vc100-x86-09.03.2013 -D BOOST_ROOT:PATH=C:\dev\boost-1.54-rev83369-vc100-x86-09.03.2013 -D Boost_INCLUDE_DIR:PATH=C:\dev\boost-1.54-rev83369-vc100-x86-09.03.2013 -D CMAKE_USE_RELATIVE_PATHS:BOOL=ON -G "Visual Studio 10" C:\dev\ogitor
  7. Build Ogitor by opening the Visual Studio Solution or by command line

    Code: Select all

    devenv Ogitor.sln /build "Release|Win32" /Project ALL_BUILD
  8. Build the INSTALL project in the Visual Studio Solution or by command line

    Code: Select all

    devenv Ogitor.sln /build "Release|Win32" /Project INSTALL
  9. Depending on your Ogre version and Ogitor source revision you may have to modify plugins.cfg/resources.cfg

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Can't compile ogitor editor

Post by jacmoe »

About Boost: what I usually do is to grab the precompiled package from Boost-pro and then copy the lib over to the Ogre SDK directory, and the header file(s). Boost regex, that is. It's hacky, but works.
Just an alternative way of dealing with Boost.
I mean: since Ogre needs Boost, and Ogitor needs Ogre, ...
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

Transporter
Minaton
Posts: 933
Joined: Mon Mar 05, 2012 11:37 am
Location: Germany
x 110

Re: Can't compile ogitor editor

Post by Transporter »

jacmoe wrote:I mean: since Ogre needs Boost, and Ogitor needs Ogre, ...
Ogitor doesn't need Boost except of ogre? I've looked at an old version of CMakeList.txt and there is boost regex required which is not required by Ogre. I mean if there is no regex required, I'll remove the regex stuff from CMakeList.txt. At the moment it's: Ogre needs Boost, Ogitor needs Ogre, Ogitor need Boost ...

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Can't compile ogitor editor

Post by jacmoe »

Ogitor wants regex in addition to the stuff that Ogre wants. I just explained why I usually just copy and dump the lib and includes into the Boost directory in the Ogre sdk. :)
Sorry for sounding obtuse. :p
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

Post Reply