Ogre Wiki Missing Links

Anything and everything that's related to OGRE or the wider graphics field that doesn't fit into the other forums.
Post Reply
zgrapher
Gnoblar
Posts: 1
Joined: Sat Jun 30, 2012 7:58 am

Re: Ogre Wiki Missing Links

Post by zgrapher »


User avatar
Mind Calamity
Ogre Magi
Posts: 1255
Joined: Sat Dec 25, 2010 2:55 pm
Location: Macedonia
x 81

Re: Ogre Wiki Missing Links

Post by Mind Calamity »

That's here: http://www.ogre3d.org/tikiwiki/tiki-ind ... e=Cookbook

I think that SEO URLs don't work after the server move.
BitBucket username changed to iboshkov (from MindCalamity)
Do you need help? What have you tried?
- xavier
---------------------
HkOgre - a Havok Integration for OGRE | Simple SSAO | My Blog | My YouTube | My DeviantArt

magicaxis
Gnoblar
Posts: 15
Joined: Fri Jun 29, 2012 6:48 am
x 2

Re: Ogre Wiki Missing Links

Post by magicaxis »


User avatar
duststorm
Minaton
Posts: 921
Joined: Sat Jul 31, 2010 6:29 pm
Location: Belgium
x 80
Contact:

Re: Ogre Wiki Missing Links

Post by duststorm »

I noticed that on the wiki there are still some pages that refer to old forum urls (http://www.ogre3d.org/phpBB2/)
Would it be possible to mass replace those with http://www.ogre3d.org/forums/?
Developer @ MakeHuman.org

User avatar
Mind Calamity
Ogre Magi
Posts: 1255
Joined: Sat Dec 25, 2010 2:55 pm
Location: Macedonia
x 81

Re: Ogre Wiki Missing Links

Post by Mind Calamity »

duststorm wrote:I noticed that on the wiki there are still some pages that refer to old forum urls (http://www.ogre3d.org/phpBB2/)
Would it be possible to mass replace those with http://www.ogre3d.org/forums/?
I thought about that too, but what I think would be better is create a directory phpBB2 on the server, and make a redirection script for viewforum/viewtopic.php and pass the IDs to the actual view scripts. Because the problem is not just the wiki, it's the forums, and external sites that Google finds.

Also, by the time I created a wiki page I realized that it wasn't in the category I wanted, and the time that it would take me to move it to the correct category is way too long (Tiki's category selection method sucks!), so I created a new page, therefore I would like that some of the moderators delete this page: http://www.ogre3d.org/tikiwiki/tiki-ind ... r+with+OIS
BitBucket username changed to iboshkov (from MindCalamity)
Do you need help? What have you tried?
- xavier
---------------------
HkOgre - a Havok Integration for OGRE | Simple SSAO | My Blog | My YouTube | My DeviantArt

User avatar
duststorm
Minaton
Posts: 921
Joined: Sat Jul 31, 2010 6:29 pm
Location: Belgium
x 80
Contact:

Re: Ogre Wiki Missing Links

Post by duststorm »

Mind Calamity wrote:what I think would be better is create a directory phpBB2 on the server, and make a redirection script for viewforum/viewtopic.php
Good point. This will also solve the problem of forum links, links from external sites and some google results. As there are quite a few links that still point to the phpBB2 folder.

There's also an issue with some urls pointing to an ip address (89.151.96.106). I assume that is the IP of the old server, as it gives a "server move in progress" message. If that is indeed the IP of the old server than it would be a little more difficult to solve that one ;).
I wonder why people link to an IP address in the first place.
Developer @ MakeHuman.org

Pork Chop
Gnoblar
Posts: 3
Joined: Fri Aug 28, 2009 5:40 pm

Re: Ogre Wiki Missing Links

Post by Pork Chop »

Looking for
A Series Of Tubes&structure=Cookbook

http://www.ogre3d.org/tikiwiki/A+Series ... #Tubes.cpp

User avatar
duststorm
Minaton
Posts: 921
Joined: Sat Jul 31, 2010 6:29 pm
Location: Belgium
x 80
Contact:

Re: Ogre Wiki Missing Links

Post by duststorm »

Pork Chop wrote:Looking for "A Series Of Tubes"
Here you are: http://www.ogre3d.org/tikiwiki/A+Series+Of+Tubes

With all those not-working wiki links: remove the "&structure..." part (maybe also a suggestion of something to fix)
Developer @ MakeHuman.org

User avatar
Mind Calamity
Ogre Magi
Posts: 1255
Joined: Sat Dec 25, 2010 2:55 pm
Location: Macedonia
x 81

Re: Ogre Wiki Missing Links

Post by Mind Calamity »

OK, since the fancy links are disabled, URLs like this:

Code: Select all

http://www.ogre3d.org/tikiwiki/A+Series+Of+Tubes&structure=Cookbook#Tubes.cpp
will not work. To fix that, copy the part after /tikiwiki/ (for this example it's: "A+Series+Of+Tubes&structure=Cookbook#Tubes.cpp")

Then add it to this:

Code: Select all

http://www.ogre3d.org/tikiwiki/tiki-index.php?page=
So for this example, you'd get:

Code: Select all

http://www.ogre3d.org/tikiwiki/tiki-index.php?page=A+Series+Of+Tubes&structure=Cookbook#Tubes.cpp
And it will work.
----------------------------------------
Anyway... Jacmoe, why not just simply enable the fancy links again ? Or do the hackish approach and just make the .htaccess redirect people to the proper URLs.
BitBucket username changed to iboshkov (from MindCalamity)
Do you need help? What have you tried?
- xavier
---------------------
HkOgre - a Havok Integration for OGRE | Simple SSAO | My Blog | My YouTube | My DeviantArt

CABAListic
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 2903
Joined: Thu Jan 18, 2007 2:48 pm
x 57
Contact:

Re: Ogre Wiki Missing Links

Post by CABAListic »

Because we are no longer powered by Apache, and nginx will not forward the URLs like that because it considers + in the URL as illegal characters (which is correct, far as I understand).

User avatar
Mind Calamity
Ogre Magi
Posts: 1255
Joined: Sat Dec 25, 2010 2:55 pm
Location: Macedonia
x 81

Re: Ogre Wiki Missing Links

Post by Mind Calamity »

I see, I appreciate the explanation. So there's no way to do any forwarding on the current server ?
BitBucket username changed to iboshkov (from MindCalamity)
Do you need help? What have you tried?
- xavier
---------------------
HkOgre - a Havok Integration for OGRE | Simple SSAO | My Blog | My YouTube | My DeviantArt

CABAListic
OGRE Retired Team Member
OGRE Retired Team Member
Posts: 2903
Joined: Thu Jan 18, 2007 2:48 pm
x 57
Contact:

Re: Ogre Wiki Missing Links

Post by CABAListic »

If there is, we haven't found it. As I said, the nginx equivalent to mod-rewrite can't deal with these URLs due to tikiwiki using + as a word separator, which is illegal and confuses nginx.

The only other solution I see is a hack of the following form:
- Rename the tikiwiki folder.
- Place a PHP script by the name of tikiwiki (no ending) and tell nginx to treat it as a PHP script, if possible.
- The script might then be able to interpret the rest of the URL and forward it to the tiki installation.

No idea if this could even work, but that's the only thing I see. Everything else has been tried, I think.

Werner291
Kobold
Posts: 27
Joined: Sun Jun 10, 2012 9:23 pm

Re: Ogre Wiki Missing Links

Post by Werner291 »


drwbns
Orc Shaman
Posts: 777
Joined: Mon Jan 18, 2010 6:06 pm
Location: Costa Mesa, California
x 23

Re: Ogre Wiki Missing Links

Post by drwbns »

Bad link here ( bottom of post ) http://www.ogre3d.org/forums/viewtopic. ... 99#p442823 We should have a little button next to each link to report it as invalid. I think that would help...

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4293
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 127
Contact:

Re: Ogre Wiki Missing Links

Post by spacegaier »

drwbns wrote:Bad link here ( bottom of post ) http://www.ogre3d.org/forums/viewtopic. ... 99#p442823 We should have a little button next to each link to report it as invalid. I think that would help...
Fixed (not a wiki issue, but a bad link in the thread).
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

User avatar
spacegaier
OGRE Team Member
OGRE Team Member
Posts: 4293
Joined: Mon Feb 04, 2008 2:02 pm
Location: Germany
x 127
Contact:

Re: Ogre Wiki Missing Links

Post by spacegaier »

Werner291 wrote:Broken link to "normals" here.
http://www.ogre3d.org/tikiwiki/tiki-ind ... s#Lighting
Fixed as well.
Ogre Admin [Admin, Dev, PR, Finance, Wiki, etc.] | BasicOgreFramework | AdvancedOgreFramework
Don't know what to do in your spare time? Help the Ogre wiki grow! Or squash a bug...

teseien
Kobold
Posts: 25
Joined: Mon Feb 04, 2013 7:27 pm

Re: Ogre Wiki Missing Links

Post by teseien »


drwbns
Orc Shaman
Posts: 777
Joined: Mon Jan 18, 2010 6:06 pm
Location: Costa Mesa, California
x 23

Re: Ogre Wiki Missing Links

Post by drwbns »

Post where you found the link

User avatar
Mind Calamity
Ogre Magi
Posts: 1255
Joined: Sat Dec 25, 2010 2:55 pm
Location: Macedonia
x 81

Re: Ogre Wiki Missing Links

Post by Mind Calamity »

teseien wrote:this link doesn't work...

http://www.ogre3d.org/tikiwiki/JaJDoo+S ... e=Cookbook
Not sure where you found it, but this works:

http://www.ogre3d.org/tikiwiki/tiki-ind ... e=Cookbook

Don't know how to fix it, though.
BitBucket username changed to iboshkov (from MindCalamity)
Do you need help? What have you tried?
- xavier
---------------------
HkOgre - a Havok Integration for OGRE | Simple SSAO | My Blog | My YouTube | My DeviantArt

peterlee
Gnoblar
Posts: 1
Joined: Tue Apr 09, 2013 11:01 am

Re: Ogre Wiki Missing Links

Post by peterlee »

http://www.ogre3d.org/tikiwiki/Particle ... ture=Tools the link is missing ..i cant download the particle accelerator..

User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Ogre Wiki Missing Links

Post by jacmoe »

As have been said before, remove &structure=Tools.
This is a bug related to Tiki and Nginx.
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

praveencastelino
Gnoblar
Posts: 1
Joined: Mon Apr 15, 2013 8:21 am

Re: Ogre Wiki Missing Links

Post by praveencastelino »


User avatar
jacmoe
OGRE Retired Moderator
OGRE Retired Moderator
Posts: 20570
Joined: Thu Jan 22, 2004 10:13 am
Location: Denmark
x 179
Contact:

Re: Ogre Wiki Missing Links

Post by jacmoe »

Just remove the &blah=blah part of the URL.

Would be a good idea if Nginx could ignore it automatically.
Any experts?
/* Less noise. More signal. */
Ogitor Scenebuilder - powered by Ogre, presented by Qt, fueled by Passion.
OgreAddons - the Ogre code suppository.

shanefarris
Greenskin
Posts: 107
Joined: Sun Mar 01, 2009 8:36 pm
x 7

Re: Ogre Wiki Missing Links

Post by shanefarris »

Almost all the links under "Shader" is bad in this wiki: http://www.ogre3d.org/tikiwiki/tiki-ind ... es#Shaders

humus Dx and GL source code shaders
Delphi shaders demo, but shaders are language independent
shaders competition source
shaders competition source
Shadertech.com (I think this is some kind of Japanese sex education site)

shanefarris
Greenskin
Posts: 107
Joined: Sun Mar 01, 2009 8:36 pm
x 7

Re: Ogre Wiki Missing Links

Post by shanefarris »

All of these tutorials point to empty wikis.
http://www.ogre3d.org/tikiwiki/tiki-ind ... =Tutorials

Post Reply