Building Ogre-Assimp

A place for users of OGRE to discuss ideas and experiences of utilitising OGRE in their games / demos / applications.
Post Reply
Owl53
Halfling
Posts: 89
Joined: Sat Jul 22, 2017 2:32 pm
x 4

Building Ogre-Assimp

Post by Owl53 » Thu Oct 04, 2018 10:05 am

Hi,

I have built Ogre 1.11 using cmake-gui previously, and have been using it successfully. I have very limited experience of using cmake-gui however, and have run into the following error when trying to build ogre-assimp:

Code: Select all

By not providing "FindOGRE.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "OGRE", but
  CMake did not find one.

  Could not find a package configuration file provided by "OGRE" (requested
  version 1.10) with any of the following names:

    OGREConfig.cmake
    ogre-config.cmake

  Add the installation prefix of "OGRE" to CMAKE_PREFIX_PATH or set
  "OGRE_DIR" to a directory containing one of the above files.  If "OGRE"
  provides a separate development package or SDK, be sure it has been
  installed.
I realise this means that I need to provide a version of ogre for cmake to use, but I don't know how to go about this. Upon researching this issue, I found this suggestion: viewtopic.php?f=11&t=65993&start=75 , but I don't actually know how I'd go about implementing this using the gui, so any advice on how to accomplish this would be welcome.

Thanks.

paroj
OGRE Team Member
OGRE Team Member
Posts: 956
Joined: Sun Mar 30, 2014 2:51 pm
x 278
Contact:

Re: Building Ogre-Assimp

Post by paroj » Thu Oct 04, 2018 10:37 am

as the error message suggests you have to set OGRE_DIR (in cmake-gui) to the location of OGREConfig.cmake (inside the ogre install directory).

Owl53
Halfling
Posts: 89
Joined: Sat Jul 22, 2017 2:32 pm
x 4

Re: Building Ogre-Assimp

Post by Owl53 » Thu Oct 04, 2018 10:46 am

paroj wrote:
Thu Oct 04, 2018 10:37 am
as the error message suggests you have to set OGRE_DIR (in cmake-gui) to the location of OGREConfig.cmake (inside the ogre install directory).
I understood the issue, but it was the how to do that was puzzling me, I had never edited entries in the gui before. After reading your message I've set OGRE_DIR now and resolved the error.

Thanks for the help. :)

Owl53
Halfling
Posts: 89
Joined: Sat Jul 22, 2017 2:32 pm
x 4

Re: Building Ogre-Assimp

Post by Owl53 » Thu Oct 04, 2018 11:33 am

Sorry for the further questions. After getting past that error, cmake now comes up with this...

Code: Select all

CMake Error at C:/[Username]/cmake/OGREConfig.cmake:91 (include):
include could not find load file:

C:/[Username]/cmake/OgreTargets.cmake
Call Stack (most recent call first):
CMakeLists.txt:53 (find_package)
There is no clear place that I can set the directory for this file, so I don't really know how to proceed from here.

paroj
OGRE Team Member
OGRE Team Member
Posts: 956
Joined: Sun Mar 30, 2014 2:51 pm
x 278
Contact:

Re: Building Ogre-Assimp

Post by paroj » Thu Oct 04, 2018 2:00 pm

it seems that you specified the wrong location. You have to install ogre and the path should look like sdk/CMake and contain OGREConfig.cmake as well as OgreTargets.cmake. (cf. prebuild sdk).

Unfortunately you stripped too much of the path by [Username] to verify.

Owl53
Halfling
Posts: 89
Joined: Sat Jul 22, 2017 2:32 pm
x 4

Re: Building Ogre-Assimp

Post by Owl53 » Thu Oct 04, 2018 4:09 pm

paroj wrote:
Thu Oct 04, 2018 2:00 pm
it seems that you specified the wrong location. You have to install ogre and the path should look like sdk/CMake and contain OGREConfig.cmake as well as OgreTargets.cmake. (cf. prebuild sdk).

Unfortunately you stripped too much of the path by [Username] to verify.
After looking at the link you posted, I noticed my mistake with why files weren't where they should be, I hadn't done the install step after building in VS. So I then rebuilt Ogre with that additional step afterwards, and am now able to build Ogre-Assimp too as it can find everything it needs.

Thanks for your help! :)

Post Reply